aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2013-06-10 16:20:15 +0800
committerrm <rm@FreeBSD.org>2013-06-10 16:20:15 +0800
commit4caa98baf637922ed6cc5745c80b4520d83f8316 (patch)
tree7af12785fd9e7ecfe6be72b2bdedd985eef9e30a /lang
parentd8b19477cc784d83397d26d071ba37d01f6a77a8 (diff)
downloadfreebsd-ports-gnome-4caa98baf637922ed6cc5745c80b4520d83f8316.tar.gz
freebsd-ports-gnome-4caa98baf637922ed6cc5745c80b4520d83f8316.tar.zst
freebsd-ports-gnome-4caa98baf637922ed6cc5745c80b4520d83f8316.zip
Add patch that resolves the issue, found after r250991 in src HEAD.
Investigation and the patch are from Marcel Moolenaar. I also added upstream bug-report, based on Marcel's info: http://bugs.python.org/issue18178 There also was relevant discussion on current@: http://lists.freebsd.org/pipermail/freebsd-current/2013-June/ Please see there for details of the issue. Submitted by: marcel (python@ ML) Reported by: many
Diffstat (limited to 'lang')
-rw-r--r--lang/python27/Makefile1
-rw-r--r--lang/python27/files/patch-Modules-_ctypes-libffi_fficonfig.py.in10
-rw-r--r--lang/python32/Makefile1
-rw-r--r--lang/python32/files/patch-Modules-_ctypes-libffi_fficonfig.py.in10
-rw-r--r--lang/python33/Makefile1
-rw-r--r--lang/python33/files/patch-Modules-_ctypes-libffi_fficonfig.py.in10
6 files changed, 33 insertions, 0 deletions
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index 329021cf304e..003dd8a2a431 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -3,6 +3,7 @@
PORTNAME= python27
PORTVERSION= 2.7.5
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
diff --git a/lang/python27/files/patch-Modules-_ctypes-libffi_fficonfig.py.in b/lang/python27/files/patch-Modules-_ctypes-libffi_fficonfig.py.in
new file mode 100644
index 000000000000..a2675bb94dfa
--- /dev/null
+++ b/lang/python27/files/patch-Modules-_ctypes-libffi_fficonfig.py.in
@@ -0,0 +1,10 @@
+--- ./Modules/_ctypes/libffi/fficonfig.py.in.orig 2013-05-12 07:32:49.000000000 +0400
++++ ./Modules/_ctypes/libffi/fficonfig.py.in 2013-06-05 10:36:24.000000000 +0400
+@@ -1,7 +1,6 @@
+ ffi_sources = """
+ src/prep_cif.c
+ src/closures.c
+-src/dlmalloc.c
+ """.split()
+
+ ffi_platforms = {
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index ece165c57513..8fa5ea0ac1f6 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -2,6 +2,7 @@
PORTNAME= python32
PORTVERSION= 3.2.5
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
diff --git a/lang/python32/files/patch-Modules-_ctypes-libffi_fficonfig.py.in b/lang/python32/files/patch-Modules-_ctypes-libffi_fficonfig.py.in
new file mode 100644
index 000000000000..a2675bb94dfa
--- /dev/null
+++ b/lang/python32/files/patch-Modules-_ctypes-libffi_fficonfig.py.in
@@ -0,0 +1,10 @@
+--- ./Modules/_ctypes/libffi/fficonfig.py.in.orig 2013-05-12 07:32:49.000000000 +0400
++++ ./Modules/_ctypes/libffi/fficonfig.py.in 2013-06-05 10:36:24.000000000 +0400
+@@ -1,7 +1,6 @@
+ ffi_sources = """
+ src/prep_cif.c
+ src/closures.c
+-src/dlmalloc.c
+ """.split()
+
+ ffi_platforms = {
diff --git a/lang/python33/Makefile b/lang/python33/Makefile
index 8bd1aac55422..769f66d37d53 100644
--- a/lang/python33/Makefile
+++ b/lang/python33/Makefile
@@ -2,6 +2,7 @@
PORTNAME= python33
PORTVERSION= 3.3.2
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
diff --git a/lang/python33/files/patch-Modules-_ctypes-libffi_fficonfig.py.in b/lang/python33/files/patch-Modules-_ctypes-libffi_fficonfig.py.in
new file mode 100644
index 000000000000..a2675bb94dfa
--- /dev/null
+++ b/lang/python33/files/patch-Modules-_ctypes-libffi_fficonfig.py.in
@@ -0,0 +1,10 @@
+--- ./Modules/_ctypes/libffi/fficonfig.py.in.orig 2013-05-12 07:32:49.000000000 +0400
++++ ./Modules/_ctypes/libffi/fficonfig.py.in 2013-06-05 10:36:24.000000000 +0400
+@@ -1,7 +1,6 @@
+ ffi_sources = """
+ src/prep_cif.c
+ src/closures.c
+-src/dlmalloc.c
+ """.split()
+
+ ffi_platforms = {