aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2017-02-01 19:33:21 +0800
committerolgeni <olgeni@FreeBSD.org>2017-02-01 19:33:21 +0800
commit4ce486eeedce1405a196c39f16ce03f2a1a03741 (patch)
treef16cb09f22609280924d0fbc389925b6532ebebc /lang
parent0ed562a4d6c22ddc3e3dff3e3b37dd9977ba1209 (diff)
downloadfreebsd-ports-gnome-4ce486eeedce1405a196c39f16ce03f2a1a03741.tar.gz
freebsd-ports-gnome-4ce486eeedce1405a196c39f16ce03f2a1a03741.tar.zst
freebsd-ports-gnome-4ce486eeedce1405a196c39f16ce03f2a1a03741.zip
lang/erlang-runtime18: fix build with clang 4.0.
PR: 216615 Submitted by: Jan Beich
Diffstat (limited to 'lang')
-rw-r--r--lang/erlang-runtime18/Makefile2
-rw-r--r--lang/erlang-runtime18/files/patch-lib_wx_c__src_wxe__impl.cpp20
2 files changed, 21 insertions, 1 deletions
diff --git a/lang/erlang-runtime18/Makefile b/lang/erlang-runtime18/Makefile
index 5b00d6a445ba..8316a377cdce 100644
--- a/lang/erlang-runtime18/Makefile
+++ b/lang/erlang-runtime18/Makefile
@@ -3,7 +3,7 @@
PORTNAME= erlang
PORTVERSION= 18.3.4.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang parallel java
MASTER_SITES= http://www.erlang.org/download/:erlangorg \
http://erlang.stacken.kth.se/download/:erlangorg \
diff --git a/lang/erlang-runtime18/files/patch-lib_wx_c__src_wxe__impl.cpp b/lang/erlang-runtime18/files/patch-lib_wx_c__src_wxe__impl.cpp
new file mode 100644
index 000000000000..5b1e66586f2f
--- /dev/null
+++ b/lang/erlang-runtime18/files/patch-lib_wx_c__src_wxe__impl.cpp
@@ -0,0 +1,20 @@
+--- lib/wx/c_src/wxe_impl.cpp.orig 2017-01-30 23:13:25 UTC
++++ lib/wx/c_src/wxe_impl.cpp
+@@ -666,7 +666,7 @@ void * WxeApp::getPtr(char * bp, wxeMemE
+ throw wxe_badarg(index);
+ }
+ void * temp = memenv->ref2ptr[index];
+- if((index < memenv->next) && ((index == 0) || (temp > NULL)))
++ if((index < memenv->next) && ((index == 0) || (temp != NULL)))
+ return temp;
+ else {
+ throw wxe_badarg(index);
+@@ -678,7 +678,7 @@ void WxeApp::registerPid(char * bp, ErlD
+ if(!memenv)
+ throw wxe_badarg(index);
+ void * temp = memenv->ref2ptr[index];
+- if((index < memenv->next) && ((index == 0) || (temp > NULL))) {
++ if((index < memenv->next) && ((index == 0) || (temp != NULL))) {
+ ptrMap::iterator it;
+ it = ptr2ref.find(temp);
+ if(it != ptr2ref.end()) {