aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-08-09 22:29:13 +0800
committermat <mat@FreeBSD.org>2016-08-09 22:29:13 +0800
commit5fe135fdd007c887ff1b28d0bb9450e63eebbdd7 (patch)
tree7978cfb28e8a9f1e503f75b907454a636a3460ac /lang
parent4d3be255a9fcd2ba023d1f156e84e70b84e3c5f8 (diff)
downloadfreebsd-ports-gnome-5fe135fdd007c887ff1b28d0bb9450e63eebbdd7.tar.gz
freebsd-ports-gnome-5fe135fdd007c887ff1b28d0bb9450e63eebbdd7.tar.zst
freebsd-ports-gnome-5fe135fdd007c887ff1b28d0bb9450e63eebbdd7.zip
Change www/php*-session's priority to be loaded before most other PHP extensions.
Many PHP extensions were adding a build dependency on session, so that it was loaded first. This is now no longer needed, we have a nice framework handle the extensions ordering. PR: 203741 Sponsored by: Absolight
Diffstat (limited to 'lang')
-rw-r--r--lang/php55/Makefile.ext6
-rw-r--r--lang/php56/Makefile.ext6
-rw-r--r--lang/php70/Makefile.ext6
3 files changed, 3 insertions, 15 deletions
diff --git a/lang/php55/Makefile.ext b/lang/php55/Makefile.ext
index b834be078ef6..0087da08853b 100644
--- a/lang/php55/Makefile.ext
+++ b/lang/php55/Makefile.ext
@@ -300,9 +300,6 @@ CONFIGURE_ARGS+=--enable-posix
LIB_DEPENDS+= libaspell.so:textproc/aspell
CONFIGURE_ARGS+=--with-pspell=${LOCALBASE}
-
-# Ugly hack to load session before psell to avoid crashes
-USE_PHP= session:build
.endif
.if ${PHP_MODNAME} == "readline"
@@ -318,6 +315,7 @@ CONFIGURE_ARGS+=--with-recode=${LOCALBASE}
.if ${PHP_MODNAME} == "session"
CONFIGURE_ARGS+=--enable-session
+PHP_MOD_PRIO= 18
.endif
.if ${PHP_MODNAME} == "shmop"
@@ -349,8 +347,6 @@ CONFIGURE_ARGS+=--enable-soap \
--with-libxml-dir=${LOCALBASE}
USE_GNOME= libxml2
-
-USE_PHP= session:build
.endif
.if ${PHP_MODNAME} == "sockets"
diff --git a/lang/php56/Makefile.ext b/lang/php56/Makefile.ext
index 266b508ef208..9957c30b7fbc 100644
--- a/lang/php56/Makefile.ext
+++ b/lang/php56/Makefile.ext
@@ -300,9 +300,6 @@ CONFIGURE_ARGS+=--enable-posix
LIB_DEPENDS+= libaspell.so:textproc/aspell
CONFIGURE_ARGS+=--with-pspell=${LOCALBASE}
-
-# Ugly hack to load session before psell to avoid crashes
-USE_PHP= session:build
.endif
.if ${PHP_MODNAME} == "readline"
@@ -318,6 +315,7 @@ CONFIGURE_ARGS+=--with-recode=${LOCALBASE}
.if ${PHP_MODNAME} == "session"
CONFIGURE_ARGS+=--enable-session
+PHP_MOD_PRIO= 18
.endif
.if ${PHP_MODNAME} == "shmop"
@@ -349,8 +347,6 @@ CONFIGURE_ARGS+=--enable-soap \
--with-libxml-dir=${LOCALBASE}
USE_GNOME= libxml2
-
-USE_PHP= session:build
.endif
.if ${PHP_MODNAME} == "sockets"
diff --git a/lang/php70/Makefile.ext b/lang/php70/Makefile.ext
index 51182856614e..3104bd2696e9 100644
--- a/lang/php70/Makefile.ext
+++ b/lang/php70/Makefile.ext
@@ -292,9 +292,6 @@ CONFIGURE_ARGS+=--enable-posix
LIB_DEPENDS+= libaspell.so:textproc/aspell
CONFIGURE_ARGS+=--with-pspell=${LOCALBASE}
-
-# Ugly hack to load session before psell to avoid crashes
-USE_PHP= session:build
.endif
.if ${PHP_MODNAME} == "readline"
@@ -310,6 +307,7 @@ CONFIGURE_ARGS+=--with-recode=${LOCALBASE}
.if ${PHP_MODNAME} == "session"
CONFIGURE_ARGS+=--enable-session
+PHP_MOD_PRIO= 18
.endif
.if ${PHP_MODNAME} == "shmop"
@@ -341,8 +339,6 @@ CONFIGURE_ARGS+=--enable-soap \
--with-libxml-dir=${LOCALBASE}
USE_GNOME= libxml2
-
-USE_PHP= session:build
.endif
.if ${PHP_MODNAME} == "sockets"