aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2003-07-31 15:57:01 +0800
committernork <nork@FreeBSD.org>2003-07-31 15:57:01 +0800
commit65817201fb40990de723e20fcb0fb755498af375 (patch)
tree6987403c8de6ce77c0f37a1b20918088b6dfd658 /lang
parent427877706ca37e143fe399e2bc3eee5b3ef17a85 (diff)
downloadfreebsd-ports-gnome-65817201fb40990de723e20fcb0fb755498af375.tar.gz
freebsd-ports-gnome-65817201fb40990de723e20fcb0fb755498af375.tar.zst
freebsd-ports-gnome-65817201fb40990de723e20fcb0fb755498af375.zip
o Update to 4.3.3RC2.
o Add identification to php4 configuration dialog [1]. o Fix incorrect detecting of OpenLDAP dependency [2]. PR: ports/55100, ports/54283[1], ports/54726[2] Submitted by: Alex Dupre <sysadmin@alexdupre.com> (maintainer) Mark Linimon <linimon@lonesome.com> [1] Jens Rehsack <rehsack@liwing.de> [2]
Diffstat (limited to 'lang')
-rw-r--r--lang/php4/Makefile17
-rw-r--r--lang/php4/distinfo2
-rw-r--r--lang/php4/files/patch-configure130
-rw-r--r--lang/php4/pkg-plist1
-rw-r--r--lang/php4/scripts/configure.php2
5 files changed, 118 insertions, 34 deletions
diff --git a/lang/php4/Makefile b/lang/php4/Makefile
index b3693984520d..99e2b4b1bf36 100644
--- a/lang/php4/Makefile
+++ b/lang/php4/Makefile
@@ -20,8 +20,8 @@
#
PORTNAME= php4
-PORTVERSION= 4.3.3.r1
-PORTREVISION= 1
+PORTVERSION= 4.3.3.r2
+PORTREVISION= 0
CATEGORIES?= lang devel www
MASTER_SITES= http://www.php.net/distributions/ \
http://it.php.net/distributions/ \
@@ -98,6 +98,7 @@ CONFLICTS= php4-4* php4-cgi-4* mod_php4-4*
CONFLICTS= php4-4* php4-cli-4* php4-cgi-4*
.endif
.endif
+CONFLICTS+= php5-5* php5-cli-5* mod_php5-5* php5-cgi-5*
.if defined(WITHOUT_APACHE)
CONFIGURE_ARGS+=--enable-discard-path
@@ -411,13 +412,11 @@ CONFIGURE_ARGS+=--with-ming=${LOCALBASE}
.if defined(WITH_MYSQL)
.if exists(${LOCALBASE}/lib/mysql/libmysqlclient.so.10)
LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
-.else
-.if exists(${LOCALBASE}/lib/mysql/libmysqlclient.so.14)
+.elif exists(${LOCALBASE}/lib/mysql/libmysqlclient.so.14)
LIB_DEPENDS+= mysqlclient.14:${PORTSDIR}/databases/mysql41-client
.else
LIB_DEPENDS+= mysqlclient.12:${PORTSDIR}/databases/mysql40-client
.endif
-.endif
CONFIGURE_ARGS+=--with-mysql=${LOCALBASE}
.endif
@@ -434,8 +433,14 @@ CONFIGURE_ARGS+=--with-ncurses=${NCURSESBASE}
.if defined(WITH_OPENLDAP)
.if exists(${LOCALBASE}/lib/libldap.so.1)
LIB_DEPENDS+= ldap.1:${PORTSDIR}/net/openldap12
-.else
+.elif exists(${LOCALBASE}/lib/libldap.la)
+.if exists(${LOCALBASE}/bin/ldapwhoami)
LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap21
+.else
+LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap20
+.endif
+.else
+LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap22
.endif
CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}
.endif
diff --git a/lang/php4/distinfo b/lang/php4/distinfo
index b364404c5a36..0ef7e51f748d 100644
--- a/lang/php4/distinfo
+++ b/lang/php4/distinfo
@@ -1 +1 @@
-MD5 (php-4.3.3RC1.tar.bz2) = 2b3b4866bedd073d505c554c551fef92
+MD5 (php-4.3.3RC2.tar.bz2) = bc8cda0bd523c653d0900a460117c2af
diff --git a/lang/php4/files/patch-configure b/lang/php4/files/patch-configure
index 9a84d05c3f1c..20e1bccefbd6 100644
--- a/lang/php4/files/patch-configure
+++ b/lang/php4/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Thu Jun 19 00:06:29 2003
-+++ configure Sat Jun 28 16:45:44 2003
-@@ -597,6 +597,8 @@
+--- configure.orig Thu Jul 31 00:51:41 2003
++++ configure Thu Jul 31 08:56:35 2003
+@@ -616,6 +616,8 @@
ac_help="$ac_help
--enable-gd-jis-conv GD: Enable JIS-mapped Japanese font support."
ac_help="$ac_help
@@ -9,7 +9,7 @@
--with-gettext[=DIR] Include GNU gettext support."
ac_help="$ac_help
--with-gmp Include GNU MP support"
-@@ -28224,6 +28226,31 @@
+@@ -29141,6 +29143,31 @@
@@ -41,7 +41,7 @@
-@@ -28248,7 +28275,7 @@
+@@ -29293,7 +29320,7 @@
libgd/gd_io_file.c libgd/gd_ss.c libgd/gd_io_ss.c libgd/gd_png.c libgd/gd_jpeg.c \
libgd/gdxpm.c libgd/gdfontt.c libgd/gdfonts.c libgd/gdfontmb.c libgd/gdfontl.c \
libgd/gdfontg.c libgd/gdtables.c libgd/gdft.c libgd/gdcache.c libgd/gdkanji.c \
@@ -50,7 +50,7 @@
libgd/xbm.c"
for ac_func in fabsf floorf
-@@ -28323,6 +28350,11 @@
+@@ -29368,6 +29395,11 @@
fi
@@ -62,7 +62,7 @@
if test "$PHP_JPEG_DIR" != "no"; then
for i in /usr /usr/local $PHP_JPEG_DIR; do
-@@ -29724,6 +29756,9 @@
+@@ -31077,6 +31109,9 @@
cat >> confdefs.h <<\EOF
#define HAVE_GD_BUNDLED 1
@@ -72,7 +72,7 @@
EOF
cat >> confdefs.h <<\EOF
-@@ -29774,6 +29809,14 @@
+@@ -31127,6 +31162,14 @@
GDLIB_CFLAGS="$GDLIB_CFLAGS -DJISX0208"
fi
@@ -87,10 +87,10 @@
else
if test "$PHP_GD" != "no"; then
-@@ -32275,6 +32318,60 @@
-
- save_old_LDFLAGS=$LDFLAGS
- LDFLAGS=" -L$GD_LIB $GD_SHARED_LIBADD $LDFLAGS"
+@@ -35474,6 +35517,137 @@
+ esac
+ done
+
+ echo $ac_n "checking for gdImageGifAnimBegin in -lgd""... $ac_c" 1>&6
+echo "configure:32250: checking for gdImageGifAnimBegin in -lgd" >&5
+ac_lib_var=`echo gd'_'gdImageGifAnimBegin | sed 'y%./+-%__p_%'`
@@ -126,32 +126,109 @@
+fi
+if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
+ echo "$ac_t""yes" 1>&6
-+
++
+ LDFLAGS=$save_old_LDFLAGS
++ ext_shared=$save_ext_shared
+ cat >> confdefs.h <<\EOF
+#define HAVE_GD_GIF_ANIM 1
+EOF
+
-+
++
+else
+ echo "$ac_t""no" 1>&6
+
+ LDFLAGS=$save_old_LDFLAGS
++ ext_shared=$save_ext_shared
+ unset ac_cv_func_gd
-+
-+
++
++
+fi
+
-+
++
+ save_old_LDFLAGS=$LDFLAGS
-+ LDFLAGS=" -L$GD_LIB $GD_SHARED_LIBADD $LDFLAGS"
++ ac_stuff=" -L$GD_LIB $GD_SHARED_LIBADD "
++
++ save_ext_shared=$ext_shared
++ ext_shared=yes
++
++ for ac_i in $ac_stuff; do
++ case $ac_i in
++ -l*)
++ ac_ii=`echo $ac_i|cut -c 3-`
++
++
++ case $ac_ii in
++ c|c_r|pthread*) ;;
++ *)
++ if test "$ext_shared" = "yes"; then
++ LDFLAGS="$LDFLAGS -l$ac_ii"
++ else
++
++
++ case $ac_ii in
++ c|c_r|pthread*) ;;
++ *)
++ LIBS="$LIBS -l$ac_ii"
++ ;;
++ esac
++
++
++ fi
++ ;;
++ esac
++
++
++ ;;
++ -L*)
++ ac_ii=`echo $ac_i|cut -c 3-`
++
++ if test "$ac_ii" != "/usr/lib"; then
++
++ if test -z "$ac_ii" || echo "$ac_ii" | grep '^/' >/dev/null ; then
++ ai_p=$ac_ii
++ else
++
++ ep_dir="`echo $ac_ii|sed 's%/*[^/][^/]*/*$%%'`"
++
++ ep_realdir="`(cd \"$ep_dir\" && pwd)`"
++ ai_p="$ep_realdir/`basename \"$ac_ii\"`"
++ fi
++
++
++ if test "$ext_shared" = "yes"; then
++ LDFLAGS="$ld_runpath_switch$ai_p -L$ai_p $LDFLAGS"
++ else
++
++
++
++ unique=`echo $ai_p|sed 's/[^a-zA-Z0-9]/_/g'`
++
++ cmd="echo $ac_n \"\$LIBPATH$unique$ac_c\""
++ if test -n "$unique" && test "`eval $cmd`" = "" ; then
++ eval "LIBPATH$unique=set"
++
++ test -n "$ld_runpath_switch" && LDFLAGS="$LDFLAGS $ld_runpath_switch$ai_p"
++ LDFLAGS="$LDFLAGS -L$ai_p"
++ PHP_RPATHS="$PHP_RPATHS $ai_p"
++
++ fi
++
++
++ fi
++
++ fi
++
++ ;;
++ esac
++ done
++
echo $ac_n "checking for gdCacheCreate in -lgd""... $ac_c" 1>&6
- echo "configure:32280: checking for gdCacheCreate in -lgd" >&5
+ echo "configure:35479: checking for gdCacheCreate in -lgd" >&5
ac_lib_var=`echo gd'_'gdCacheCreate | sed 'y%./+-%__p_%'`
-@@ -54325,8 +54422,8 @@
+@@ -58977,8 +59151,8 @@
echo $ac_n "checking Oracle version""... $ac_c" 1>&6
- echo "configure:54328: checking Oracle version" >&5
+ echo "configure:58980: checking Oracle version" >&5
- if test -s "$ORACLE_DIR/orainst/unix.rgs"; then
- ORACLE_VERSION=`grep '"ocommon"' $ORACLE_DIR/orainst/unix.rgs | sed 's/ */:/g' | cut -d: -f 6 | cut -c 2-4`
+ if test -s "$ORACLE_DIR/ocommon/install/partial.prd"; then
@@ -159,7 +236,7 @@
test -z "$ORACLE_VERSION" && ORACLE_VERSION=7.3
elif test -f $ORACLE_DIR/lib/libclntsh.$SHLIB_SUFFIX_NAME.9.0; then
ORACLE_VERSION=9.0
-@@ -56589,6 +56686,102 @@
+@@ -60270,6 +60444,102 @@
if test "$ext_shared" = "yes"; then
@@ -262,7 +339,7 @@
ORACLE_SHARED_LIBADD="-lnlsrtl3 $ORACLE_SHARED_LIBADD"
if test -n "$ORACLE_DIR/lib"; then
-@@ -71130,29 +71323,6 @@
+@@ -76670,29 +76940,6 @@
else
@@ -292,7 +369,7 @@
case ct in
c|c_r|pthread*) ;;
*)
-@@ -71176,52 +71346,7 @@
+@@ -76716,52 +76963,7 @@
@@ -346,7 +423,7 @@
save_old_LDFLAGS=$LDFLAGS
-@@ -71291,37 +71416,6 @@
+@@ -76907,38 +77109,6 @@
@@ -354,6 +431,7 @@
- echo "$ac_t""no" 1>&6
-
- LDFLAGS=$save_old_LDFLAGS
+- ext_shared=$save_ext_shared
- unset ac_cv_func_tcl
-
-
@@ -384,7 +462,7 @@
fi
-@@ -84252,10 +84346,7 @@
+@@ -90711,10 +90881,7 @@
CXXFLAGS="$CXXFLAGS $standard_libtool_flag"
all_targets='$(OVERALL_TARGET) $(PHP_MODULES) $(PHP_CLI_TARGET)'
diff --git a/lang/php4/pkg-plist b/lang/php4/pkg-plist
index c95c4a6f5dd1..02e3314ccb4b 100644
--- a/lang/php4/pkg-plist
+++ b/lang/php4/pkg-plist
@@ -142,6 +142,7 @@ include/php/ext/xml/expat/ascii.h
include/php/ext/xml/expat/asciitab.h
include/php/ext/xml/expat/expat.h
include/php/ext/xml/expat/iasciitab.h
+include/php/ext/xml/expat/internal.h
include/php/ext/xml/expat/latin1tab.h
include/php/ext/xml/expat/nametab.h
include/php/ext/xml/expat/utf8tab.h
diff --git a/lang/php4/scripts/configure.php b/lang/php4/scripts/configure.php
index 97c8cf2eea3a..4bb84c6ffb36 100644
--- a/lang/php4/scripts/configure.php
+++ b/lang/php4/scripts/configure.php
@@ -16,7 +16,7 @@ else
export $i
done
fi
- /usr/bin/dialog --title "configuration options" --clear --checklist "\n\
+ /usr/bin/dialog --title "PHP configuration options" --clear --checklist "\n\
Please select desired options:" -1 -1 16 \
BCMATH "bc style precision math functions" ${WITH_BCMATH:-OFF} \
BZIP2 "bzip2 library support" ${WITH_BZIP2:-OFF} \