aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2012-01-15 03:11:35 +0800
committermiwi <miwi@FreeBSD.org>2012-01-15 03:11:35 +0800
commit683fb846941bcea737ab386723bda195e8334631 (patch)
treedf7f59db3c47fe9fae85655d19bb08087bdde58a /lang
parentf390db5c063c303361abcc0419aec964467f8063 (diff)
downloadfreebsd-ports-gnome-683fb846941bcea737ab386723bda195e8334631.tar.gz
freebsd-ports-gnome-683fb846941bcea737ab386723bda195e8334631.tar.zst
freebsd-ports-gnome-683fb846941bcea737ab386723bda195e8334631.zip
- Respect CC/CFLAGS
PR: 162913 Submitted by: Jan Beich <jbeich@tormail.net>
Diffstat (limited to 'lang')
-rw-r--r--lang/rexx-wrapper/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/lang/rexx-wrapper/Makefile b/lang/rexx-wrapper/Makefile
index e080a276f5fe..86a4eba75af3 100644
--- a/lang/rexx-wrapper/Makefile
+++ b/lang/rexx-wrapper/Makefile
@@ -23,4 +23,12 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-rexx=regina
DATADIR= ${PREFIX}/share/rexx${PORTNAME}
+post-patch: .SILENT
+ @${REINPLACE_CMD} -Ee "/^compiler\.unix/s,'.*','${CC:T}'," \
+ -e "s,cc\.cc = .*,cc.${CC:T} = '${CC}'," \
+ -e "/ opt/s/-[Og][^' ]?//" \
+ -e "s,cflags\. = '(.*)',cflags. = '\1 ${CFLAGS}'," \
+ ${WRKSRC}/rexxwrap.cmd
+ @${REINPLACE_CMD} 's/-compiler=$$(CC/&:T/' ${WRKSRC}/Makefile.in
+
.include <bsd.port.mk>