aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2013-09-15 20:52:28 +0800
committermva <mva@FreeBSD.org>2013-09-15 20:52:28 +0800
commit6a5eb9eff6b125067d5ec3fea4bbd1b342ef45bd (patch)
treeff94ebc9e7c79c921019300543c3b38f19ee3fa9 /lang
parentf9bd02898969a8cc357054bc648c778074269143 (diff)
downloadfreebsd-ports-gnome-6a5eb9eff6b125067d5ec3fea4bbd1b342ef45bd.tar.gz
freebsd-ports-gnome-6a5eb9eff6b125067d5ec3fea4bbd1b342ef45bd.tar.zst
freebsd-ports-gnome-6a5eb9eff6b125067d5ec3fea4bbd1b342ef45bd.zip
- Introduce PYTHON2_DEFAULT_VERSION, the version of the default python2
binary in $PATH. It can be set in case the user wants to use a specific python2 version as a default. Its behaviour is similar to the existing PYTHON3_DEFAULT_VERSION and fixes a small issue with package builds for different python versions. - Outline that PYTHON_DEFAULT_VERSION always takes precedence for a specific python major version. - Update lang/python2 to use PYTHON2_DEFAULT_VERSION and bump the PORTREVISION to let the installed port catch up with the change. - Allow PYTHON3_DEFAULT_VERSION to overriden by a user choice, if PYTHON_DEFAULT_VERSION is not set to a python3 port. Reported by: David Demelier <demelier.david@gmail.com> Reviewed by: koobs@, sbz@ With hat on: python@
Diffstat (limited to 'lang')
-rw-r--r--lang/python2/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/lang/python2/Makefile b/lang/python2/Makefile
index 1e0448e61aa8..6a6c6b950803 100644
--- a/lang/python2/Makefile
+++ b/lang/python2/Makefile
@@ -2,6 +2,7 @@
PORTNAME= python2
PORTVERSION= ${PYTHON_MAJOR_VER}
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= # empty
DISTFILES= # empty
@@ -11,7 +12,7 @@ MAINTAINER= python@FreeBSD.org
COMMENT= The "meta-port" for version 2 of the Python interpreter
USE_PYTHON_RUN= yes
-PYTHON_VERSION= ${PYTHON_DEFAULT_VERSION}
+PYTHON_VERSION= ${PYTHON2_DEFAULT_VERSION}
NO_BUILD= yes
PYTHON_NO_DEPENDS= yes