aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorjdp <jdp@FreeBSD.org>1999-01-28 13:39:19 +0800
committerjdp <jdp@FreeBSD.org>1999-01-28 13:39:19 +0800
commit6d178765f57d85fec93362aad71e64c781b5b24a (patch)
tree73bf7ad8327744e2237c8c55a2eb59eda3b98435 /lang
parent73c6e1eea9cbb8c723f85a0273c43ba82fd9110c (diff)
downloadfreebsd-ports-gnome-6d178765f57d85fec93362aad71e64c781b5b24a.tar.gz
freebsd-ports-gnome-6d178765f57d85fec93362aad71e64c781b5b24a.tar.zst
freebsd-ports-gnome-6d178765f57d85fec93362aad71e64c781b5b24a.zip
Instead of trying to auto-detect whether X11 is installed, require
the user to define NO_X11 if it is not. The auto-detection scheme caused problems for Satoshi's port building system.
Diffstat (limited to 'lang')
-rw-r--r--lang/modula-3-lib/Makefile23
-rw-r--r--lang/modula-3/Makefile27
-rw-r--r--lang/modula-3/scripts/fix_pathnames12
-rw-r--r--lang/modula-3/scripts/maybe-strip7
4 files changed, 40 insertions, 29 deletions
diff --git a/lang/modula-3-lib/Makefile b/lang/modula-3-lib/Makefile
index 02e261229c68..c17cc13d460e 100644
--- a/lang/modula-3-lib/Makefile
+++ b/lang/modula-3-lib/Makefile
@@ -3,7 +3,7 @@
# Date created: 28 Oct 1996
# Whom: John Polstra <jdp@polstra.com>
#
-# $Id: Makefile,v 1.12 1998/10/12 16:38:04 jseger Exp $
+# $Id: Makefile,v 1.13 1998/10/13 01:17:27 jseger Exp $
#
DISTNAME= modula-3-lib-3.6
@@ -51,16 +51,6 @@ have_gcc!= /bin/sh scripts/check_files files/T.gcc m3cc /usr/src/contrib
DISTFILES+= m3-fbsd-gcc-3.6.tar.gz
.endif
-# Support building on systems with or without X11 installed. The port
-# only supports X11R6 in the standard location, so we don't bother using
-# the X11BASE macro. It's not defined yet at this point in the Makefile
-# anyway.
-.if exists(/usr/X11R6/lib/libX11.a)
-PLIST= ${WRKDIR}/PLIST
-.else
-PLIST= ${WRKDIR}/PLIST.noX11
-.endif
-
# Startup script, run at boot time
startup_dir= ${PREFIX}/etc/rc.d
startup_script= ${startup_dir}/50.m3.sh
@@ -77,6 +67,17 @@ libdir= lib/m3/FreeBSD2
# Shared library major version number
major= 6
+# Support building on systems with or without X11 installed.
+.ifdef NO_X11
+PLIST= ${WRKDIR}/PLIST.noX11
+.else
+pre-fetch:
+ @echo "To build this port without X11, define \"NO_X11\"."
+
+USE_XLIB= yes
+PLIST= ${WRKDIR}/PLIST
+.endif
+
post-extract:
.if !empty(have_boot)
@echo "Copying bootstrap modula-3 compiler from ${have_boot}"
diff --git a/lang/modula-3/Makefile b/lang/modula-3/Makefile
index 2afa5181ce00..a0ee3a395e2a 100644
--- a/lang/modula-3/Makefile
+++ b/lang/modula-3/Makefile
@@ -3,7 +3,7 @@
# Date created: 18 Mar 1996
# Whom: John Polstra <jdp@polstra.com>
#
-# $Id: Makefile,v 1.26 1998/10/13 01:17:27 jseger Exp $
+# $Id: Makefile,v 1.27 1998/12/04 07:23:01 asami Exp $
#
DISTNAME= modula-3-3.6
@@ -22,17 +22,6 @@ MAN1= analyze_coverage.1 m3browser.1 m3build.1 \
m3totex.1 m3where.1 quake.1 recordheap.1
SCRIPTS_ENV+= MAJOR=${major} PKGDIR=${PKGDIR} PLIST=${PLIST}
-# Support building on systems with or without X11 installed. The port
-# only supports X11R6 in the standard location, so we don't bother using
-# the X11BASE macro. It's not defined yet at this point in the Makefile
-# anyway.
-.if exists(/usr/X11R6/lib/libX11.a)
-PLIST= ${WRKDIR}/PLIST
-MAN1+= formsedit.1 replayheap.1 showheap.1 shownew.1 showthread.1
-.else
-PLIST= ${WRKDIR}/PLIST.noX11
-.endif
-
# Shared library major version number. Keep this in sync with the
# modula-3-lib port.
major= 6
@@ -43,6 +32,17 @@ major= 6
# be "installed" into the following directory, which we own.
temp_prefix= ${WRKSRC}/installed
+# Support building on systems with or without X11 installed.
+.ifdef NO_X11
+PLIST= ${WRKDIR}/PLIST.noX11
+.else
+pre-fetch:
+ @echo "To build this port without X11, define \"NO_X11\"."
+
+PLIST= ${WRKDIR}/PLIST
+MAN1+= formsedit.1 replayheap.1 showheap.1 shownew.1 showthread.1
+.endif
+
do-install:
@echo "Deleting extraneous cruft"
@cd ${temp_prefix}/lib/m3/pkg; \
@@ -93,7 +93,8 @@ do-install:
@${INSTALL_DATA} ${WRKSRC}/m3/src/COPYRIGHT ${PREFIX}/share/modula-3
@echo "Stripping executables"
@cd ${temp_prefix}; \
- find bin -type f ! -name recordheap | (cd ${PREFIX}; xargs strip)
+ find bin -type f ! -name recordheap |\
+ (cd ${PREFIX}; xargs ${SH} ${SCRIPTDIR}/maybe-strip)
@cd ${PREFIX}/lib/m3/FreeBSD2; strip m3 m3cgc1 m3mkdir
@cd ${PREFIX}/bin; \
ln -f m3build m3build-${major}
diff --git a/lang/modula-3/scripts/fix_pathnames b/lang/modula-3/scripts/fix_pathnames
index c04fca5f9868..2eca36b5b708 100644
--- a/lang/modula-3/scripts/fix_pathnames
+++ b/lang/modula-3/scripts/fix_pathnames
@@ -1,6 +1,6 @@
#! /bin/sh
#
-# $Id: fix_pathnames,v 1.2 1996/09/10 05:25:10 jdp Exp $
+# $Id: fix_pathnames,v 1.3 1996/10/29 23:17:19 jdp Exp $
umask 022
@@ -20,8 +20,10 @@ pkgdir=lib/m3/pkg
cd ${newpath}/${pkgdir}
for i in `cd ${oldpath}/${pkgdir}; \
find . -type f \( -name .M3IMPTAB -o -name FreeBSD2 \)`; do
- test -f ${i}.bak || cp -p ${i} ${i}.bak
- rm -f ${i}
- sed -e "s|/[^ ]*/work/installed/|${newpath}/|g" ${i}.bak >${i} && \
- rm -f ${i}.bak
+ if [ -f ${i} ]; then
+ test -f ${i}.bak || cp -p ${i} ${i}.bak
+ rm -f ${i}
+ sed -e "s|/[^ ]*/work/installed/|${newpath}/|g" ${i}.bak >${i} && \
+ rm -f ${i}.bak
+ fi
done
diff --git a/lang/modula-3/scripts/maybe-strip b/lang/modula-3/scripts/maybe-strip
new file mode 100644
index 000000000000..ef0b03f05592
--- /dev/null
+++ b/lang/modula-3/scripts/maybe-strip
@@ -0,0 +1,7 @@
+#! /bin/sh
+
+for i; do
+ if [ -f $i ]; then
+ strip $i
+ fi
+done