aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2004-01-08 15:50:54 +0800
committerijliao <ijliao@FreeBSD.org>2004-01-08 15:50:54 +0800
commit6ed895a89d1f3ecca80ae41e8073a865bd897328 (patch)
tree94c9878b5ccd08adc7b4457beda3ac78be2f15c9 /lang
parentdc0963790e9f4349640cf4af4fd61a512fb2f7b6 (diff)
downloadfreebsd-ports-gnome-6ed895a89d1f3ecca80ae41e8073a865bd897328.tar.gz
freebsd-ports-gnome-6ed895a89d1f3ecca80ae41e8073a865bd897328.tar.zst
freebsd-ports-gnome-6ed895a89d1f3ecca80ae41e8073a865bd897328.zip
add q 4.6
Q -- equational programming language
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/q/Makefile79
-rw-r--r--lang/q/distinfo1
-rw-r--r--lang/q/files/patch-ltmain.sh15
-rw-r--r--lang/q/pkg-descr37
-rw-r--r--lang/q/pkg-plist153
6 files changed, 286 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index e5334f9c2aa9..eddea65d3e9a 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -182,6 +182,7 @@
SUBDIR += python20
SUBDIR += python21
SUBDIR += python22
+ SUBDIR += q
SUBDIR += qc--
SUBDIR += qscheme
SUBDIR += quack
diff --git a/lang/q/Makefile b/lang/q/Makefile
new file mode 100644
index 000000000000..6c2b7a41058b
--- /dev/null
+++ b/lang/q/Makefile
@@ -0,0 +1,79 @@
+# New ports collection makefile for: q
+# Date created: 14 August 2003
+# Whom: ag@muwiinfa.geschichte.uni-mainz.de Albert Graef
+#
+# $FreeBSD$
+#
+
+PORTNAME= q
+PORTVERSION= 4.6
+CATEGORIES= lang
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= q-lang
+
+MAINTAINER= ag@muwiinfa.geschichte.uni-mainz.de
+COMMENT= Q -- equational programming language
+
+BUILD_DEPENDS= ${LOCALBASE}/dx/lib_freebsd/libDXL.a:${PORTSDIR}/graphics/opendx
+LIB_DEPENDS= Magick.6:${PORTSDIR}/graphics/ImageMagick \
+ freetype.9:${PORTSDIR}/print/freetype2 \
+ gdbm.3:${PORTSDIR}/databases/gdbm \
+ gii.0:${PORTSDIR}/devel/libgii \
+ ggi.2:${PORTSDIR}/graphics/libggi \
+ gmp.6:${PORTSDIR}/math/libgmp4
+
+USE_REINPLACE= yes
+USE_BISON= yes
+USE_GNOME= gnometarget
+CFLAGS+= -I${LOCALBASE}/include
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -L${LOCALBASE}/dx/lib_freebsd" \
+ MAKEINFO="makeinfo --no-split"
+CONFIGURE_ARGS= --with-dxl-includes=-I${LOCALBASE}/dx/include
+INSTALLS_SHLIB= yes
+
+# The tk module is built by default, but you can disable this by defining
+# the following variable.
+.if defined(WITHOUT_TK)
+CONFIGURE_ARGS+= --without-tk
+.else
+LIB_DEPENDS+= tcl84:${PORTSDIR}/lang/tcl84 \
+ tk84:${PORTSDIR}/x11-toolkits/tk84
+CFLAGS+= -I${LOCALBASE}/include/tcl8.4 -I${LOCALBASE}/include/tk8.4
+CONFIGURE_ARGS+= --with-tk="-ltcl84 -ltk84"
+.endif
+
+# POSIX threads support is enabled by default, but you can disable this by
+# defining the following variable.
+.if defined(WITHOUT_PTHREAD)
+CONFIGURE_ARGS+= --without-pthread
+.else
+CONFIGURE_ARGS+= --with-pthread="${PTHREAD_LIBS}"
+.endif
+
+# The odbc module needs an ODBC driver manager to be installed, and it
+# supports both iODBC and unixODBC. The following variable may be set at
+# build-time to either "iodbc" or "unixodbc", with the former being the
+# default:
+ODBC?= iodbc
+
+.if ${ODBC} == "unixodbc"
+LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
+CONFIGURE_ARGS+= --with-odbc=-lodbc
+.else # assume we're using iodbc
+LIB_DEPENDS+= iodbc.3:${PORTSDIR}/databases/libiodbc
+CONFIGURE_ARGS+= --with-odbc=-liodbc
+.endif
+
+MAN1= q.1
+INFO= qdoc
+
+post-extract:
+ @${RM} -f ${WRKSRC}/doc/*info*
+
+post-patch:
+ @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} \
+ ${GREP} -l "^examplesdir" | ${XARGS} ${REINPLACE_CMD} -e \
+ "s;[(]pkgdatadir[)]/examples;(datadir)/examples/@PACKAGE@;"
+
+.include <bsd.port.mk>
diff --git a/lang/q/distinfo b/lang/q/distinfo
new file mode 100644
index 000000000000..cf3467aa2916
--- /dev/null
+++ b/lang/q/distinfo
@@ -0,0 +1 @@
+MD5 (q-4.6.tar.gz) = 22820c3434d7b0b956be75fb9c21b9a1
diff --git a/lang/q/files/patch-ltmain.sh b/lang/q/files/patch-ltmain.sh
new file mode 100644
index 000000000000..6820023a7fef
--- /dev/null
+++ b/lang/q/files/patch-ltmain.sh
@@ -0,0 +1,15 @@
+--- ltmain.sh.orig Thu Jan 8 11:47:45 2004
++++ ltmain.sh Thu Jan 8 11:48:00 2004
+@@ -4210,10 +4210,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false ; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/lang/q/pkg-descr b/lang/q/pkg-descr
new file mode 100644
index 000000000000..f47a071d873a
--- /dev/null
+++ b/lang/q/pkg-descr
@@ -0,0 +1,37 @@
+Q is a powerful and extensible functional programming language based on the
+term rewriting calculus. You specify an arbitrary system of equations which
+the interpreter uses as rewrite rules to reduce expressions to normal form. Q
+is useful for scientific programming and other advanced applications, and also
+as a sophisticated kind of desktop calculator. The distribution includes the Q
+programming tools, the standard library, add-on modules for interfacing to GNU
+dbm, ODBC, GNU Octave, GGI, ImageMagick, Tcl/Tk and IBM's Data Explorer, and
+an Emacs mode.
+
+Q's main features:
+
+- advanced symbolic expression manipulation, using equations supplied by the
+ programmer
+
+- fast bytecode interpreter, which executes Q scripts almost as fast as
+ interpreted Lisp or Haskell
+
+- built-in support for arbitrary precision integers, double precision floating
+ point numbers, strings, lists, tuples, curried function applications, lazy
+ evaluation, exception handling, and user-defined object-oriented data types
+ with single inheritance
+
+- simple but powerful module system which lets you manage large scripts with
+ ease, and a libtool-based interface to external C modules which allows such
+ modules to be loaded at runtime
+
+- comprehensive standard library written mostly in Q itself, which includes
+ powerful list processing functions, a collection of useful container data
+ structures, an implementation of the lambda calculus, an interface to the
+ PostScript language, and a system interface featuring binary and C-style
+ formatted I/O, file system and process manipulation utilities, POSIX
+ threads, BSD sockets, regular expression matching, ...
+
+WWW: http://q-lang.sourceforge.net/
+
+- Albert Graef
+ag@muwiinfa.geschichte.uni-mainz.de
diff --git a/lang/q/pkg-plist b/lang/q/pkg-plist
new file mode 100644
index 000000000000..0281b1008d72
--- /dev/null
+++ b/lang/q/pkg-plist
@@ -0,0 +1,153 @@
+bin/q
+bin/qc
+bin/qcc
+bin/qld
+include/libq.h
+lib/libq.a
+lib/libq.so
+lib/libq.so.4
+lib/libqmain.a
+lib/q/clib.a
+lib/q/clib.so
+lib/q/dxl.a
+lib/q/dxl.so
+lib/q/gdbm.a
+lib/q/gdbm.so
+lib/q/ggi.a
+lib/q/ggi.so
+lib/q/libtool
+lib/q/magick.a
+lib/q/magick.so
+lib/q/octave.a
+lib/q/octave.so
+lib/q/odbc.a
+lib/q/odbc.so
+lib/q/tk.a
+lib/q/tk.so
+%%DATADIR%%/etc/AUTHORS
+%%DATADIR%%/etc/COPYING
+%%DATADIR%%/etc/ChangeLog
+%%DATADIR%%/etc/NEWS
+%%DATADIR%%/etc/README
+%%DATADIR%%/etc/README-Clib
+%%DATADIR%%/etc/README-DXL
+%%DATADIR%%/etc/README-GGI
+%%DATADIR%%/etc/README-Gdbm
+%%DATADIR%%/etc/README-Magick
+%%DATADIR%%/etc/README-ODBC
+%%DATADIR%%/etc/README-Octave
+%%DATADIR%%/etc/README-Tk
+%%DATADIR%%/etc/q-mode.el
+%%DATADIR%%/etc/q.xml
+%%DATADIR%%/etc/qexitrc
+%%DATADIR%%/etc/qinitrc
+%%DATADIR%%/lib/array.q
+%%DATADIR%%/lib/assert.q
+%%DATADIR%%/lib/bag.q
+%%DATADIR%%/lib/clib.q
+%%DATADIR%%/lib/comp.q
+%%DATADIR%%/lib/complex.q
+%%DATADIR%%/lib/cond.q
+%%DATADIR%%/lib/dict.q
+%%DATADIR%%/lib/dxl.q
+%%DATADIR%%/lib/error.q
+%%DATADIR%%/lib/gdbm.q
+%%DATADIR%%/lib/ggi.q
+%%DATADIR%%/lib/graphics.q
+%%DATADIR%%/lib/hdict.q
+%%DATADIR%%/lib/heap.q
+%%DATADIR%%/lib/lambda.q
+%%DATADIR%%/lib/list.q
+%%DATADIR%%/lib/magick.q
+%%DATADIR%%/lib/math.q
+%%DATADIR%%/lib/octave.q
+%%DATADIR%%/lib/odbc.q
+%%DATADIR%%/lib/prelude.q
+%%DATADIR%%/lib/set.q
+%%DATADIR%%/lib/sort.q
+%%DATADIR%%/lib/stddecl.q
+%%DATADIR%%/lib/stdlib.q
+%%DATADIR%%/lib/stdtypes.q
+%%DATADIR%%/lib/stream.q
+%%DATADIR%%/lib/string.q
+%%DATADIR%%/lib/tk.q
+%%DATADIR%%/lib/typec.q
+%%EXAMPLESDIR%%/avltree.q
+%%EXAMPLESDIR%%/bintree.q
+%%EXAMPLESDIR%%/creverse.c
+%%EXAMPLESDIR%%/creverse.q
+%%EXAMPLESDIR%%/ctype.c
+%%EXAMPLESDIR%%/ctype.q
+%%EXAMPLESDIR%%/daemon.q
+%%EXAMPLESDIR%%/dfs.q
+%%EXAMPLESDIR%%/dgram.q
+%%EXAMPLESDIR%%/dnf.q
+%%EXAMPLESDIR%%/dxl/dxl_sample.cfg
+%%EXAMPLESDIR%%/dxl/dxl_sample.net
+%%EXAMPLESDIR%%/dxl/dxl_sample.q
+%%EXAMPLESDIR%%/dxl/dxl_simple.q
+%%EXAMPLESDIR%%/dxl/sombrero.cfg
+%%EXAMPLESDIR%%/dxl/sombrero.dx
+%%EXAMPLESDIR%%/dxl/sombrero.net
+%%EXAMPLESDIR%%/dxl/sombrero.q
+%%EXAMPLESDIR%%/except.q
+%%EXAMPLESDIR%%/fac.q
+%%EXAMPLESDIR%%/factor.q
+%%EXAMPLESDIR%%/fcntl.q
+%%EXAMPLESDIR%%/fib.q
+%%EXAMPLESDIR%%/fixpt.q
+%%EXAMPLESDIR%%/gdbm/gdbm_dict.q
+%%EXAMPLESDIR%%/gdbm/testdb.q
+%%EXAMPLESDIR%%/getpass.q
+%%EXAMPLESDIR%%/ggi/bufdemo.q
+%%EXAMPLESDIR%%/ggi/flying_ggis.q
+%%EXAMPLESDIR%%/ggi/font_test.q
+%%EXAMPLESDIR%%/ggi/ggi_demo.q
+%%EXAMPLESDIR%%/globexamp.q
+%%EXAMPLESDIR%%/graph.q
+%%EXAMPLESDIR%%/grid.q
+%%EXAMPLESDIR%%/hamming.q
+%%EXAMPLESDIR%%/hashed.q
+%%EXAMPLESDIR%%/huffman.q
+%%EXAMPLESDIR%%/magick/magicktest.q
+%%EXAMPLESDIR%%/magick/mozilla.png
+%%EXAMPLESDIR%%/magick/mozilla_48x48.rgba
+%%EXAMPLESDIR%%/magick/sprite.q
+%%EXAMPLESDIR%%/menu.q
+%%EXAMPLESDIR%%/newton.q
+%%EXAMPLESDIR%%/odbc/odbc_examp.q
+%%EXAMPLESDIR%%/perms.q
+%%EXAMPLESDIR%%/pipes.q
+%%EXAMPLESDIR%%/popen2.q
+%%EXAMPLESDIR%%/powers.q
+%%EXAMPLESDIR%%/primes.q
+%%EXAMPLESDIR%%/primesum.q
+%%EXAMPLESDIR%%/print.q
+%%EXAMPLESDIR%%/pty.q
+%%EXAMPLESDIR%%/queens.q
+%%EXAMPLESDIR%%/queens2.q
+%%EXAMPLESDIR%%/queens3.q
+%%EXAMPLESDIR%%/queue.q
+%%EXAMPLESDIR%%/regexamp.q
+%%EXAMPLESDIR%%/scan.q
+%%EXAMPLESDIR%%/searchtree.q
+%%EXAMPLESDIR%%/select.q
+%%EXAMPLESDIR%%/signal.q
+%%EXAMPLESDIR%%/sys.q
+%%EXAMPLESDIR%%/testfont.q
+%%EXAMPLESDIR%%/time.q
+%%EXAMPLESDIR%%/tk/tix.q
+%%EXAMPLESDIR%%/tk/tk_examp.q
+%%EXAMPLESDIR%%/tk/tk_test.q
+%%EXAMPLESDIR%%/trees.q
+@dirrm lib/q
+@dirrm %%DATADIR%%/lib
+@dirrm %%DATADIR%%/etc
+@dirrm %%DATADIR%%
+@dirrm %%EXAMPLESDIR%%/tk
+@dirrm %%EXAMPLESDIR%%/odbc
+@dirrm %%EXAMPLESDIR%%/magick
+@dirrm %%EXAMPLESDIR%%/gdbm
+@dirrm %%EXAMPLESDIR%%/ggi
+@dirrm %%EXAMPLESDIR%%/dxl
+@dirrm %%EXAMPLESDIR%%