aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2015-08-15 23:59:40 +0800
committerdanfe <danfe@FreeBSD.org>2015-08-15 23:59:40 +0800
commit7056c5334f387c497065b17890265847ff573376 (patch)
tree502c1c41ea4117e8745ae5ccf0bd24fbcccf9838 /lang
parent4afe78bfd3dff30f4f788d47eda72b3842afaaf4 (diff)
downloadfreebsd-ports-gnome-7056c5334f387c497065b17890265847ff573376.tar.gz
freebsd-ports-gnome-7056c5334f387c497065b17890265847ff573376.tar.zst
freebsd-ports-gnome-7056c5334f387c497065b17890265847ff573376.zip
- Resurrect lang/quack port, unbreak, and update to the latest version (0.47)
- Remove BROKEN on ia64 statement, it was never a first-class architecture and officially killed in -CURRENT already - Modernize and clean up the port while here, define LICENSE (GPLv2)
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/quack/Makefile39
-rw-r--r--lang/quack/distinfo2
-rw-r--r--lang/quack/pkg-descr5
-rw-r--r--lang/quack/pkg-message3
5 files changed, 50 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 0f920c08fa6e..6cf4749cc662 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -266,6 +266,7 @@
SUBDIR += qore
SUBDIR += qscheme
SUBDIR += qt5-qml
+ SUBDIR += quack
SUBDIR += racket
SUBDIR += racket-minimal
SUBDIR += ratfor
diff --git a/lang/quack/Makefile b/lang/quack/Makefile
new file mode 100644
index 000000000000..fa4c51355b85
--- /dev/null
+++ b/lang/quack/Makefile
@@ -0,0 +1,39 @@
+# Created by: Kimura Fuyuki <fuyuki@nigredo.org>
+# $FreeBSD$
+
+PORTNAME= quack
+PORTVERSION= 0.47
+CATEGORIES= lang scheme elisp
+MASTER_SITES= http://www.neilvandyke.org/quack/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .el
+DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Enhanced support for editing and running Scheme code
+
+LICENSE= GPLv2
+
+RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
+
+USE_EMACS= yes
+
+NO_WRKSUBDIR= yes
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS= # empty
+EXTRACT_AFTER_ARGS= ${WRKSRC}
+
+PLIST_FILES= ${EMACS_VERSION_SITE_LISPDIR}/quack/quack.el \
+ ${EMACS_VERSION_SITE_LISPDIR}/quack/quack.elc
+PLIST_DIRS= ${EMACS_VERSION_SITE_LISPDIR}/quack
+
+ELISPDIR= ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/${PORTNAME}
+
+do-build:
+ cd ${WRKSRC} && ${EMACS_CMD} -batch -q -f batch-byte-compile quack.el
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${ELISPDIR}
+ ${INSTALL_DATA} ${WRKSRC}/quack.* ${STAGEDIR}${ELISPDIR}
+
+.include <bsd.port.mk>
diff --git a/lang/quack/distinfo b/lang/quack/distinfo
new file mode 100644
index 000000000000..9a000c04b534
--- /dev/null
+++ b/lang/quack/distinfo
@@ -0,0 +1,2 @@
+SHA256 (quack-0.47/quack.el) = 454a7229dd0a18a166f9785deb9c6243a38aa933608871796b71c5d929d5abe0
+SIZE (quack-0.47/quack.el) = 199403
diff --git a/lang/quack/pkg-descr b/lang/quack/pkg-descr
new file mode 100644
index 000000000000..95d1ca231dab
--- /dev/null
+++ b/lang/quack/pkg-descr
@@ -0,0 +1,5 @@
+Quack enhances Emacs support for Scheme programming. Quack is layered
+atop the standard packages `cmuscheme.el', by Olin Shivers, and
+`scheme.el', by Bill Rozas and Dave Love.
+
+WWW: http://www.neilvandyke.org/quack/
diff --git a/lang/quack/pkg-message b/lang/quack/pkg-message
new file mode 100644
index 000000000000..76d261bfe023
--- /dev/null
+++ b/lang/quack/pkg-message
@@ -0,0 +1,3 @@
+To use Quack, add the following line to your ~/.emacs:
+
+(require 'quack)