aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2014-07-24 22:53:06 +0800
committergahr <gahr@FreeBSD.org>2014-07-24 22:53:06 +0800
commit712e2a928d57bf904b935ede548b006b8eeb28fa (patch)
tree8ad119e12b9c77ada9c7bf747389dd92a8c12c67 /lang
parentdacdd5bac6ac4f51c57a36b17f8e4a06c62b181c (diff)
downloadfreebsd-ports-gnome-712e2a928d57bf904b935ede548b006b8eeb28fa.tar.gz
freebsd-ports-gnome-712e2a928d57bf904b935ede548b006b8eeb28fa.tar.zst
freebsd-ports-gnome-712e2a928d57bf904b935ede548b006b8eeb28fa.zip
- Fix linking with readline from ports
- While at it, convert to USES=libtool
Diffstat (limited to 'lang')
-rw-r--r--lang/kawa/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/lang/kawa/Makefile b/lang/kawa/Makefile
index 84e00f805ee1..3c019348a8c9 100644
--- a/lang/kawa/Makefile
+++ b/lang/kawa/Makefile
@@ -15,14 +15,14 @@ LICENSE= MIT
BUILD_DEPENDS= ${LOCALBASE}/bin/makeinfo:${PORTSDIR}/print/texinfo
-USES= gmake readline
+USES= gmake libtool readline
USE_JAVA= yes
-USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-kawa-frontend \
--with-java-source=${JAVA_PORT_VERSION} \
--with-libtool
CONFIGURE_ENV+= MAKEINFO=${LOCALBASE}/bin/makeinfo
+MAKE_ENV+= READLINE_LIB_PATH=${LOCALBASE}/lib
MAKE_JOBS_UNSAFE=yes
@@ -37,6 +37,9 @@ pre-patch:
-e '/^JAR =/s|[a-zA-Z]*$$|${JAR}|g;'
@${REINPLACE_CMD} -e 's|{JAVAC-javac}|{JAVAC-${JAVAC}}|g;' \
-e 's|{JAVA-java}|{JAVA-${JAVA}}|g;' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/^READLINE_LIB_PATH =/s|$$|-L${LOCALBASE}/lib|' \
+ ${WRKSRC}/bin/Makefile.in \
+ ${WRKSRC}/bin/Makefile.am
regression-test: build
cd ${WRKSRC} && ${MAKE_CMD} check