aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2010-08-20 14:46:35 +0800
committerdinoex <dinoex@FreeBSD.org>2010-08-20 14:46:35 +0800
commit72659706a2320d9b6dbab4226a45f2b1d6ed82c3 (patch)
treec978e3a572736ff1c231b9e420bdd915b89b5f56 /lang
parente73f535bacd622ec6d807a79eac92761e0b87fb9 (diff)
downloadfreebsd-ports-gnome-72659706a2320d9b6dbab4226a45f2b1d6ed82c3.tar.gz
freebsd-ports-gnome-72659706a2320d9b6dbab4226a45f2b1d6ed82c3.tar.zst
freebsd-ports-gnome-72659706a2320d9b6dbab4226a45f2b1d6ed82c3.zip
- fix build with gcc42
Diffstat (limited to 'lang')
-rw-r--r--lang/gnustep-base/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/lang/gnustep-base/Makefile b/lang/gnustep-base/Makefile
index a34af4907812..455a5d5443a1 100644
--- a/lang/gnustep-base/Makefile
+++ b/lang/gnustep-base/Makefile
@@ -8,9 +8,10 @@
PORTNAME= gnustep-base
.if defined(WITH_GNUSTEP_DEVEL)
PORTVERSION= 1.21.1
+PORTREVISION= 1
.else
PORTVERSION= 1.19.3
-PORTREVISION= 2
+PORTREVISION= 3
.endif
CATEGORIES= lang devel gnustep
MASTER_SITES= ${MASTER_SITE_GNUSTEP}
@@ -19,6 +20,7 @@ MASTER_SITE_SUBDIR= core
MAINTAINER= dinoex@FreeBSD.org
COMMENT= GNUstep Foundation library
+LIB_DEPENDS+= ffi.5:${PORTSDIR}/devel/libffi
LIB_DEPENDS+= xml2.5:${PORTSDIR}/textproc/libxml2
LIB_DEPENDS+= xslt.2:${PORTSDIR}/textproc/libxslt
LIB_DEPENDS+= gmp.10:${PORTSDIR}/math/gmp
@@ -42,7 +44,7 @@ USE_ICONV= yes
MAKE_FLAGS= OPTFLAG="${CFLAGS}"
MAKE_ENV+= GNUSTEP_INSTALLATION_DOMAIN=SYSTEM
-CFLAGS+= -I${LOCALBASE}/include/libxml2/libxml
+CFLAGS+= -I${LOCALBASE}/include/libxml2/libxml -DHAVE_DLADDR=1
BREAKS_IF_PEDANTIC= yes
PLIST_SUB+= LOCALBASE=${LOCALBASE}
ETCDIR= ${LOCALBASE}/etc
@@ -56,12 +58,6 @@ EXTRA_PATCHES+= ${FILESDIR}/NSFileManager.m.patch
.include <bsd.port.pre.mk>
-.if defined(GNUSTEP_WITH_GCC42)
-.if (${ARCH} == i386) || (${ARCH} == amd64)
-BROKEN= Does not build with gcc42
-.endif
-.endif
-
PATH:= ${PREFIX}/System/Tools:${PATH}
post-build: