aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2013-08-03 21:44:00 +0800
committermat <mat@FreeBSD.org>2013-08-03 21:44:00 +0800
commit75dd7415d6d89e4f6c03a98e4dd8589865c9cb43 (patch)
tree5fff787fcf509ed53762690c395516c337412423 /lang
parent3e657489e209d0aec5331fd70f19c96df0146a59 (diff)
downloadfreebsd-ports-gnome-75dd7415d6d89e4f6c03a98e4dd8589865c9cb43.tar.gz
freebsd-ports-gnome-75dd7415d6d89e4f6c03a98e4dd8589865c9cb43.tar.zst
freebsd-ports-gnome-75dd7415d6d89e4f6c03a98e4dd8589865c9cb43.zip
- Convert to new perl framework
- Remove MAKE_JOBS_SAFE=yes, it's the default.
Diffstat (limited to 'lang')
-rw-r--r--lang/rubinius/Makefile3
-rw-r--r--lang/tcc/Makefile4
2 files changed, 4 insertions, 3 deletions
diff --git a/lang/rubinius/Makefile b/lang/rubinius/Makefile
index 530c04bca0fe..4fda62bbe49a 100644
--- a/lang/rubinius/Makefile
+++ b/lang/rubinius/Makefile
@@ -30,10 +30,11 @@ CONFIGURE_ARGS= --without-execinfo \
--vendordir "${PREFIX}/lib/ruby/vendor_ruby/rubinius"
LLVMDIST= llvm-2.8.tgz
+USES= perl5
USE_RUBY= yes
RUBY_NO_RUN_DEPENDS= yes
USE_RAKE= yes
-USE_PERL5_BUILD= yes
+USE_PERL5= build
USE_GMAKE= yes
MAKE_JOBS_UNSAFE= yes
diff --git a/lang/tcc/Makefile b/lang/tcc/Makefile
index df8a34631d4b..16c2f1061942 100644
--- a/lang/tcc/Makefile
+++ b/lang/tcc/Makefile
@@ -18,13 +18,13 @@ ONLY_FOR_ARCHS= i386
CONFLICTS= TenDRA-*
+USES= perl5
USE_BZIP2= yes
-USE_PERL5_BUILD=yes
+USE_PERL5= build
USE_GMAKE= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix="${PREFIX}" --cc="${CC}"
MAKE_ARGS= CONFIG_NOLDL=1
-MAKE_JOBS_SAFE= yes
MAN1= tcc.1