aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2017-09-18 01:51:24 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 05:32:59 +0800
commit76d97d8453b1b822cce0847ff70b3ccfcde73b67 (patch)
tree7162dbaf62fe8464abca8ed0f4c26543e41abc6e /lang
parente3ac7644ac0e144e67d66134edba8778c19c2db4 (diff)
downloadfreebsd-ports-gnome-76d97d8453b1b822cce0847ff70b3ccfcde73b67.tar.gz
freebsd-ports-gnome-76d97d8453b1b822cce0847ff70b3ccfcde73b67.tar.zst
freebsd-ports-gnome-76d97d8453b1b822cce0847ff70b3ccfcde73b67.zip
Do not quote constant strings compared with ${ARCH}. [1] Remove
some commented (and thus disabled) logic around this on the way. This brings the active lang/gcc* release-based ports in sync with their respective lang/gcc*-devel twins. PR: 221905 [1] Submitted by: linimon [1]
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc5/Makefile6
-rw-r--r--lang/gcc6/Makefile6
-rw-r--r--lang/gcc7/Makefile6
3 files changed, 6 insertions, 12 deletions
diff --git a/lang/gcc5/Makefile b/lang/gcc5/Makefile
index f420ceb1b841..37f8ab453498 100644
--- a/lang/gcc5/Makefile
+++ b/lang/gcc5/Makefile
@@ -62,7 +62,7 @@ CONFIGURE_ARGS+= --disable-multilib
.include <bsd.port.pre.mk>
-.if ${ARCH} == "amd64"
+.if ${ARCH} == amd64
CONFIGURE_TARGET= x86_64-portbld-${OPSYS:tl}${OSREL}
.endif
@@ -70,7 +70,7 @@ CONFIGURE_TARGET= x86_64-portbld-${OPSYS:tl}${OSREL}
CONFIGURE_ENV+= UNAME_m="powerpc64"
.endif
-.if ${ARCH} == "aarch64" || ${ARCH} == "armv6"
+.if ${ARCH} == aarch64 || ${ARCH} == armv6
. if ${COMPILER_TYPE} == clang
. if empty(PORT_OPTIONS:MBOOTSTRAP)
MAKE_ARGS+=CXXFLAGS=-fbracket-depth=512
@@ -116,10 +116,8 @@ INFO= gcc${SUFFIX}/cpp \
gcc${SUFFIX}/gfortran \
gcc${SUFFIX}/libgomp
# Release tarballs (as opposed to snapshots) always carry this.
-#.if ${ARCH} == "amd64" || ${ARCH} == "i386"
INFO+= gcc${SUFFIX}/libquadmath \
gcc${SUFFIX}/libitm
-#.endif
SUB_FILES= pkg-message
SUB_LIST+= TARGLIB=${TARGLIB}
diff --git a/lang/gcc6/Makefile b/lang/gcc6/Makefile
index cc3e7407dd5b..e01087e573f3 100644
--- a/lang/gcc6/Makefile
+++ b/lang/gcc6/Makefile
@@ -62,7 +62,7 @@ CONFIGURE_ARGS+= --disable-multilib
.include <bsd.port.pre.mk>
-.if ${ARCH} == "amd64"
+.if ${ARCH} == amd64
CONFIGURE_TARGET= x86_64-portbld-${OPSYS:tl}${OSREL}
.endif
@@ -71,7 +71,7 @@ CONFIGURE_ENV+= UNAME_m="powerpc64"
USE_GCC= 5 # Cannot require ourselves, needs to be at least 4.9.
.endif
-.if ${ARCH} == "aarch64" || ${ARCH} == "armv6"
+.if ${ARCH} == aarch64 || ${ARCH} == armv6
. if ${COMPILER_TYPE} == clang
. if empty(PORT_OPTIONS:MBOOTSTRAP)
MAKE_ARGS+=CXXFLAGS=-fbracket-depth=512
@@ -117,10 +117,8 @@ INFO= gcc${SUFFIX}/cpp \
gcc${SUFFIX}/gfortran \
gcc${SUFFIX}/libgomp
# Release tarballs (as opposed to snapshots) always carry this.
-#.if ${ARCH} == "amd64" || ${ARCH} == "i386"
INFO+= gcc${SUFFIX}/libquadmath \
gcc${SUFFIX}/libitm
-#.endif
SUB_FILES= pkg-message
SUB_LIST+= TARGLIB=${TARGLIB}
diff --git a/lang/gcc7/Makefile b/lang/gcc7/Makefile
index bd4ff420abd3..0db3713551f7 100644
--- a/lang/gcc7/Makefile
+++ b/lang/gcc7/Makefile
@@ -51,7 +51,7 @@ CONFIGURE_ARGS+= --disable-multilib
.include <bsd.port.pre.mk>
-.if ${ARCH} == "amd64"
+.if ${ARCH} == amd64
CONFIGURE_TARGET= x86_64-portbld-${OPSYS:tl}${OSREL}
.endif
@@ -60,7 +60,7 @@ CONFIGURE_ENV+= UNAME_m="powerpc64"
USE_GCC= yes
.endif
-.if ${ARCH} == "armv6"
+.if ${ARCH} == armv6
. if ${COMPILER_TYPE} == clang
. if empty(PORT_OPTIONS:MBOOTSTRAP)
MAKE_ARGS+=CXXFLAGS+=-fbracket-depth=512
@@ -106,10 +106,8 @@ INFO= gcc${SUFFIX}/cpp \
gcc${SUFFIX}/gfortran \
gcc${SUFFIX}/libgomp
# Release tarballs (as opposed to snapshots) always carry this.
-#.if ${ARCH} == "amd64" || ${ARCH} == "i386"
INFO+= gcc${SUFFIX}/libquadmath \
gcc${SUFFIX}/libitm
-#.endif
SUB_FILES= pkg-message
SUB_LIST+= TARGLIB=${TARGLIB}