aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorjlaffaye <jlaffaye@FreeBSD.org>2011-06-30 03:51:17 +0800
committerjlaffaye <jlaffaye@FreeBSD.org>2011-06-30 03:51:17 +0800
commit7f50b008a605856f2f15392d278e5f8641c6a1d4 (patch)
treeb3a9366d54dda9030a166929a9cd7550822dbcf0 /lang
parentddbdaa6b48a5bf8553cf735f927bf81f28b8f05f (diff)
downloadfreebsd-ports-gnome-7f50b008a605856f2f15392d278e5f8641c6a1d4.tar.gz
freebsd-ports-gnome-7f50b008a605856f2f15392d278e5f8641c6a1d4.tar.zst
freebsd-ports-gnome-7f50b008a605856f2f15392d278e5f8641c6a1d4.zip
Add an option to link against libthr
PR: ports/158423 Submitted by: Frank Wall <fw@moov.de> Approved by: Alex Keda <admin@lissyara.su> (maintainer), bapt (mentor, implicit)
Diffstat (limited to 'lang')
-rw-r--r--lang/php52/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/lang/php52/Makefile b/lang/php52/Makefile
index 51b88f751228..1a331750cc3b 100644
--- a/lang/php52/Makefile
+++ b/lang/php52/Makefile
@@ -7,6 +7,7 @@
PORTNAME= php52
PORTVERSION= 5.2.17
+PORTREVISION= 1
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP}
MASTER_SITE_SUBDIR= distributions
@@ -46,7 +47,8 @@ OPTIONS= CLI "Build CLI version" on \
DISCARD "Enable discard-path support (CGI only)" off \
FASTCGI "Enable fastcgi support (CGI only)" on \
FPM "Enable fastcgi process manager (CGI only)" off \
- PATHINFO "Enable path-info-check support (CGI only)" on
+ PATHINFO "Enable path-info-check support (CGI only)" on \
+ LINKTHR "Link thread lib (for threaded extensions)" off
CONFLICTS= php4-4* php5-5.3*
@@ -170,6 +172,10 @@ CONFIGURE_ENV+= ac_cv_pthreads_lib="" \
MAKE_ENV+= LDFLAGS="${LDFLAGS}"
+.if defined(WITH_LINKTHR)
+CONFIGURE_ENV+= LIBS="${LIBS} ${PTHREAD_LIBS}"
+.endif
+
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+=--enable-debug
.endif