aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2005-06-14 22:27:20 +0800
committerale <ale@FreeBSD.org>2005-06-14 22:27:20 +0800
commit7ffebada9dbe1d0bf4d035907c6a36a6c619efbf (patch)
tree7fb92d167d7d112f81b4dcbdbfb57577cbc76478 /lang
parenta0e7d80955d09fc0ac15e23369641d6a574574ee (diff)
downloadfreebsd-ports-gnome-7ffebada9dbe1d0bf4d035907c6a36a6c619efbf.tar.gz
freebsd-ports-gnome-7ffebada9dbe1d0bf4d035907c6a36a6c619efbf.tar.zst
freebsd-ports-gnome-7ffebada9dbe1d0bf4d035907c6a36a6c619efbf.zip
Fix oracle extension.
PR: ports/81382 Submitted by: Simun Mikecin <sime@logos.hr>
Diffstat (limited to 'lang')
-rw-r--r--lang/php4/Makefile.ext11
-rw-r--r--lang/php5/Makefile.ext10
-rw-r--r--lang/php53/Makefile.ext10
3 files changed, 27 insertions, 4 deletions
diff --git a/lang/php4/Makefile.ext b/lang/php4/Makefile.ext
index 002a91252647..75c153c20bee 100644
--- a/lang/php4/Makefile.ext
+++ b/lang/php4/Makefile.ext
@@ -32,7 +32,6 @@ CONFIGURE_ARGS+=--enable-calendar
.if ${PHP_MODNAME} == "crack"
BUILD_DEPENDS+= ${LOCALBASE}/lib/libcrack.a:${PORTSDIR}/security/cracklib
-RUN_DEPENDS+= ${LOCALBASE}/lib/libcrack.a:${PORTSDIR}/security/cracklib
CONFIGURE_ARGS+=--with-crack=${LOCALBASE}
.endif
@@ -242,7 +241,6 @@ USE_OPENSSL= yes
.if ${PHP_MODNAME} == "oracle"
BUILD_DEPENDS+= ${LOCALBASE}/oracle7/lib/libcore3.a:${PORTSDIR}/databases/oracle7-client
-RUN_DEPENDS+= ${LOCALBASE}/oracle7/lib/libcore3.a:${PORTSDIR}/databases/oracle7-client
CONFIGURE_ARGS+=--with-oracle=${LOCALBASE}/oracle7
.endif
@@ -450,6 +448,15 @@ post-extract:
@${MV} ${WRKSRC}/config0.m4 ${WRKSRC}/config.m4
.endif
+.if ${PHP_MODNAME} == "oracle"
+post-patch:
+ @cd ${WRKSRC}; \
+ for lib in c3v6 client common core3 epc generic ncr nlsrtl3 sqlnet wrap; do \
+ /usr/bin/ar x ${LOCALBASE}/oracle7/lib/lib$${lib}.a; \
+ done; \
+ /usr/bin/ar rcs liboracle.a *.o
+.endif
+
.if ${PHP_MODNAME} == "snmp"
. if defined(WITH_SNMP4) || exists(${LOCALBASE}/lib/libsnmp.so.4)
LIB_DEPENDS+= snmp.4:${PORTSDIR}/net-mgmt/net-snmp4
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index d627640750fe..c3774d39f8fb 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -238,7 +238,6 @@ USE_OPENSSL= yes
.if ${PHP_MODNAME} == "oracle"
BUILD_DEPENDS+= ${LOCALBASE}/oracle7/lib/libcore3.a:${PORTSDIR}/databases/oracle7-client
-RUN_DEPENDS+= ${LOCALBASE}/oracle7/lib/libcore3.a:${PORTSDIR}/databases/oracle7-client
CONFIGURE_ARGS+=--with-oracle=${LOCALBASE}/oracle7
.endif
@@ -458,6 +457,15 @@ post-extract:
@${MV} ${WRKSRC}/config0.m4 ${WRKSRC}/config.m4
.endif
+.if ${PHP_MODNAME} == "oracle"
+post-patch:
+ @cd ${WRKSRC}; \
+ for lib in c3v6 client common core3 epc generic ncr nlsrtl3 sqlnet wrap; do \
+ /usr/bin/ar x ${LOCALBASE}/oracle7/lib/lib$${lib}.a; \
+ done; \
+ /usr/bin/ar rcs liboracle.a *.o
+.endif
+
.if ${PHP_MODNAME} == "snmp"
. if defined(WITH_SNMP4) || exists(${LOCALBASE}/lib/libsnmp.so.4)
LIB_DEPENDS+= snmp.4:${PORTSDIR}/net-mgmt/net-snmp4
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index d627640750fe..c3774d39f8fb 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -238,7 +238,6 @@ USE_OPENSSL= yes
.if ${PHP_MODNAME} == "oracle"
BUILD_DEPENDS+= ${LOCALBASE}/oracle7/lib/libcore3.a:${PORTSDIR}/databases/oracle7-client
-RUN_DEPENDS+= ${LOCALBASE}/oracle7/lib/libcore3.a:${PORTSDIR}/databases/oracle7-client
CONFIGURE_ARGS+=--with-oracle=${LOCALBASE}/oracle7
.endif
@@ -458,6 +457,15 @@ post-extract:
@${MV} ${WRKSRC}/config0.m4 ${WRKSRC}/config.m4
.endif
+.if ${PHP_MODNAME} == "oracle"
+post-patch:
+ @cd ${WRKSRC}; \
+ for lib in c3v6 client common core3 epc generic ncr nlsrtl3 sqlnet wrap; do \
+ /usr/bin/ar x ${LOCALBASE}/oracle7/lib/lib$${lib}.a; \
+ done; \
+ /usr/bin/ar rcs liboracle.a *.o
+.endif
+
.if ${PHP_MODNAME} == "snmp"
. if defined(WITH_SNMP4) || exists(${LOCALBASE}/lib/libsnmp.so.4)
LIB_DEPENDS+= snmp.4:${PORTSDIR}/net-mgmt/net-snmp4