aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2013-07-09 20:51:31 +0800
committervanilla <vanilla@FreeBSD.org>2013-07-09 20:51:31 +0800
commit82bc058a967afbff0ecfe891d7d984f63e0375a9 (patch)
tree1049a639232d5ef3787b16c3988638f880a7b966 /lang
parente7590868bf9e78dd0b5df57b2c2611524de3cdc5 (diff)
downloadfreebsd-ports-gnome-82bc058a967afbff0ecfe891d7d984f63e0375a9.tar.gz
freebsd-ports-gnome-82bc058a967afbff0ecfe891d7d984f63e0375a9.tar.zst
freebsd-ports-gnome-82bc058a967afbff0ecfe891d7d984f63e0375a9.zip
Upgrade to 0.7.
PR: ports/180405 Submitted by: maintainer
Diffstat (limited to 'lang')
-rw-r--r--lang/rust/Makefile11
-rw-r--r--lang/rust/distinfo8
-rw-r--r--lang/rust/files/llvm.patch8
-rw-r--r--lang/rust/files/log2.patch88
-rw-r--r--lang/rust/files/patch-mk_platform.mk8
-rw-r--r--lang/rust/pkg-plist30
6 files changed, 79 insertions, 74 deletions
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index f554cd1a917e..63f43f1a7dd8 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= rust
-PORTVERSION= 0.6
+PORTVERSION= 0.7
CATEGORIES= lang
MASTER_SITES= http://static.rust-lang.org/dist/:src \
http://static.rust-lang.org/stage0-snapshots/:boot
@@ -15,14 +15,13 @@ COMMENT= A language with a focus on memory safety and concurrency
RUST_SOURCE= ${DISTNAME}${EXTRACT_SUFX}
RUST_BOOT= rust-stage0-${RUST_BOOT_SIG}.tar.bz2
-RUST_BOOT_SIG= 2013-03-28-f7a2371-freebsd-x86_64-01f1e4b94504045e763eecb71c7e0852f6e85036
+RUST_BOOT_SIG= 2013-06-23-f827561-freebsd-x86_64-a05bdda2d9ec0e66336d81b98bee8a95442a501f
RUST_TARGET= x86_64-unknown-freebsd
ONLY_FOR_ARCHS= amd64
HAS_CONFIGURE= yes
USE_LDCONFIG= yes
USE_GMAKE= yes
-MAKE_JOBS_SAFE= yes
USE_PERL5_BUILD= yes
USE_PYTHON_BUILD= 2.6-2.7
@@ -35,7 +34,8 @@ OPTIONS_DEFAULT= RUSTPKG
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 900044
-EXTRA_PATCHES+= ${FILESDIR}/log2.patch
+EXTRA_PATCHES+= ${FILESDIR}/log2.patch \
+ ${FILESDIR}/llvm.patch
.endif
.if ${OSVERSION} >= 900044
@@ -48,8 +48,7 @@ USE_GCC= yes
.endif
.if ${PORT_OPTIONS:MRUSTPKG}
-RUN_DEPENDS+= curl:${PORTSDIR}/ftp/curl \
- git:${PORTSDIR}/devel/git
+RUN_DEPENDS+= git:${PORTSDIR}/devel/git
PLIST_SUB+= RUSTPKG=""
.else
PLIST_SUB+= RUSTPKG="@comment "
diff --git a/lang/rust/distinfo b/lang/rust/distinfo
index ddd42e6979e8..1eb08501ace3 100644
--- a/lang/rust/distinfo
+++ b/lang/rust/distinfo
@@ -1,4 +1,4 @@
-SHA256 (rust-0.6.tar.gz) = e11cb529a1e20f27d99033181a9e0e131817136b46d2742f0fa1afa1210053e5
-SIZE (rust-0.6.tar.gz) = 23595432
-SHA256 (rust-stage0-2013-03-28-f7a2371-freebsd-x86_64-01f1e4b94504045e763eecb71c7e0852f6e85036.tar.bz2) = 2e4afca52678f6004573beb01a72084c4118cc1ac813a171bfcace35cf873cc6
-SIZE (rust-stage0-2013-03-28-f7a2371-freebsd-x86_64-01f1e4b94504045e763eecb71c7e0852f6e85036.tar.bz2) = 16732821
+SHA256 (rust-0.7.tar.gz) = 0b88b8a4489382e0a69214eaab88e2e7c316ec33c164af0d3b53630b17590df0
+SIZE (rust-0.7.tar.gz) = 14494878
+SHA256 (rust-stage0-2013-06-23-f827561-freebsd-x86_64-a05bdda2d9ec0e66336d81b98bee8a95442a501f.tar.bz2) = 7fb723176c88539311692406f80817300f87560d47f96d229ab5efa527cc6fe2
+SIZE (rust-stage0-2013-06-23-f827561-freebsd-x86_64-a05bdda2d9ec0e66336d81b98bee8a95442a501f.tar.bz2) = 19028080
diff --git a/lang/rust/files/llvm.patch b/lang/rust/files/llvm.patch
new file mode 100644
index 000000000000..3f93528518f0
--- /dev/null
+++ b/lang/rust/files/llvm.patch
@@ -0,0 +1,8 @@
+--- src/llvm/unittests/ExecutionEngine/JIT/JITTests.def.orig 2013-07-09 08:30:41.112596275 +0800
++++ src/llvm/unittests/ExecutionEngine/JIT/JITTests.def 2013-07-09 09:57:30.773783840 +0800
+@@ -2,3 +2,5 @@
+ getPointerToNamedFunction
+ JITTest_AvailableExternallyFunction
+ JITTest_AvailableExternallyGlobal
++__progname
++environ
diff --git a/lang/rust/files/log2.patch b/lang/rust/files/log2.patch
index d6054b3b5ef5..a45919aa87f8 100644
--- a/lang/rust/files/log2.patch
+++ b/lang/rust/files/log2.patch
@@ -1,66 +1,62 @@
---- src/libcore/num/cmath.rs.orig 2013-04-06 12:52:09.596039132 +0800
-+++ src/libcore/num/cmath.rs 2013-04-06 12:53:24.474452681 +0800
-@@ -64,7 +64,6 @@
+--- src/libstd/num/cmath.rs.orig 2013-07-09 10:33:09.079593770 +0800
++++ src/libstd/num/cmath.rs 2013-07-09 10:33:30.174857926 +0800
+@@ -66,7 +66,6 @@
// renamed: to be consitent with log as ln
- #[link_name="log1p"] unsafe fn ln1p(n: c_double) -> c_double;
+ #[link_name="log1p"] unsafe fn ln_1p(n: c_double) -> c_double;
unsafe fn log10(n: c_double) -> c_double;
- unsafe fn log2(n: c_double) -> c_double;
#[link_name="ilogb"] unsafe fn ilog_radix(n: c_double) -> c_int;
unsafe fn modf(n: c_double, iptr: &mut c_double) -> c_double;
unsafe fn pow(n: c_double, e: c_double) -> c_double;
-@@ -148,7 +147,6 @@
+@@ -150,7 +149,6 @@
#[link_name="logf"] unsafe fn ln(n: c_float) -> c_float;
#[link_name="logbf"] unsafe fn log_radix(n: c_float) -> c_float;
- #[link_name="log1pf"] unsafe fn ln1p(n: c_float) -> c_float;
+ #[link_name="log1pf"] unsafe fn ln_1p(n: c_float) -> c_float;
- #[link_name="log2f"] unsafe fn log2(n: c_float) -> c_float;
#[link_name="log10f"] unsafe fn log10(n: c_float) -> c_float;
#[link_name="ilogbf"] unsafe fn ilog_radix(n: c_float) -> c_int;
#[link_name="modff"] unsafe fn modf(n: c_float,
---- src/libcore/num/f32.rs.orig 2013-04-06 12:52:15.395037527 +0800
-+++ src/libcore/num/f32.rs 2013-04-06 13:00:55.623679761 +0800
-@@ -81,7 +81,6 @@
- cmath::c_float_utils::log_radix)
- delegate!(fn ln1p(n: c_float) -> c_float = cmath::c_float_utils::ln1p)
- delegate!(fn log10(n: c_float) -> c_float = cmath::c_float_utils::log10)
--delegate!(fn log2(n: c_float) -> c_float = cmath::c_float_utils::log2)
- delegate!(fn ilog_radix(n: c_float) -> c_int =
- cmath::c_float_utils::ilog_radix)
- delegate!(fn modf(n: c_float, iptr: &mut c_float) -> c_float =
-@@ -254,7 +253,12 @@
+--- src/libstd/num/f32.rs.orig 2013-07-09 10:33:13.385594163 +0800
++++ src/libstd/num/f32.rs 2013-07-09 10:43:27.147593687 +0800
+@@ -60,7 +60,6 @@
+ fn floor(x: f32) -> f32 = intrinsics::floorf32,
+ fn ln(n: f32) -> f32 = intrinsics::logf32,
+ fn log10(n: f32) -> f32 = intrinsics::log10f32,
+- fn log2(n: f32) -> f32 = intrinsics::log2f32,
+ fn mul_add(a: f32, b: f32, c: f32) -> f32 = intrinsics::fmaf32,
+ fn pow(n: f32, e: f32) -> f32 = intrinsics::powf32,
+ fn powi(n: f32, e: c_int) -> f32 = intrinsics::powif32,
+@@ -158,6 +157,11 @@
+ if x <= y || y.is_NaN() { x } else { y }
+ }
- #[inline(always)]
- pub fn logarithm(n: f32, b: f32) -> f32 {
-- return log2(n) / log2(b);
-+ return ln(n) / ln(b);
++#[inline]
++pub fn log2(n: f32) -> f32 {
++ ln(n) / consts::ln_2
+}
+
-+#[inline(always)]
-+pub fn log2(n: f32) -> f32 {
-+ return ln(n) / consts::ln_2;
- }
- #[cfg(notest)]
---- src/libcore/num/f64.rs.orig 2013-04-06 12:52:25.866037307 +0800
-+++ src/libcore/num/f64.rs 2013-04-06 13:02:33.051357016 +0800
-@@ -82,7 +82,6 @@
- cmath::c_double_utils::log_radix)
- delegate!(fn ln1p(n: c_double) -> c_double = cmath::c_double_utils::ln1p)
- delegate!(fn log10(n: c_double) -> c_double = cmath::c_double_utils::log10)
--delegate!(fn log2(n: c_double) -> c_double = cmath::c_double_utils::log2)
- delegate!(fn ilog_radix(n: c_double) -> c_int =
- cmath::c_double_utils::ilog_radix)
- delegate!(fn modf(n: c_double, iptr: &mut c_double) -> c_double =
-@@ -276,7 +275,12 @@
+ // FIXME (#1999): replace the predicates below with llvm intrinsics or
+ // calls to the libmath macros in the rust runtime for performance.
+--- src/libstd/num/f64.rs.orig 2013-07-09 10:33:18.415594640 +0800
++++ src/libstd/num/f64.rs 2013-07-09 10:41:42.289594525 +0800
+@@ -62,7 +62,6 @@
+ fn floor(x: f64) -> f64 = intrinsics::floorf64,
+ fn ln(n: f64) -> f64 = intrinsics::logf64,
+ fn log10(n: f64) -> f64 = intrinsics::log10f64,
+- fn log2(n: f64) -> f64 = intrinsics::log2f64,
+ fn mul_add(a: f64, b: f64, c: f64) -> f64 = intrinsics::fmaf64,
+ fn pow(n: f64, e: f64) -> f64 = intrinsics::powf64,
+ fn powi(n: f64, e: c_int) -> f64 = intrinsics::powif64,
+@@ -184,6 +183,11 @@
+ if x <= y || y.is_NaN() { x } else { y }
+ }
- #[inline(always)]
- pub fn logarithm(n: f64, b: f64) -> f64 {
-- return log2(n) / log2(b);
-+ return ln(n) / ln(b);
++#[inline]
++pub fn log2(n: f64) -> f64 {
++ ln(n) / consts::ln_2
+}
+
-+#[inline(always)]
-+pub fn log2(n: f64) -> f64 {
-+ return ln(n) / consts::ln_2;
- }
+ // FIXME (#1999): add is_normal, is_subnormal, and fpclassify
- #[cfg(notest)]
+ /* Module: consts */
diff --git a/lang/rust/files/patch-mk_platform.mk b/lang/rust/files/patch-mk_platform.mk
index 7aafd3ac0abc..18ebc51783f6 100644
--- a/lang/rust/files/patch-mk_platform.mk
+++ b/lang/rust/files/patch-mk_platform.mk
@@ -1,11 +1,11 @@
---- mk/platform.mk.orig 2013-04-06 12:47:35.924036199 +0800
-+++ mk/platform.mk 2013-04-06 12:48:04.696038055 +0800
-@@ -299,7 +299,7 @@
+--- mk/platform.mk.orig 2013-07-09 00:57:39.009593612 +0800
++++ mk/platform.mk 2013-07-09 00:57:55.526200080 +0800
+@@ -375,7 +375,7 @@
CFG_LIB_NAME_x86_64-unknown-freebsd=lib$(1).so
CFG_LIB_GLOB_x86_64-unknown-freebsd=lib$(1)-*.so
CFG_LIB_DSYM_GLOB_x86_64-unknown-freebsd=$(1)-*.dylib.dSYM
-CFG_GCCISH_CFLAGS_x86_64-unknown-freebsd := -Wall -Werror -g -fPIC -I/usr/local/include
+CFG_GCCISH_CFLAGS_x86_64-unknown-freebsd := -Wall -g -fPIC -I/usr/local/include
- CFG_GCCISH_LINK_FLAGS_x86_64-unknown-freebsd := -shared -fPIC -g -lpthread -lrt
+ CFG_GCCISH_LINK_FLAGS_x86_64-unknown-freebsd := -shared -fPIC -g -pthread -lrt
CFG_GCCISH_DEF_FLAG_x86_64-unknown-freebsd := -Wl,--export-dynamic,--dynamic-list=
CFG_GCCISH_PRE_LIB_FLAGS_x86_64-unknown-freebsd := -Wl,-whole-archive
diff --git a/lang/rust/pkg-plist b/lang/rust/pkg-plist
index c1daa5985949..10ff07d7eb95 100644
--- a/lang/rust/pkg-plist
+++ b/lang/rust/pkg-plist
@@ -3,24 +3,26 @@ bin/rustc
bin/rustdoc
bin/rusti
%%RUSTPKG%%bin/rustpkg
-lib/libcore-c3ca5d77d81b46c1-0.6.so
-lib/librust-39583f72884834e3-0.6.so
-lib/librustc-c84825241471686d-0.6.so
-lib/librusti-5047c7f210c7cac8-0.6.so
+lib/libextra-a7c050cfd46b2c9a-0.7.so
+lib/librust-8d2fe0c0fe8188b-0.7.so
+lib/librustc-d3cb8c2ccd84a7a7-0.7.so
+lib/librustdoc-6b49af4948607d84-0.7.so
+lib/librusti-53e0ef2ae196aaff-0.7.so
lib/librustllvm.so
+lib/librustpkg-38a86178bd95e7e1-0.7.so
lib/librustrt.so
-lib/libstd-4782a756585a81-0.6.so
-lib/libsyntax-84efebcb12c867a2-0.6.so
-lib/rustc/x86_64-unknown-freebsd/lib/libcore-c3ca5d77d81b46c1-0.6.so
+lib/libstd-6c65cf4b443341b1-0.7.so
+lib/libsyntax-64629f7f0c6a9bc-0.7.so
+lib/rustc/x86_64-unknown-freebsd/lib/libextra-a7c050cfd46b2c9a-0.7.so
lib/rustc/x86_64-unknown-freebsd/lib/libmorestack.a
-lib/rustc/x86_64-unknown-freebsd/lib/librust-39583f72884834e3-0.6.so
-lib/rustc/x86_64-unknown-freebsd/lib/librustc-c84825241471686d-0.6.so
-lib/rustc/x86_64-unknown-freebsd/lib/librustdoc-1ac3c0763957e4b0-0.6.so
-lib/rustc/x86_64-unknown-freebsd/lib/librusti-5047c7f210c7cac8-0.6.so
-lib/rustc/x86_64-unknown-freebsd/lib/librustpkg-795073e423d025b-0.6.so
+lib/rustc/x86_64-unknown-freebsd/lib/librust-8d2fe0c0fe8188b-0.7.so
+lib/rustc/x86_64-unknown-freebsd/lib/librustc-d3cb8c2ccd84a7a7-0.7.so
+lib/rustc/x86_64-unknown-freebsd/lib/librustdoc-6b49af4948607d84-0.7.so
+lib/rustc/x86_64-unknown-freebsd/lib/librusti-53e0ef2ae196aaff-0.7.so
+lib/rustc/x86_64-unknown-freebsd/lib/librustpkg-38a86178bd95e7e1-0.7.so
lib/rustc/x86_64-unknown-freebsd/lib/librustrt.so
-lib/rustc/x86_64-unknown-freebsd/lib/libstd-4782a756585a81-0.6.so
-lib/rustc/x86_64-unknown-freebsd/lib/libsyntax-84efebcb12c867a2-0.6.so
+lib/rustc/x86_64-unknown-freebsd/lib/libstd-6c65cf4b443341b1-0.7.so
+lib/rustc/x86_64-unknown-freebsd/lib/libsyntax-64629f7f0c6a9bc-0.7.so
@dirrm lib/rustc/x86_64-unknown-freebsd/lib
@dirrm lib/rustc/x86_64-unknown-freebsd
@dirrm lib/rustc