aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-07-28 22:10:10 +0800
committermarino <marino@FreeBSD.org>2014-07-28 22:10:10 +0800
commit8b77130c5ae63106de5e845d45c463a188ae2d53 (patch)
tree47b7bd52144037438780491e2a6846648c32bed5 /lang
parent2d2c8c25fbc0c268f495dc1f68c3cdea18d0b557 (diff)
downloadfreebsd-ports-gnome-8b77130c5ae63106de5e845d45c463a188ae2d53.tar.gz
freebsd-ports-gnome-8b77130c5ae63106de5e845d45c463a188ae2d53.tar.zst
freebsd-ports-gnome-8b77130c5ae63106de5e845d45c463a188ae2d53.zip
lang/squeak: Claimed fix for PowerPC
I've no way to test this, but it supposedly fixes the PowerPC build. Submitter has been notified the port will be removed due to lack of staging soon. PR: 184580 Submitted by: jrh29 (alumni.cwru.edu) Approved by: maintainer timeout (8 months) Approved by: portmgr (implicit, NO_STAGE)
Diffstat (limited to 'lang')
-rw-r--r--lang/squeak/Makefile2
-rw-r--r--lang/squeak/files/patch-unix_vm_sqUnixMain.c13
2 files changed, 14 insertions, 1 deletions
diff --git a/lang/squeak/Makefile b/lang/squeak/Makefile
index 674b2d02ef54..073967ef830d 100644
--- a/lang/squeak/Makefile
+++ b/lang/squeak/Makefile
@@ -45,7 +45,7 @@ NO_STAGE= yes
##################################################
DIST_SUBDIR= squeak
-ONLY_FOR_ARCHS= i386 amd64
+ONLY_FOR_ARCHS= i386 amd64 powerpc
MAN1= squeak.1
USE_GCC= any
USE_GL= gl
diff --git a/lang/squeak/files/patch-unix_vm_sqUnixMain.c b/lang/squeak/files/patch-unix_vm_sqUnixMain.c
new file mode 100644
index 000000000000..269d2a0b98bb
--- /dev/null
+++ b/lang/squeak/files/patch-unix_vm_sqUnixMain.c
@@ -0,0 +1,13 @@
+--- unix/vm/sqUnixMain.c.bak 2013-12-05 13:49:51 -0800
++++ unix/vm/sqUnixMain.c
+@@ -1334,8 +1334,8 @@
+ || defined(POWERPC) || defined(__POWERPC) || defined (__POWERPC__) )
+ void mtfsfi(unsigned long long fpscr)
+ {
+- __asm__("lfd f0, %0" :: "m"(fpscr));
+- __asm__("mtfsf 0xff, f0");
++ __asm__("lfd 0, %0" :: "m"(fpscr));
++ __asm__("mtfsf 0xff, 0");
+ }
+ #else
+ # define mtfsfi(fpscr)