aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-01-25 06:08:25 +0800
committermiwi <miwi@FreeBSD.org>2007-01-25 06:08:25 +0800
commit8d5cc345689d0af32edcb06f7c676db25e07e923 (patch)
tree9e85a89af162fff7e1cd7735eb5b50d9969b6f6d /lang
parent782ab92c3bae58402222b6b2f3106053f9d07abf (diff)
downloadfreebsd-ports-gnome-8d5cc345689d0af32edcb06f7c676db25e07e923.tar.gz
freebsd-ports-gnome-8d5cc345689d0af32edcb06f7c676db25e07e923.tar.zst
freebsd-ports-gnome-8d5cc345689d0af32edcb06f7c676db25e07e923.zip
- Fix build with gcc 4.1
Diffstat (limited to 'lang')
-rw-r--r--lang/smalltalk/Makefile1
-rw-r--r--lang/smalltalk/files/patch-snprintfv-snprintfv-format.c20
2 files changed, 21 insertions, 0 deletions
diff --git a/lang/smalltalk/Makefile b/lang/smalltalk/Makefile
index 5128ca422746..f6c9fec859ed 100644
--- a/lang/smalltalk/Makefile
+++ b/lang/smalltalk/Makefile
@@ -7,6 +7,7 @@
PORTNAME= smalltalk
PORTVERSION= 2.3.1
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/lang/smalltalk/files/patch-snprintfv-snprintfv-format.c b/lang/smalltalk/files/patch-snprintfv-snprintfv-format.c
new file mode 100644
index 000000000000..d73974342bd4
--- /dev/null
+++ b/lang/smalltalk/files/patch-snprintfv-snprintfv-format.c
@@ -0,0 +1,20 @@
+--- snprintfv/snprintfv/format.c.orig Thu Jan 18 11:46:33 2007
++++ snprintfv/snprintfv/format.c Thu Jan 18 11:51:54 2007
+@@ -54,7 +54,7 @@
+ # define isinfl(x) isnanl ((x) - (x))
+ # endif
+ # ifndef HAVE_MODFL
+-static snv_long_double modfl (long double x, long double *exp);
++snv_long_double modfl (long double x, long double *exp);
+ # endif
+ # ifndef HAVE_COPYSIGNL
+ static snv_long_double copysignl (long double x, long double y);
+@@ -1097,7 +1097,7 @@
+
+ #if !defined NO_FLOAT_PRINTING && defined HAVE_LONG_DOUBLE
+ # ifndef HAVE_MODFL
+-static long double modfl (long double x, long double *exp)
++long double modfl (long double x, long double *exp)
+ {
+ /* To compute the integer part of a positive integer (in this case
+ abs(X)), sum a big enough integer to the absolute value, so that