aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2014-04-22 20:14:26 +0800
committerkoobs <koobs@FreeBSD.org>2014-04-22 20:14:26 +0800
commit8dd14dc444bdc9c01e7e57c63e6b0b20045c92a8 (patch)
tree2226051bf99bde369767be57f56156ee325743e8 /lang
parent00bd427fc1d02bf17f78e3ffbafa65e2ca699ff2 (diff)
downloadfreebsd-ports-gnome-8dd14dc444bdc9c01e7e57c63e6b0b20045c92a8.tar.gz
freebsd-ports-gnome-8dd14dc444bdc9c01e7e57c63e6b0b20045c92a8.tar.zst
freebsd-ports-gnome-8dd14dc444bdc9c01e7e57c63e6b0b20045c92a8.zip
lang/python{31,32,33}: Fix stage/package as non-root
Copy the second part of a change previously made to python27 [1], to python31, python32 and python33. This fixes staging and packaging of these ports by a non-root user by running ranlib on the archive prior to it being installed read-only. While I'm here: - python27: Add breadcrumbs and references to the patch header - python34: Update breadcrumbs and references to the patch header [1] https://svnweb.freebsd.org/ports?view=revision&revision=350207 Submitted by: antoine Reviewed by: kwm, sbz
Diffstat (limited to 'lang')
-rw-r--r--lang/python27/files/patch-Makefile.pre.in12
-rw-r--r--lang/python31/files/patch-Makefile.pre.in16
-rw-r--r--lang/python32/files/patch-Makefile.pre.in26
-rw-r--r--lang/python33/files/patch-Makefile.pre.in32
-rw-r--r--lang/python34/files/patch-Makefile.pre.in6
5 files changed, 81 insertions, 11 deletions
diff --git a/lang/python27/files/patch-Makefile.pre.in b/lang/python27/files/patch-Makefile.pre.in
index 4963357e5b51..c0358eef5ca2 100644
--- a/lang/python27/files/patch-Makefile.pre.in
+++ b/lang/python27/files/patch-Makefile.pre.in
@@ -1,3 +1,15 @@
+# Description: Fix out-of-tree build as a result of upstream #15819
+# Submitted by: rm (r318353)
+# Issue ID: http://bugs.python.org/issue15819#msg203348
+
+# Description: Run pycompile only once
+# Submitted by: antoine (r350207)
+# TODO: ?
+
+# Description: Run ranlib before installing the library read-only
+# Submitted by: antoine@ (r350207)
+# TODO: Upstream
+
--- ./Makefile.pre.in.orig 2013-11-10 07:36:41.000000000 +0000
+++ ./Makefile.pre.in 2014-04-04 09:16:00.000000000 +0000
@@ -285,9 +285,9 @@
diff --git a/lang/python31/files/patch-Makefile.pre.in b/lang/python31/files/patch-Makefile.pre.in
new file mode 100644
index 000000000000..1979cfa34049
--- /dev/null
+++ b/lang/python31/files/patch-Makefile.pre.in
@@ -0,0 +1,16 @@
+# Description: Run ranlib before installing the library read-only
+# Submitted by: antoine@ (r350207)
+# TODO: Upstream
+
+--- ./Makefile.pre.in.orig 2014-04-20 23:22:37.435954278 +1000
++++ ./Makefile.pre.in 2014-04-20 23:23:10.767071278 +1000
+@@ -985,8 +985,8 @@
+ if test "$(SO)" = .dll; then \
+ $(INSTALL_DATA) $(LDLIBRARY) $(DESTDIR)$(LIBPL) ; \
+ else \
++ $(RANLIB) $(LIBRARY) ; \
+ $(INSTALL_DATA) $(LIBRARY) $(DESTDIR)$(LIBPL)/$(LIBRARY) ; \
+- $(RANLIB) $(DESTDIR)$(LIBPL)/$(LIBRARY) ; \
+ fi; \
+ else \
+ echo Skip install of $(LIBRARY) - use make frameworkinstall; \
diff --git a/lang/python32/files/patch-Makefile.pre.in b/lang/python32/files/patch-Makefile.pre.in
index 997211fbf9a8..60c15542e123 100644
--- a/lang/python32/files/patch-Makefile.pre.in
+++ b/lang/python32/files/patch-Makefile.pre.in
@@ -1,5 +1,17 @@
---- Makefile.pre.in.orig 2013-05-16 02:33:51.000000000 +1000
-+++ Makefile.pre.in 2013-09-05 23:42:32.910025692 +1000
+# Description: Remove duplicate CFLAGS, CPPFLAGS, LDFLAGS by stripping CONFIGURE_*
+# Submitted by: koobs (r326729)
+# TODO: Upstream
+
+# Description: Fix out-of-tree build as a result of upstream #15819
+# Submitted by: rm (r318353)
+# Issue ID: http://bugs.python.org/issue15819#msg203348
+
+# Description: Run ranlib before installing the library read-only
+# Submitted by: antoine@ (r350207)
+# TODO: Upstream
+
+--- ./Makefile.pre.in.orig 2013-05-16 02:33:51.000000000 +1000
++++ ./Makefile.pre.in 2014-04-20 23:27:06.346079817 +1000
@@ -70,18 +70,18 @@
OPT= @OPT@
BASECFLAGS= @BASECFLAGS@
@@ -69,3 +81,13 @@
############################################################################
# Header files
+@@ -1108,8 +1108,8 @@
+ if test "$(SHLIB_SUFFIX)" = .dll; then \
+ $(INSTALL_DATA) $(LDLIBRARY) $(DESTDIR)$(LIBPL) ; \
+ else \
++ $(RANLIB) $(LIBRARY) ; \
+ $(INSTALL_DATA) $(LIBRARY) $(DESTDIR)$(LIBPL)/$(LIBRARY) ; \
+- $(RANLIB) $(DESTDIR)$(LIBPL)/$(LIBRARY) ; \
+ fi; \
+ else \
+ echo Skip install of $(LIBRARY) - use make frameworkinstall; \
diff --git a/lang/python33/files/patch-Makefile.pre.in b/lang/python33/files/patch-Makefile.pre.in
index 6f49f6e25e59..71d2e5fcc63b 100644
--- a/lang/python33/files/patch-Makefile.pre.in
+++ b/lang/python33/files/patch-Makefile.pre.in
@@ -1,5 +1,17 @@
---- Makefile.pre.in.orig 2013-05-16 02:32:57.000000000 +1000
-+++ Makefile.pre.in 2013-09-05 23:48:22.439871947 +1000
+# Description: Remove duplicate CFLAGS, CPPFLAGS, LDFLAGS by stripping CONFIGURE_*
+# Submitted by: koobs (r326729)
+# TODO: Upstream
+
+# Description: Fix out-of-tree build as a result of upstream #15819
+# Submitted by: rm (r318353)
+# Issue ID: http://bugs.python.org/issue15819#msg203348
+
+# Description: Run ranlib before installing the library read-only
+# Submitted by: antoine@ (r350207)
+# TODO: Upstream
+
+--- ./Makefile.pre.in.orig 2014-03-09 19:40:23.000000000 +1100
++++ ./Makefile.pre.in 2014-04-20 23:28:30.086226530 +1000
@@ -70,18 +70,18 @@
OPT= @OPT@
BASECFLAGS= @BASECFLAGS@
@@ -25,7 +37,7 @@
NO_AS_NEEDED= @NO_AS_NEEDED@
LDLAST= @LDLAST@
SGI_ABI= @SGI_ABI@
-@@ -306,21 +306,21 @@
+@@ -310,21 +310,21 @@
##########################################################################
# AST
@@ -51,7 +63,7 @@
OPCODETARGETGEN= \
$(srcdir)/Python/makeopcodetargets.py
-@@ -742,7 +742,7 @@
+@@ -747,7 +747,7 @@
Objects/setobject.o: $(srcdir)/Objects/stringlib/eq.h
$(OPCODETARGETS_H): $(OPCODETARGETGEN_FILES)
@@ -60,7 +72,7 @@
Python/ceval.o: $(OPCODETARGETS_H) $(srcdir)/Python/ceval_gil.h
-@@ -753,7 +753,7 @@
+@@ -758,7 +758,7 @@
Objects/typeobject.o: Objects/typeslots.inc
Objects/typeslots.inc: $(srcdir)/Include/typeslots.h $(srcdir)/Objects/typeslots.py
@@ -69,3 +81,13 @@
############################################################################
# Header files
+@@ -1205,8 +1205,8 @@
+ if test "$(SHLIB_SUFFIX)" = .dll; then \
+ $(INSTALL_DATA) $(LDLIBRARY) $(DESTDIR)$(LIBPL) ; \
+ else \
++ $(RANLIB) $(LIBRARY) ; \
+ $(INSTALL_DATA) $(LIBRARY) $(DESTDIR)$(LIBPL)/$(LIBRARY) ; \
+- $(RANLIB) $(DESTDIR)$(LIBPL)/$(LIBRARY) ; \
+ fi; \
+ else \
+ echo Skip install of $(LIBRARY) - use make frameworkinstall; \
diff --git a/lang/python34/files/patch-Makefile.pre.in b/lang/python34/files/patch-Makefile.pre.in
index 66c65e8407c9..2b820e254797 100644
--- a/lang/python34/files/patch-Makefile.pre.in
+++ b/lang/python34/files/patch-Makefile.pre.in
@@ -1,11 +1,9 @@
# Description: Remove duplicate CFLAGS, CPPFLAGS, LDFLAGS by stripping CONFIGURE_*
-# Changeset: https://svnweb.freebsd.org/ports?view=revision&revision=326729
-# Submitted by: koobs@
+# Submitted by: koobs (r326729)
# TODO: Upstream
# Description: Run ranlib before installing the library read-only
-# Changeset: https://svnweb.freebsd.org/ports?view=revision&revision=350207
-# Submitted by: antoine@
+# Submitted by: antoine@ (r350207)
# TODO: Upstream
--- ./Makefile.pre.in.orig 2014-03-17 13:31:30.000000000 +1100