aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-07-21 20:36:08 +0800
committermat <mat@FreeBSD.org>2015-07-21 20:36:08 +0800
commit998aeec5619344dc494d6b9f7c442f9fbc86246d (patch)
tree813a02089a8c36891ab85e8b436089f511f62444 /lang
parent51dac20db902f33f66538ae056e1a9e8cd3cca66 (diff)
downloadfreebsd-ports-gnome-998aeec5619344dc494d6b9f7c442f9fbc86246d.tar.gz
freebsd-ports-gnome-998aeec5619344dc494d6b9f7c442f9fbc86246d.tar.zst
freebsd-ports-gnome-998aeec5619344dc494d6b9f7c442f9fbc86246d.zip
Convert the post-patch target to use the new target option helpers.
While there, remove some DEBUG handling that is already done in bsd.port.mk. Sponsored by: Absolight
Diffstat (limited to 'lang')
-rw-r--r--lang/perl5-devel/Makefile10
-rw-r--r--lang/perl5.18/Makefile11
-rw-r--r--lang/perl5.20/Makefile11
-rw-r--r--lang/perl5.22/Makefile11
4 files changed, 14 insertions, 29 deletions
diff --git a/lang/perl5-devel/Makefile b/lang/perl5-devel/Makefile
index 2879d49c304f..40e77aaff873 100644
--- a/lang/perl5-devel/Makefile
+++ b/lang/perl5-devel/Makefile
@@ -186,11 +186,6 @@ PKGINSTALL= ${WRKDIR}/use.perl
PKGDEINSTALL= ${WRKDIR}/use.perl
.endif
-.if ${PORT_OPTIONS:MDEBUG}
-STRIP=
-STRIP_CMD= ${TRUE}
-.endif
-
# XXX
# No need to spam logs, or make me wait
.if !defined(PACKAGE_BUILDING) && !defined(PERL_DEV_SHUT_UP)
@@ -221,13 +216,12 @@ post-extract:
post-patch:
${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
${WRKSRC}/Configure ${WRKSRC}/hints/freebsd.sh
-.if ${PORT_OPTIONS:MPTHREAD}
+post-patch-PTHREAD-on:
${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|-lpthread|g;' \
${WRKSRC}/hints/freebsd.sh
-.else
+post-patch-PTHREAD-off:
${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%||g;' \
${WRKSRC}/hints/freebsd.sh
-.endif
.endif # MAKING_PATCHES
post-install:
diff --git a/lang/perl5.18/Makefile b/lang/perl5.18/Makefile
index c34cb7485a42..55b2fa3c5f5b 100644
--- a/lang/perl5.18/Makefile
+++ b/lang/perl5.18/Makefile
@@ -161,11 +161,6 @@ PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
PRIV_LIB=${_PRIV_LIB} \
ARCH_LIB=${_ARCH_LIB}
-.if ${PORT_OPTIONS:MDEBUG}
-STRIP=
-STRIP_CMD= ${TRUE}
-.endif
-
.if ${OSVERSION} >= 900022
PLIST_SUB+= MANCONF=""
.else
@@ -184,13 +179,15 @@ post-extract:
${LN} -s libperl.so.${PERL_VERSION} ${WRKSRC}/libperl.so
${LN} -s libperl.so.${PERL_VERSION} ${WRKSRC}/libperl.so.${PERL_VER}
+.if !defined(MAKING_PATCHES)
+# make clean patch makepatch MAKING_PATCHES=
post-patch:
${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
${WRKSRC}/Configure ${WRKSRC}/hints/freebsd.sh
-.if ${PORT_OPTIONS:MPTHREAD}
+post-patch-PTHREAD-on:
${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|-lpthread|g;' \
${WRKSRC}/hints/freebsd.sh
-.else
+post-patch-PTHREAD-off:
${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%||g;' \
${WRKSRC}/hints/freebsd.sh
.endif
diff --git a/lang/perl5.20/Makefile b/lang/perl5.20/Makefile
index 758e3e3838dd..11a7f986e4ab 100644
--- a/lang/perl5.20/Makefile
+++ b/lang/perl5.20/Makefile
@@ -169,23 +169,20 @@ PKGINSTALL= ${WRKDIR}/use.perl
PKGDEINSTALL= ${WRKDIR}/use.perl
.endif
-.if ${PORT_OPTIONS:MDEBUG}
-STRIP=
-STRIP_CMD= ${TRUE}
-.endif
-
# Put a symlink to the future libperl.so.x.yy so that -lperl works.
post-extract:
${LN} -s libperl.so.${PERL_VERSION} ${WRKSRC}/libperl.so
${LN} -s libperl.so.${PERL_VERSION} ${WRKSRC}/libperl.so.${PERL_VER}
+.if !defined(MAKING_PATCHES)
+# make clean patch makepatch MAKING_PATCHES=
post-patch:
${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
${WRKSRC}/Configure ${WRKSRC}/hints/freebsd.sh
-.if ${PORT_OPTIONS:MPTHREAD}
+post-patch-PTHREAD-on:
${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|-lpthread|g;' \
${WRKSRC}/hints/freebsd.sh
-.else
+post-patch-PTHREAD-off:
${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%||g;' \
${WRKSRC}/hints/freebsd.sh
.endif
diff --git a/lang/perl5.22/Makefile b/lang/perl5.22/Makefile
index 8803efedc82c..b228f6675cbc 100644
--- a/lang/perl5.22/Makefile
+++ b/lang/perl5.22/Makefile
@@ -166,23 +166,20 @@ PKGINSTALL= ${WRKDIR}/use.perl
PKGDEINSTALL= ${WRKDIR}/use.perl
.endif
-.if ${PORT_OPTIONS:MDEBUG}
-STRIP=
-STRIP_CMD= ${TRUE}
-.endif
-
# Put a symlink to the future libperl.so.x.yy so that -lperl works.
post-extract:
${LN} -s libperl.so.${PERL_VERSION} ${WRKSRC}/libperl.so
${LN} -s libperl.so.${PERL_VERSION} ${WRKSRC}/libperl.so.${PERL_VER}
+.if !defined(MAKING_PATCHES)
+# make clean patch makepatch MAKING_PATCHES=
post-patch:
${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
${WRKSRC}/Configure ${WRKSRC}/hints/freebsd.sh
-.if ${PORT_OPTIONS:MPTHREAD}
+post-patch-PTHREAD-on:
${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|-lpthread|g;' \
${WRKSRC}/hints/freebsd.sh
-.else
+post-patch-PTHREAD-off:
${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%||g;' \
${WRKSRC}/hints/freebsd.sh
.endif