aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2014-11-11 06:17:45 +0800
committerpgj <pgj@FreeBSD.org>2014-11-11 06:17:45 +0800
commit9c10f8f08a013235f7f298c2a91e5116bf5aa9ed (patch)
treec00bd38830978b44a16c1384fb0d756e08f5e861 /lang
parentf89ee2344f76c20289c98bb41ab7163507e5ac33 (diff)
downloadfreebsd-ports-gnome-9c10f8f08a013235f7f298c2a91e5116bf5aa9ed.tar.gz
freebsd-ports-gnome-9c10f8f08a013235f7f298c2a91e5116bf5aa9ed.tar.zst
freebsd-ports-gnome-9c10f8f08a013235f7f298c2a91e5116bf5aa9ed.zip
- Remove @dirrm* from (often automatically generated) plists of GHC and
all the Haskell Cabal ports Obtained from: FreeBSD Haskell
Diffstat (limited to 'lang')
-rw-r--r--lang/ghc/Makefile4
-rw-r--r--lang/ghc/bsd.cabal.mk11
-rw-r--r--lang/ghc/pkg-plist8
3 files changed, 1 insertions, 22 deletions
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index 50d0b1062d9b..d86f729691b0 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -259,10 +259,6 @@ post-install-script:
.if ${PORT_OPTIONS:MDOCS}
@${ECHO} '@exec ${SH} -c "cd %D/${DOCSDIR_REL}/html/libraries && ./gen_contents_index"' >> ${TMPPLIST}
.endif
- @${FIND} -ds ${STAGEDIR}${DOCSDIR} -type d -print | ${SED} -E -e \
- 's,^${STAGEDIR}${PREFIX}/?,@dirrm ,' >> ${TMPPLIST}
- @${FIND} -ds ${GHC_LIBDIR} -type d -print | ${SED} -E -e \
- 's,^${STAGEDIR}${PREFIX}/?,@dirrm ,' >> ${TMPPLIST}
post-patch:
@${REINPLACE_CMD} -e 's|%%CC%%|${CC}|; \
diff --git a/lang/ghc/bsd.cabal.mk b/lang/ghc/bsd.cabal.mk
index f1d1f414c9fb..0985865f190c 100644
--- a/lang/ghc/bsd.cabal.mk
+++ b/lang/ghc/bsd.cabal.mk
@@ -303,18 +303,9 @@ post-install-script:
.for exe in ${EXECUTABLE}
@${ECHO_CMD} 'bin/${exe}' >>${TMPPLIST}
.endfor
-.if defined(STANDALONE) && !${PORT_OPTIONS:MDYNAMIC}
- @for dir in lib share share/doc share/examples; do \
- if [ -d ${STAGEDIR}${PREFIX}/$${dir}/cabal/ghc-${GHC_VERSION} ]; then \
- echo "@dirrmtry $${dir}/cabal/ghc-${GHC_VERSION}" >> ${TMPPLIST}; fi ; \
- if [ -d ${STAGEDIR}${PREFIX}/$${dir}/cabal ]; then \
- echo "@dirrmtry $${dir}/cabal" >> ${TMPPLIST}; fi ; done
-.endif
.endif # EXECUTABLE
@for dir in ${CABAL_DIRS}; do if [ -d ${STAGEDIR}$${dir} ]; then ${FIND} -ds ${STAGEDIR}$${dir} \
- -type f -print | ${SED} -E -e 's,^${STAGEDIR}${PREFIX}/?,,' >> ${TMPPLIST}; fi ; \
- if [ -d ${STAGEDIR}$${dir} ]; then ${FIND} -ds ${STAGEDIR}$${dir} \
- -type d -print | ${SED} -E -e 's,^${STAGEDIR}${PREFIX}/?,@dirrm ,' >> ${TMPPLIST}; fi ; done
+ -type f -print | ${SED} -E -e 's,^${STAGEDIR}${PREFIX}/?,,' >> ${TMPPLIST}; fi ; done
.endif # target(post-install-script)
.if !defined(METAPORT)
diff --git a/lang/ghc/pkg-plist b/lang/ghc/pkg-plist
index 601fe49d83d6..3e79bdd3ac88 100644
--- a/lang/ghc/pkg-plist
+++ b/lang/ghc/pkg-plist
@@ -18,11 +18,3 @@ bin/runghc-%%GHC_VERSION%%
@exec /bin/mkdir -p %D/share/cabal/ghc-%%GHC_VERSION%% || return true
@exec /bin/mkdir -p %D/share/doc/cabal/ghc-%%GHC_VERSION%% || return true
@exec /bin/mkdir -p %D/share/examples/cabal/ghc-%%GHC_VERSION%% || return true
-@dirrmtry lib/cabal/ghc-%%GHC_VERSION%%
-@dirrmtry lib/cabal
-@dirrmtry share/cabal/ghc-%%GHC_VERSION%%
-@dirrmtry share/cabal
-@dirrmtry share/doc/cabal/ghc-%%GHC_VERSION%%
-@dirrmtry share/doc/cabal
-@dirrmtry share/examples/cabal/ghc-%%GHC_VERSION%%
-@dirrmtry share/examples/cabal