aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-05-14 02:47:42 +0800
committermarino <marino@FreeBSD.org>2014-05-14 02:47:42 +0800
commita0390c65844321551495294d5a3fb5957492eb3e (patch)
treebc96e16444a120a014d7749ad51480b0a351b44b /lang
parent875cfa767fde1aeac9a8a7952200f36ba95bf837 (diff)
downloadfreebsd-ports-gnome-a0390c65844321551495294d5a3fb5957492eb3e.tar.gz
freebsd-ports-gnome-a0390c65844321551495294d5a3fb5957492eb3e.tar.zst
freebsd-ports-gnome-a0390c65844321551495294d5a3fb5957492eb3e.zip
lang/gcc-aux: Require latest binutils for DF 3.6 and earlier
Based on observations from pkgsrc and recent failures on Dragonfly 3.6, it appears that GCC 4.9 requires a linker from binutils 2.23 or later. DF 3.6 uses binutils 2.22 while the master branch uses 2.24 by default. This adds the binutils requirement for DF 3.6 and earlier.
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc-aux/Makefile23
-rw-r--r--lang/gcc-aux/Makefile.version2
2 files changed, 17 insertions, 8 deletions
diff --git a/lang/gcc-aux/Makefile b/lang/gcc-aux/Makefile
index 71cbeb5d1a1f..d65e04cab273 100644
--- a/lang/gcc-aux/Makefile
+++ b/lang/gcc-aux/Makefile
@@ -40,7 +40,7 @@ TESTSUITE_DESC= Activate test support
STATIC_DESC= Link compilers and drivers statically
BOOTSTRAP_DESC= Create bootstrap compiler (overrides other options)
-# The BOOTSTRAP option overrides all the others. "make stage" will build a
+# The BOOTSTRAP option overrides all the others. "make stage" will build a
# static compiler that supports C, C++, and Ada languages and then create
# a new distfile in $WRKDIR/newbsd with the name following the pattern:
# ada-bootstrap.$ARCH.$OPSYS.XY.tar.bz2. There is no need to "make install"
@@ -48,10 +48,7 @@ BOOTSTRAP_DESC= Create bootstrap compiler (overrides other options)
.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD
-USE_BINUTILS= yes
-RUN_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
-EXTRA_CONFIG+= --with-ld=${LOCALBASE}/bin/ld
-EXTRA_CONFIG+= --with-as=${LOCALBASE}/bin/as
+MODERN_BINUTILS= yes
. if ${OSVERSION} < 900000
BOOTSTRAP_COMPILER= ada-bootstrap.${GARCH}.freebsd.84.tar.bz2
. else
@@ -59,9 +56,21 @@ BOOTSTRAP_COMPILER= ada-bootstrap.${GARCH}.freebsd.100B.tar.bz2
. endif
.endif
.if ${OPSYS} == DragonFly
+. if ${OSREL:S/.//} < 37
+MODERN_BINUTILS= yes
+. endif
+BOOTSTRAP_COMPILER= ada-bootstrap.${GARCH}.dragonfly.36A.tar.bz2
+.endif
+
+.if defined(MODERN_BINUTILS)
+# Apparently gcc 4.9 needs binutils 2.23 or greater to link Ada correctly
+USE_BINUTILS= yes
+RUN_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
+EXTRA_CONFIG+= --with-ld=${LOCALBASE}/bin/ld
+EXTRA_CONFIG+= --with-as=${LOCALBASE}/bin/as
+.else
EXTRA_CONFIG+= --with-ld=/usr/bin/ld
EXTRA_CONFIG+= --with-as=/usr/bin/as
-BOOTSTRAP_COMPILER= ada-bootstrap.${GARCH}.dragonfly.36A.tar.bz2
.endif
WRKSRC= ${WRKDIR}/${IDENTIFICATION}
@@ -252,7 +261,7 @@ do-install:
cd ${BUILDDIR} && ${SETENV} ${ADA_MAKE_ENV} \
${MAKE_CMD} install-strip ${MAKE_ARGS}
${MV} ${STAGEDIR}${PKG_PREFIX}/share ${WRKDIR}/moved_share
- ${MKDIR} -p ${STAGEDIR}${PREFIX}/share/dejagnu/baseboards \
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/dejagnu/baseboards \
${STAGEDIR}${PREFIX}/share/dejagnu/config
${INSTALL_DATA} ${FILESDIR}/android.exp \
${STAGEDIR}${PREFIX}/share/dejagnu/config
diff --git a/lang/gcc-aux/Makefile.version b/lang/gcc-aux/Makefile.version
index a1610221bb76..813055f1c839 100644
--- a/lang/gcc-aux/Makefile.version
+++ b/lang/gcc-aux/Makefile.version
@@ -4,7 +4,7 @@ GCC_BRANCH= 4.9
GCC_POINT= 0
GCC_VERSION= ${GCC_BRANCH}.${GCC_POINT}
SNAPSHOT= 20140422
-MAIN_PR= 0
+MAIN_PR= 1
ARMV5_PR= 0
ARMV7_PR= 0