aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-03-23 07:49:34 +0800
committerpav <pav@FreeBSD.org>2004-03-23 07:49:34 +0800
commita86758cab843441f0af2d4030c0a2d781719ec26 (patch)
tree876f42c1d311e0c590b7424cbf07e2545c84384d /lang
parent5877275c39222eace74eeaa55ae1adafc4f8f21d (diff)
downloadfreebsd-ports-gnome-a86758cab843441f0af2d4030c0a2d781719ec26.tar.gz
freebsd-ports-gnome-a86758cab843441f0af2d4030c0a2d781719ec26.tar.zst
freebsd-ports-gnome-a86758cab843441f0af2d4030c0a2d781719ec26.zip
- Replace nasty [A-Za-hj-z] with a recursive cp. Not that elegant but it
works under all locales. Approved by: maintainer
Diffstat (limited to 'lang')
-rw-r--r--lang/ocaml/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/lang/ocaml/Makefile b/lang/ocaml/Makefile
index bd4ce0d50fa5..dd1a2abadd56 100644
--- a/lang/ocaml/Makefile
+++ b/lang/ocaml/Makefile
@@ -98,10 +98,8 @@ post-install:
@${MKDIR} ${EXAMPLESDIR}/camltk/images
@cd ${WRKSRC}/otherlibs/labltk/examples_labltk; \
${INSTALL_DATA} * ${EXAMPLESDIR}/labltk
- @cd ${WRKSRC}/otherlibs/labltk/examples_camltk/images; \
- ${INSTALL_DATA} * ${EXAMPLESDIR}/camltk/images
- @cd ${WRKSRC}/otherlibs/labltk/examples_camltk; \
- ${INSTALL_DATA} [A-Za-hj-z]* ${EXAMPLESDIR}/camltk
+ @${CP} -r ${WRKSRC}/otherlibs/labltk/examples_camltk/* \
+ ${EXAMPLESDIR}/camltk
.endif
.for prog in camlp4o.opt camlp4r.opt ocamlc.opt ocamldep.opt ocamldoc.opt \
ocamllex.opt ocamlopt.opt ocamlrun ocamlyacc