aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-07-29 06:58:33 +0800
committermarino <marino@FreeBSD.org>2014-07-29 06:58:33 +0800
commitafc4ca0cb23c4b5a8bf7a88eaf0d63cb9c4beffa (patch)
tree98abe2da85ac50fe6184511cafc395b8dce0887c /lang
parent3c85bd315df366206e3fdba9fc70031df2c426f8 (diff)
downloadfreebsd-ports-gnome-afc4ca0cb23c4b5a8bf7a88eaf0d63cb9c4beffa.tar.gz
freebsd-ports-gnome-afc4ca0cb23c4b5a8bf7a88eaf0d63cb9c4beffa.tar.zst
freebsd-ports-gnome-afc4ca0cb23c4b5a8bf7a88eaf0d63cb9c4beffa.zip
lang/rust: Fix link issue and build failure
[1] Linking fails with missing reference to __morestack symbol [2] gpy fails with error about missing sem implementation PR: 189357 [1] PR: 191927 [2] Submitted by: bertrand.augereau (gmail) [1] Submitted by: maintainer: mitsuruike (gmail) [2]
Diffstat (limited to 'lang')
-rw-r--r--lang/rust/Makefile3
-rw-r--r--lang/rust/files/patch-src__libuv__gyp_uv.py12
2 files changed, 15 insertions, 0 deletions
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index e26bcf38875a..ad68dea2ec7f 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -3,6 +3,7 @@
PORTNAME= rust
PORTVERSION= 0.11.0
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= http://static.rust-lang.org/dist/:src \
http://static.rust-lang.org/stage0-snapshots/:bootstrap
@@ -59,5 +60,7 @@ post-install:
@${RM} ${STAGEDIR}${PREFIX}/lib/rustlib/manifest
@${STRIP_CMD} `${GREP} -v -e '^@dirrm' -e '^man' -e 'rlib$$' \
${PLIST} | ${SED} 's:^:${STAGEDIR}${PREFIX}/:'`
+ @${STRIP_CMD} `${GREP} -v -e '^@dirrm' -e '^man' -e 'rlib$$' \
+ -e '\.a$$' ${PLIST} | ${SED} 's:^:${STAGEDIR}${PREFIX}/:g'`
.include <bsd.port.post.mk>
diff --git a/lang/rust/files/patch-src__libuv__gyp_uv.py b/lang/rust/files/patch-src__libuv__gyp_uv.py
new file mode 100644
index 000000000000..fdb69da9c7c5
--- /dev/null
+++ b/lang/rust/files/patch-src__libuv__gyp_uv.py
@@ -0,0 +1,12 @@
+--- ./src/libuv/gyp_uv.py.orig 2014-06-28 04:53:11.000000000 +0900
++++ ./src/libuv/gyp_uv.py 2014-07-17 12:32:13.000000000 +0900
+@@ -96,6 +96,9 @@
+
+ if sys.platform == 'darwin' and '-DOS=android' in sys.argv[1:]:
+ sys.platform='linux'
++
++ if sys.platform.startswith('freebsd'):
++ args.append('--no-parallel')
+
+ gyp_args = list(args)
+ print gyp_args