aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2016-04-03 19:20:55 +0800
committerpi <pi@FreeBSD.org>2016-04-03 19:20:55 +0800
commitba73dd9abcf3a97334cbdd70d10a24032053a152 (patch)
tree2ee9d15b6c57af3e98fd5d608e75d485fede34a4 /lang
parentfdecd9f7d102a7faf7b8a47c89767b8987772262 (diff)
downloadfreebsd-ports-gnome-ba73dd9abcf3a97334cbdd70d10a24032053a152.tar.gz
freebsd-ports-gnome-ba73dd9abcf3a97334cbdd70d10a24032053a152.tar.zst
freebsd-ports-gnome-ba73dd9abcf3a97334cbdd70d10a24032053a152.zip
lang/parrot: 7.9.0 -> 8.1.0
2016-02-16 release 8.1.0 - Core + Annotate needed -Wcast-align fixes (for early armv5 systems) - Documentation + Fixed typo in move_buffer_callback doc + Add missing hyperref package for latex - Tests + Restore make configure_tests, remove outdated t/steps/auto/labs-01.t 2015-12-15 release 7.11.0 - Build + Improve darwin and cygwin build, seperate installable libparrot. GH #1212, 1096 + Honor --disable-rpath on darwin, skip -install_name then + Update default cygwin compiler and linker to gcc with 1.7 + Add darwin and windows smokers (travis + appveyor), prev. linux only + use a smaller default target: core (most parrot_utils, not all) make all builds now all, including docs and installables 2015-11-17 release 7.10.0 - Documentation + Accept cperldoc as fallback to perldoc GH #1211
Diffstat (limited to 'lang')
-rw-r--r--lang/parrot/Makefile3
-rw-r--r--lang/parrot/distinfo4
-rw-r--r--lang/parrot/files/patch-src_atomic_gcc__x86.c20
3 files changed, 24 insertions, 3 deletions
diff --git a/lang/parrot/Makefile b/lang/parrot/Makefile
index 2909e207da49..c1c310955bd4 100644
--- a/lang/parrot/Makefile
+++ b/lang/parrot/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= parrot
-PORTVERSION= 7.9.0
+PORTVERSION= 8.1.0
CATEGORIES= lang
MASTER_SITES= ftp://ftp.parrot.org/pub/parrot/releases/supported/${PORTVERSION}/ \
LOCAL/sunpoet
@@ -50,6 +50,7 @@ do-configure:
(cd ${WRKSRC} && ${PERL} ${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS})
post-install:
+ ${RM} ${STAGEDIR}${PREFIX}/lib/inst_libparrot.so.${PORTVERSION}
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/* \
${STAGEDIR}${PREFIX}/lib/libparrot.so.${PORTVERSION} \
${STAGEDIR}${PREFIX}/lib/parrot/${PORTVERSION}/dynext/*.so
diff --git a/lang/parrot/distinfo b/lang/parrot/distinfo
index 467583892f78..07f5694e333a 100644
--- a/lang/parrot/distinfo
+++ b/lang/parrot/distinfo
@@ -1,2 +1,2 @@
-SHA256 (parrot-7.9.0.tar.bz2) = 7c9627666ec51d7e997e582f56b0903d2220bf99dd0f4fd40aae29b462dfbe8a
-SIZE (parrot-7.9.0.tar.bz2) = 4498954
+SHA256 (parrot-8.1.0.tar.bz2) = caf356acab64f4ea50595a846808e81d0be8ada8267afbbeb66ddb3c93cb81d3
+SIZE (parrot-8.1.0.tar.bz2) = 4495502
diff --git a/lang/parrot/files/patch-src_atomic_gcc__x86.c b/lang/parrot/files/patch-src_atomic_gcc__x86.c
new file mode 100644
index 000000000000..3c4b54fbc36b
--- /dev/null
+++ b/lang/parrot/files/patch-src_atomic_gcc__x86.c
@@ -0,0 +1,20 @@
+--- src/atomic/gcc_x86.c.orig 2016-04-03 10:11:30 UTC
++++ src/atomic/gcc_x86.c
+@@ -51,7 +51,7 @@ parrot_i386_cmpxchg(ARGMOD(void *volatil
+ ARGIN_NULLOK(void *update))
+ {
+ ASSERT_ARGS(parrot_i386_cmpxchg)
+-#if defined(PARROT_HAS_AMD64_GCC_CMPXCHG) || __WORDSIZE == 64
++#if defined(PARROT_HAS_AMD64_GCC_CMPXCHG)
+ __asm__ __volatile__("lock\n"
+ "cmpxchgq %1,%2":"=a"(expect):"q"(update), "m"(*ptr),
+ "0"(expect)
+@@ -85,7 +85,7 @@ parrot_i386_xadd(ARGIN(volatile long *l)
+ {
+ ASSERT_ARGS(parrot_i386_xadd)
+ long result = amount;
+-#if defined(PARROT_HAS_AMD64_GCC_CMPXCHG) || __WORDSIZE == 64
++#if defined(PARROT_HAS_AMD64_GCC_CMPXCHG)
+ __asm__ __volatile__("lock\n" "xaddq %0, %1" : "=r"(result), "=m"(*l) :
+ "0"(result), "m"(*l));
+ #elif defined(PARROT_HAS_I386_GCC_CMPXCHG)