aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2012-10-10 06:12:13 +0800
committerlinimon <linimon@FreeBSD.org>2012-10-10 06:12:13 +0800
commitbcc2006e5a05ff46461202f4b3c0a4ac8d86476e (patch)
tree7d9d8595a250c7e5a9a646200945ef2094927620 /lang
parent27befbedb683f9336783ae19591c9b2f5037500d (diff)
downloadfreebsd-ports-gnome-bcc2006e5a05ff46461202f4b3c0a4ac8d86476e.tar.gz
freebsd-ports-gnome-bcc2006e5a05ff46461202f4b3c0a4ac8d86476e.tar.zst
freebsd-ports-gnome-bcc2006e5a05ff46461202f4b3c0a4ac8d86476e.zip
Force numerous ports that fail to build with clang over to instead always
rely on gcc. The patch uses the new USE_GCC=any code in Mk/bsd.gcc.mk to accomplish this. The ports chosen were ports that blocked 2 or more ports from building with clang. (There are several hundred other ports that still fail to build with clang, even with this patch. This is merely one step along the way.) Those interested in fixing these ports with clang, and have clang as their default compiler, can simply set FORCE_BASE_CC_FOR_TESTING=yes. For those who have gcc as their default compiler, this change is believed to cause no change. Hat: portmgr Tested with: multiple runs on amd64-8-exp-bcm and 9-exp-clang, with various combinations of patch/no-patch and flag settings.
Diffstat (limited to 'lang')
-rw-r--r--lang/clisp/Makefile1
-rw-r--r--lang/gcc42/Makefile1
-rw-r--r--lang/gcc44/Makefile1
-rw-r--r--lang/ghc/Makefile1
-rw-r--r--lang/gnatdroid-binutils/Makefile1
-rw-r--r--lang/q/Makefile1
-rw-r--r--lang/sdcc/Makefile1
-rw-r--r--lang/v8/Makefile1
8 files changed, 8 insertions, 0 deletions
diff --git a/lang/clisp/Makefile b/lang/clisp/Makefile
index 3ad3486ebfbe..67bf3ea64382 100644
--- a/lang/clisp/Makefile
+++ b/lang/clisp/Makefile
@@ -21,6 +21,7 @@ LIB_DEPENDS= readline.6:${PORTSDIR}/devel/readline \
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/GNU-GPL
+USE_GCC= any
USE_ICONV= yes
USE_LDCONFIG= yes
USE_GHOSTSCRIPT_BUILD= yes
diff --git a/lang/gcc42/Makefile b/lang/gcc42/Makefile
index d8822aead12a..bc9aba3e005f 100644
--- a/lang/gcc42/Makefile
+++ b/lang/gcc42/Makefile
@@ -30,6 +30,7 @@ LATEST_LINK= gcc${SUFFIX}${PKGNAMESUFFIX}
NOT_FOR_ARCHS= arm powerpc
USE_BISON= build
USE_BZIP2= yes
+USE_GCC= any
USE_GMAKE= yes
USE_ICONV= yes
USE_PERL5_BUILD=yes
diff --git a/lang/gcc44/Makefile b/lang/gcc44/Makefile
index 682dbda59121..d18a514d568a 100644
--- a/lang/gcc44/Makefile
+++ b/lang/gcc44/Makefile
@@ -29,6 +29,7 @@ ONLY_FOR_ARCHS= amd64 i386 sparc64
USE_BINUTILS= yes
USE_BISON= build
USE_BZIP2= yes
+USE_GCC= any
USE_GMAKE= yes
USE_ICONV= yes
USE_PERL5_BUILD=yes
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index e8e5dce48805..c27f5c1a4e02 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -27,6 +27,7 @@ EXAMPLESDIR= ${PREFIX}/share/examples/ghc-${GHC_VERSION}
CONFLICTS= ghc-6.8.* ghc-6.10.* ghc-6.12.* ghc-7.0.* ghc-7.2.*
USE_BZIP2= yes
+USE_GCC= any
LIB_DEPENDS+= gmp.10:${PORTSDIR}/math/gmp
USE_PERL5_BUILD= yes
diff --git a/lang/gnatdroid-binutils/Makefile b/lang/gnatdroid-binutils/Makefile
index d9b26f87c6ca..7aa9f0c7b7ef 100644
--- a/lang/gnatdroid-binutils/Makefile
+++ b/lang/gnatdroid-binutils/Makefile
@@ -21,6 +21,7 @@ BUILD_DEPENDS= gnatdroid-sysroot>=9:${PORTSDIR}/lang/gnatdroid-sysroot \
RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_BZIP2= YES
+USE_GCC= any
USE_GMAKE= YES
HAS_CONFIGURE= YES
NO_MTREE= YES
diff --git a/lang/q/Makefile b/lang/q/Makefile
index 14ae7804608d..2dd40213868d 100644
--- a/lang/q/Makefile
+++ b/lang/q/Makefile
@@ -25,6 +25,7 @@ LIB_DEPENDS= MagickWand.5:${PORTSDIR}/graphics/ImageMagick \
ggi.2:${PORTSDIR}/graphics/libggi
USE_BISON= build
+USE_GCC= any
USE_ICONV= yes
USE_TK= 84+
USE_LDCONFIG= yes
diff --git a/lang/sdcc/Makefile b/lang/sdcc/Makefile
index 21db3fdd734c..6350273500b0 100644
--- a/lang/sdcc/Makefile
+++ b/lang/sdcc/Makefile
@@ -22,6 +22,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/graph/adjacency_list.hpp:${PORTSDIR}/d
CONFLICTS_INSTALL= sdcc-[0-9]*
GNU_CONFIGURE= yes
USE_BZIP2= yes
+USE_GCC= any
USE_GMAKE= yes
OPTIONS_DEFINE= DEVLIB DOCS HC08 MCS51 PIC UCSIM Z80
diff --git a/lang/v8/Makefile b/lang/v8/Makefile
index 06a438f20575..af63c7735ca4 100644
--- a/lang/v8/Makefile
+++ b/lang/v8/Makefile
@@ -16,6 +16,7 @@ COMMENT= Google\'s open source JavaScript engine
LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo
+USE_GCC= any
USE_GMAKE= yes
USE_PYTHON= 2.7+
USE_XZ= yes