aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2000-07-28 18:45:43 +0800
committersobomax <sobomax@FreeBSD.org>2000-07-28 18:45:43 +0800
commitc1162f73f7166754119dd3bbd7d66ef84d311894 (patch)
treee639c6cef2724f27135776002abdb85cccabf530 /lang
parent3e599b7be0b4cdc251811778de08e17b77e31c18 (diff)
downloadfreebsd-ports-gnome-c1162f73f7166754119dd3bbd7d66ef84d311894.tar.gz
freebsd-ports-gnome-c1162f73f7166754119dd3bbd7d66ef84d311894.tar.zst
freebsd-ports-gnome-c1162f73f7166754119dd3bbd7d66ef84d311894.zip
Add ccscript - a state-event driven class extendible C++ script interpreter.
PR: 20229 Submitted by: David Sugar <dyfet@gnu.org>
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/ccscript/Makefile28
-rw-r--r--lang/ccscript/distinfo1
-rw-r--r--lang/ccscript/pkg-comment1
-rw-r--r--lang/ccscript/pkg-descr10
-rw-r--r--lang/ccscript/pkg-plist4
6 files changed, 45 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 4d574ae483ef..280c99f2f78d 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -10,6 +10,7 @@
SUBDIR += bc-gcc
SUBDIR += bwbasic
SUBDIR += caml-light
+ SUBDIR += ccscript
SUBDIR += cim
SUBDIR += clisp
SUBDIR += cmucl
diff --git a/lang/ccscript/Makefile b/lang/ccscript/Makefile
new file mode 100644
index 000000000000..3db6de80186d
--- /dev/null
+++ b/lang/ccscript/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: ccscript
+# Date created: 26 July 2000
+# Whom: David Sugar <dyfet@gnu.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ccscript
+PORTVERSION= 1.1.1
+CATEGORIES= lang
+MASTER_SITES= ftp://www.voxilla.org/pub/ccscript/
+
+MAINTAINER= dyfet@gnu.org
+
+LIB_DEPENDS= ccstd.0:${PORTSDIR}/devel/commoncpp
+
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+USE_AUTOCONF= yes
+INSTALLS_SHLIB= yes
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
+
+post-extract:
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|-release \$$\(LT_RELEASE\)||g'
+
+.include <bsd.port.mk>
diff --git a/lang/ccscript/distinfo b/lang/ccscript/distinfo
new file mode 100644
index 000000000000..34e5ea0c0c62
--- /dev/null
+++ b/lang/ccscript/distinfo
@@ -0,0 +1 @@
+MD5 (ccscript-1.1.1.tar.gz) = 5737dc9946f6e3d6a3c84eda4007dc35
diff --git a/lang/ccscript/pkg-comment b/lang/ccscript/pkg-comment
new file mode 100644
index 000000000000..1bcd12c03e8c
--- /dev/null
+++ b/lang/ccscript/pkg-comment
@@ -0,0 +1 @@
+State-event driven class extendible C++ script interpreter
diff --git a/lang/ccscript/pkg-descr b/lang/ccscript/pkg-descr
new file mode 100644
index 000000000000..9225716dda01
--- /dev/null
+++ b/lang/ccscript/pkg-descr
@@ -0,0 +1,10 @@
+ccscript offers a class extensible threaded script interpreter that may
+be embedded in Common C++ derived packages as a native extension language.
+This script interpreter differs from traditional scripting systems in that
+it is used to script near real-time state-event transitions thru
+deterministic callback step execution rather than the linear and
+non-deterministic fashion of traditional extension languages such as tcl,
+libguile, etc.
+
+- David Sugar
+dyfet@gnu.org
diff --git a/lang/ccscript/pkg-plist b/lang/ccscript/pkg-plist
new file mode 100644
index 000000000000..92153ae1ca3a
--- /dev/null
+++ b/lang/ccscript/pkg-plist
@@ -0,0 +1,4 @@
+include/cc++/script.h
+lib/libccscript.a
+lib/libccscript.so
+lib/libccscript.so.0