aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2017-09-28 05:07:48 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 05:37:26 +0800
commitcadac1feac25b965aff310c02ca101651902056c (patch)
tree249ed89458ab659d70d8214daab9a910fbab8560 /lang
parent4feba0c0b86484ec38a2aec1a8af80f1a7b92a49 (diff)
downloadfreebsd-ports-gnome-cadac1feac25b965aff310c02ca101651902056c.tar.gz
freebsd-ports-gnome-cadac1feac25b965aff310c02ca101651902056c.tar.zst
freebsd-ports-gnome-cadac1feac25b965aff310c02ca101651902056c.zip
Update to the 20170926 snapshot of GCC 5.4.1.
The patches to gcc/auto-profile.c and gcc/graphite-isl-ast-to-gimple.c that were part of files/patch-libc++ have now been backported upstream into this snapshot (in similar form) and thus can (and need to) be removed.
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc5-devel/Makefile2
-rw-r--r--lang/gcc5-devel/distinfo6
-rw-r--r--lang/gcc5-devel/files/patch-libc++33
3 files changed, 4 insertions, 37 deletions
diff --git a/lang/gcc5-devel/Makefile b/lang/gcc5-devel/Makefile
index 4567007d66a2..ae0bec923448 100644
--- a/lang/gcc5-devel/Makefile
+++ b/lang/gcc5-devel/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gcc
-PORTVERSION= 5.4.1.s20170919
+PORTVERSION= 5.4.1.s20170926
CATEGORIES= lang
MASTER_SITES= GCC/snapshots/${DIST_VERSION}
PKGNAMESUFFIX= ${SUFFIX}-devel
diff --git a/lang/gcc5-devel/distinfo b/lang/gcc5-devel/distinfo
index cf3e1f4a8ac5..dfbd87799ca8 100644
--- a/lang/gcc5-devel/distinfo
+++ b/lang/gcc5-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1506026745
-SHA256 (gcc-5-20170919.tar.xz) = d9ab03070d695eed0ab946e2e574d96aa3a3b6cd82c4a4470c4f427e23bb9cad
-SIZE (gcc-5-20170919.tar.xz) = 69384604
+TIMESTAMP = 1506528342
+SHA256 (gcc-5-20170926.tar.xz) = dfa5537341d7efb44f0ce0db93c95012d4d34c9a1fdbbc2f4ddde582cc85ece3
+SIZE (gcc-5-20170926.tar.xz) = 69385412
diff --git a/lang/gcc5-devel/files/patch-libc++ b/lang/gcc5-devel/files/patch-libc++
index 9550b11f7c29..787bf30c7d49 100644
--- a/lang/gcc5-devel/files/patch-libc++
+++ b/lang/gcc5-devel/files/patch-libc++
@@ -1,36 +1,3 @@
---- gcc/auto-profile.c.orig 2015-01-18 02:25:42 UTC
-+++ gcc/auto-profile.c
-@@ -19,11 +19,9 @@ along with GCC; see the file COPYING3.
- <http://www.gnu.org/licenses/>. */
-
- #include "config.h"
--#include "system.h"
--
--#include <string.h>
- #include <map>
- #include <set>
-+#include "system.h"
-
- #include "coretypes.h"
- #include "hash-set.h"
---- gcc/graphite-isl-ast-to-gimple.c.orig 2017-01-19 21:02:12 UTC
-+++ gcc/graphite-isl-ast-to-gimple.c
-@@ -38,6 +38,7 @@ extern "C" {
- #endif
- #endif
-
-+#include <map>
- #include "system.h"
- #include "coretypes.h"
- #include "hash-set.h"
-@@ -75,7 +76,6 @@ extern "C" {
- #include "tree-scalar-evolution.h"
- #include "gimple-ssa.h"
- #include "tree-into-ssa.h"
--#include <map>
-
- #ifdef HAVE_isl
- #include "graphite-poly.h"
--- gcc/system.h.orig 2015-01-05 12:33:28 UTC
+++ gcc/system.h
@@ -217,6 +217,7 @@ extern int errno;