aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2007-03-12 05:54:16 +0800
committerale <ale@FreeBSD.org>2007-03-12 05:54:16 +0800
commitcbd99fa4078473ed8ea0df3f67b640338e84d804 (patch)
tree91741a13d69a9f1d5bff08546b95a91850d20ef5 /lang
parent149618ad111130b120dbb612e1068ade312a86ed (diff)
downloadfreebsd-ports-gnome-cbd99fa4078473ed8ea0df3f67b640338e84d804.tar.gz
freebsd-ports-gnome-cbd99fa4078473ed8ea0df3f67b640338e84d804.tar.zst
freebsd-ports-gnome-cbd99fa4078473ed8ea0df3f67b640338e84d804.zip
Now that we have a utf8-enabled pcre port, let php5-pcre
depend on it. This should also fix PR 109542.
Diffstat (limited to 'lang')
-rw-r--r--lang/php5/Makefile.ext4
-rw-r--r--lang/php53/Makefile.ext4
2 files changed, 4 insertions, 4 deletions
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index 7963d745d379..75d14fc807c6 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -237,9 +237,9 @@ CONFIGURE_ARGS+=--enable-pcntl
.endif
.if ${PHP_MODNAME} == "pcre"
-CONFIGURE_ARGS+=--with-pcre-regex=yes
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
-PHP_HEADER_DIRS=pcrelib
+CONFIGURE_ARGS+=--with-pcre-regex=${LOCALBASE}
.endif
.if ${PHP_MODNAME} == "pdo"
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index 7963d745d379..75d14fc807c6 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -237,9 +237,9 @@ CONFIGURE_ARGS+=--enable-pcntl
.endif
.if ${PHP_MODNAME} == "pcre"
-CONFIGURE_ARGS+=--with-pcre-regex=yes
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
-PHP_HEADER_DIRS=pcrelib
+CONFIGURE_ARGS+=--with-pcre-regex=${LOCALBASE}
.endif
.if ${PHP_MODNAME} == "pdo"