aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2003-10-16 13:36:05 +0800
committerperky <perky@FreeBSD.org>2003-10-16 13:36:05 +0800
commitcc086baa4cf9d26639ca82cc7bfc3a8ba7eef5ef (patch)
treec46ad407dbe917d5596816b16287e0953139ab4a /lang
parente54a665a8463d1eebf5557ecd2cfd2f91fe8c3e9 (diff)
downloadfreebsd-ports-gnome-cc086baa4cf9d26639ca82cc7bfc3a8ba7eef5ef.tar.gz
freebsd-ports-gnome-cc086baa4cf9d26639ca82cc7bfc3a8ba7eef5ef.tar.zst
freebsd-ports-gnome-cc086baa4cf9d26639ca82cc7bfc3a8ba7eef5ef.zip
Add alpha to list of 64bit architectures. (This fixes package
building on alpha) Spotted by: kris
Diffstat (limited to 'lang')
-rw-r--r--lang/python/Makefile2
-rw-r--r--lang/python23/Makefile2
-rw-r--r--lang/python24/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/lang/python/Makefile b/lang/python/Makefile
index f4afc2575e05..46409584b548 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -73,7 +73,7 @@ PLIST_SUB+= X86_ONLY="@comment "
.if ${ARCH} == amd64
CFLAGS+= -fPIC
.endif
-.if ${ARCH} == amd64 || ${ARCH} == ia64 || ${ARCH} == sparc64
+.if ${ARCH} == amd64 || ${ARCH} == ia64 || ${ARCH} == sparc64 || ${ARCH} == alpha
PLIST_SUB+= 32BIT_ONLY="@comment "
.else
PLIST_SUB+= 32BIT_ONLY=""
diff --git a/lang/python23/Makefile b/lang/python23/Makefile
index f4afc2575e05..46409584b548 100644
--- a/lang/python23/Makefile
+++ b/lang/python23/Makefile
@@ -73,7 +73,7 @@ PLIST_SUB+= X86_ONLY="@comment "
.if ${ARCH} == amd64
CFLAGS+= -fPIC
.endif
-.if ${ARCH} == amd64 || ${ARCH} == ia64 || ${ARCH} == sparc64
+.if ${ARCH} == amd64 || ${ARCH} == ia64 || ${ARCH} == sparc64 || ${ARCH} == alpha
PLIST_SUB+= 32BIT_ONLY="@comment "
.else
PLIST_SUB+= 32BIT_ONLY=""
diff --git a/lang/python24/Makefile b/lang/python24/Makefile
index f4afc2575e05..46409584b548 100644
--- a/lang/python24/Makefile
+++ b/lang/python24/Makefile
@@ -73,7 +73,7 @@ PLIST_SUB+= X86_ONLY="@comment "
.if ${ARCH} == amd64
CFLAGS+= -fPIC
.endif
-.if ${ARCH} == amd64 || ${ARCH} == ia64 || ${ARCH} == sparc64
+.if ${ARCH} == amd64 || ${ARCH} == ia64 || ${ARCH} == sparc64 || ${ARCH} == alpha
PLIST_SUB+= 32BIT_ONLY="@comment "
.else
PLIST_SUB+= 32BIT_ONLY=""