aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-11-03 06:45:14 +0800
committermat <mat@FreeBSD.org>2016-11-03 06:45:14 +0800
commitd9ec328e16b795889ee8d72196228f00a0a3393a (patch)
treeadf234bd1f2e56ae130e9960e1467b64c9fa0ed6 /lang
parent759b32261f3c119f1062868d580795d19060e71b (diff)
downloadfreebsd-ports-gnome-d9ec328e16b795889ee8d72196228f00a0a3393a.tar.gz
freebsd-ports-gnome-d9ec328e16b795889ee8d72196228f00a0a3393a.tar.zst
freebsd-ports-gnome-d9ec328e16b795889ee8d72196228f00a0a3393a.zip
Cleanup no longer needed CHMOD usage after r424898.
PR: 213743 Submitted by: mat Exp-run by: antoine Sponsored by: Absolight
Diffstat (limited to 'lang')
-rw-r--r--lang/gscheme/Makefile3
-rw-r--r--lang/guile/Makefile1
-rw-r--r--lang/hla/Makefile10
-rw-r--r--lang/icc/Makefile2
-rw-r--r--lang/mosml/Makefile6
-rw-r--r--lang/rust/Makefile1
-rw-r--r--lang/squirrel/Makefile4
7 files changed, 10 insertions, 17 deletions
diff --git a/lang/gscheme/Makefile b/lang/gscheme/Makefile
index 39e9d8dde531..eeef15b84413 100644
--- a/lang/gscheme/Makefile
+++ b/lang/gscheme/Makefile
@@ -18,9 +18,6 @@ LICENSE= GPLv2+
USES= gnustep
USE_GNUSTEP= back build
-post-extract:
- @${CHMOD} -R u+w ${WRKSRC}
-
post-patch:
@${REINPLACE_CMD} -e 's|setMark:|setMarkScheme:|' \
${WRKSRC}/SchemeTypes.h ${WRKSRC}/SchemeTypes.m
diff --git a/lang/guile/Makefile b/lang/guile/Makefile
index 503da58b1367..f32cf9675c97 100644
--- a/lang/guile/Makefile
+++ b/lang/guile/Makefile
@@ -44,7 +44,6 @@ NLS_USES= gettext
NLS_USES_OFF= gettext-tools
post-extract:
- cd ${WRKSRC}; ${CHMOD} u+w ${REINPLACE_FILES}
@${FIND} ${WRKSRC}/doc -name "*.info*" -delete
post-patch:
diff --git a/lang/hla/Makefile b/lang/hla/Makefile
index 1cf4d49ad8a4..4d1d39580ad9 100644
--- a/lang/hla/Makefile
+++ b/lang/hla/Makefile
@@ -33,11 +33,17 @@ DISTFILES+= HLARef_html${EXTRACT_SUFX} HLAstdlib_html${EXTRACT_SUFX}
DISTFILES+= hello.hla
.endif
+.include <bsd.port.pre.mk>
+
post-extract:
${MKDIR} ${WRKDIR}/stdlib && \
${TAR} -zxf ${_DISTDIR}/bsd.${PORTNAME}.tar.gz -C ${WRKDIR}/stdlib
${CP} ${_DISTDIR}/lex.yy.c ${WRKSRC}
- ${FIND} ${WRKDIR} -type d -exec ${CHMOD} 755 {} \;
+.if ${OSVERSION} < 1100077
+# chmod -R bug.
+# Do not use "-exec ... +", because of the same bug, it will not work.
+ @${FIND} ${WRKDIR} -type d -exec ${CHMOD} 755 {} \;
+.endif
post-extract-TEST-on:
${CP} ${_DISTDIR}/hello.hla ${WRKSRC}
@@ -79,4 +85,4 @@ do-test-TEST-on:
${WRKSRC}/hello \
)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/lang/icc/Makefile b/lang/icc/Makefile
index 7da2a6f6e1e0..4cdab4cdaeb7 100644
--- a/lang/icc/Makefile
+++ b/lang/icc/Makefile
@@ -94,8 +94,6 @@ pre-patch: intel-patch
for i in `${CAT} ${FILESDIR}/exclude_noportdocs`; do \
${RM} -r ${WRKSRC}/opt/${COMPILERDIR}/$$i; done
.endif
-# Allow everyone to use it.
- ${CHMOD} a+rx ${WRKSRC}/opt
# Remove unneeded/unsafe access rights.
.for i in doc include lib
${FIND} ${WRKSRC}/opt/${COMPILERDIR}/${i} -type f -print0 | \
diff --git a/lang/mosml/Makefile b/lang/mosml/Makefile
index 959bac4ac342..64472d0a0a65 100644
--- a/lang/mosml/Makefile
+++ b/lang/mosml/Makefile
@@ -46,10 +46,8 @@ post-install:
${WRKSRC}/../copyrght/gpl2 \
${WRKSRC}/../README ${STAGEDIR}${DOCSDIR}
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- cd ${WRKSRC}/../examples && ${TAR} -cf - --dereference \
- --exclude=\*.orig --exclude=\*.bak --exclude=\*.w32 * | \
- ${TAR} -xf - -C "${STAGEDIR}${EXAMPLESDIR}"
- @${FIND} ${STAGEDIR}${EXAMPLESDIR} -type f -exec ${CHMOD} ${SHAREMODE} {} \;
+ cd ${WRKSRC}/../examples && ${COPYTREE_SHARE} . "${STAGEDIR}${EXAMPLESDIR}" \
+ '-not ( -name *\.orig -o -name *\.bak -o -name *\.w32 )'
@${REINPLACE_CMD} -i '' -e 's|${STAGEDIR}||' \
${STAGEDIR}${PREFIX}/lib/mosml/header
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/mosml/lib*.so
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index 29baa443c055..f295a0f8834a 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -118,7 +118,6 @@ pre-fetch:
post-extract:
@${MKDIR} ${WRKSRC}/dl
${LN} -sf ${DISTDIR}/${RUST_BOOT} ${WRKSRC}/dl
- ${FIND} ${WRKSRC} -type d -exec ${CHMOD} 0755 {} +
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
diff --git a/lang/squirrel/Makefile b/lang/squirrel/Makefile
index b35f955d67f8..9aea441fa114 100644
--- a/lang/squirrel/Makefile
+++ b/lang/squirrel/Makefile
@@ -25,10 +25,6 @@ CFLAGS+= -fPIC
ALL_TARGET= sq32
.endif
-post-extract:
- @${FIND} ${WRKSRC} -type d -exec ${CHMOD} 755 {} \;
- @${FIND} ${WRKSRC} -type f -exec ${CHMOD} 644 {} \;
-
post-patch:
@${FIND} ${WRKSRC} -name Makefile | ${XARGS} ${REINPLACE_CMD} \
-e '/^MAKE/d; s|gcc|$${CC}|; s|-O2|$${CFLAGS}|; s|g++|$${CXX}|' \