aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2017-07-25 22:40:20 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 05:14:17 +0800
commitdd9b71008334c971e0335384540ca22773e5924e (patch)
tree02912c9eaf8939ab2f9b54a320673955097ae847 /lang
parentf94e7713205560aea49d987f18ff2895e437fd56 (diff)
downloadfreebsd-ports-gnome-dd9b71008334c971e0335384540ca22773e5924e.tar.gz
freebsd-ports-gnome-dd9b71008334c971e0335384540ca22773e5924e.tar.zst
freebsd-ports-gnome-dd9b71008334c971e0335384540ca22773e5924e.zip
Allow building of lang/nhc98 with GCC >= 5
PR: 196857 Reported by: gerald Approved by: haskell (maintainer timeout, 2 months+)
Diffstat (limited to 'lang')
-rw-r--r--lang/nhc98/Makefile13
-rw-r--r--lang/nhc98/pkg-plist3
2 files changed, 10 insertions, 6 deletions
diff --git a/lang/nhc98/Makefile b/lang/nhc98/Makefile
index 46a00f317291..1fc18708a7e5 100644
--- a/lang/nhc98/Makefile
+++ b/lang/nhc98/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nhc98
PORTVERSION= 1.22
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang haskell
MASTER_SITES= http://haskell.org/${PORTNAME}/
DISTFILES= ${PORTNAME}src-${PORTVERSION}${EXTRACT_SUFX}
@@ -14,14 +14,11 @@ COMMENT= Fully-fledged compiler for Haskell 98
ONLY_FOR_ARCHS= i386
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-
USES= gmake
-# Fails to build with GCC 4.9, cf. PR 196857.
-USE_GCC= 4.8
+USE_GCC= yes
HAS_CONFIGURE= yes
-CONFIGURE_ARGS+= --prefix=${PREFIX} --heap=4M
+CONFIGURE_ARGS+= --prefix=${PREFIX} --heap=4M --buildwith=gcc
MAKE_ARGS+= ARCH=
MAKE_JOBS_UNSAFE= yes
@@ -35,6 +32,10 @@ CONFLICTS= hs-cpphs-[0-9]*
post-patch:
@${REINPLACE_CMD} -e 's|-O3|${CFLAGS}|' ${WRKSRC}/Makefile.inc
+# The Makefile defines target names based on $(CC) which is
+# problematic when CC=gcc5. The following patch does not affect the
+# compiler used during the build, but makes sure that targets have
+# the correct suffix e.g. 'basic-gcc' instead of 'basic-gcc5':
@${REINPLACE_CMD} -e 's|$$(CC)|gcc|g' ${WRKSRC}/Makefile
post-configure:
diff --git a/lang/nhc98/pkg-plist b/lang/nhc98/pkg-plist
index 7f622226f24e..1107f388ee7e 100644
--- a/lang/nhc98/pkg-plist
+++ b/lang/nhc98/pkg-plist
@@ -224,6 +224,8 @@ include/nhc98/packages/base/Text/Printf.hi
include/nhc98/packages/base/Text/Read.hi
include/nhc98/packages/base/Text/Show.hi
include/nhc98/packages/base/Text/Show/Functions.hi
+@dir include/nhc98/packages/base/Text/Html
+@dir include/nhc98/packages/base/Text/Regex
include/nhc98/packages/base/Typeable.h
include/nhc98/packages/base/Unsafe/Coerce.hi
include/nhc98/packages/bytestring.cabal
@@ -249,6 +251,7 @@ include/nhc98/packages/filepath.cabal
include/nhc98/packages/filepath/System/FilePath.hi
include/nhc98/packages/filepath/System/FilePath/Posix.hi
include/nhc98/packages/filepath/System/FilePath/Windows.hi
+@dir include/nhc98/packages/haskell98
include/nhc98/packages/haskell98.cabal
include/nhc98/packages/old-locale.cabal
include/nhc98/packages/old-locale/System/Locale.hi