aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorjeh <jeh@FreeBSD.org>2001-02-14 21:22:36 +0800
committerjeh <jeh@FreeBSD.org>2001-02-14 21:22:36 +0800
commite9e5029d9c4803144e8ad40336586b6d9aa76e86 (patch)
tree326910cb1dba55f7e64231f90f29f21dc50aa7a9 /lang
parentb9340b8946aa5f06ce011187a0e4153cfaf9d264 (diff)
downloadfreebsd-ports-gnome-e9e5029d9c4803144e8ad40336586b6d9aa76e86.tar.gz
freebsd-ports-gnome-e9e5029d9c4803144e8ad40336586b6d9aa76e86.tar.zst
freebsd-ports-gnome-e9e5029d9c4803144e8ad40336586b6d9aa76e86.zip
New Port: lang/cel
Cel is a computer language. In particular it is of the prototype-based, object oriented variety. PR: 23996 Submitted by: George Reid <greid@ukug.uk.freebsd.org>
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/cel/Makefile34
-rw-r--r--lang/cel/distinfo1
-rw-r--r--lang/cel/files/patch-aa7
-rw-r--r--lang/cel/pkg-comment1
-rw-r--r--lang/cel/pkg-descr11
-rw-r--r--lang/cel/pkg-plist15
7 files changed, 70 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 54f921f46a89..2a01959d8168 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -11,6 +11,7 @@
SUBDIR += bwbasic
SUBDIR += caml-light
SUBDIR += ccscript
+ SUBDIR += cel
SUBDIR += cim
SUBDIR += clisp
SUBDIR += cmucl
diff --git a/lang/cel/Makefile b/lang/cel/Makefile
new file mode 100644
index 000000000000..12119e1a5253
--- /dev/null
+++ b/lang/cel/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: cel
+# Date created: 1 January 2001
+# Whom: George Reid <greid@ukug.uk.freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cel
+PORTVERSION= 0.5
+CATEGORIES= lang
+MASTER_SITES= http://www.redwoodsoft.com/cel/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= greid@ukug.uk.freebsd.org
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_GMAKE= yes
+
+DOCFILES= CoreArchitecture.html Credits DefaultProtos \
+ Linker.html Logs.html ProtoLanguage.html README \
+ SimpleDataFormat.html Threads activation.html \
+ stackframe structure.html todo.html
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/vm/aq ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/cel
+.for F in ${DOCFILES}
+ ${INSTALL_DATA} ${WRKSRC}/doc/$F ${PREFIX}/share/doc/cel
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/lang/cel/distinfo b/lang/cel/distinfo
new file mode 100644
index 000000000000..e81be6c3f5f2
--- /dev/null
+++ b/lang/cel/distinfo
@@ -0,0 +1 @@
+MD5 (cel-0.5.tgz) = 666ff6e2bd7245fb83130a9f67d42055
diff --git a/lang/cel/files/patch-aa b/lang/cel/files/patch-aa
new file mode 100644
index 000000000000..7fb234043ceb
--- /dev/null
+++ b/lang/cel/files/patch-aa
@@ -0,0 +1,7 @@
+--- Makefile.notreal Thu Jan 1 01:00:00 1970
++++ Makefile Mon Jan 1 16:25:56 2001
+@@ -0,0 +1,4 @@
++all:
++ cd aqmalloc; ${MAKE}
++ cd hash; ${MAKE} libhash.a
++ cd vm; ${MAKE}
diff --git a/lang/cel/pkg-comment b/lang/cel/pkg-comment
new file mode 100644
index 000000000000..0d0b66e39ab6
--- /dev/null
+++ b/lang/cel/pkg-comment
@@ -0,0 +1 @@
+A small, simple prototype-based OO language
diff --git a/lang/cel/pkg-descr b/lang/cel/pkg-descr
new file mode 100644
index 000000000000..b26715cf7fef
--- /dev/null
+++ b/lang/cel/pkg-descr
@@ -0,0 +1,11 @@
+Cel is a computer language. In particular it is of the
+prototype-based, object oriented variety.
+
+It was meant to be high-level, small, simple, and very OO. It's
+syntax is very similar to Self (which is almost like Smalltalk).
+Cel was influenced primarily by the language Self. Other strong
+influencers were Smalltalk, Forth, Newtonscript, Objective-C, and
+Python.
+
+- George Reid
+greid@ukug.uk.freebsd.org
diff --git a/lang/cel/pkg-plist b/lang/cel/pkg-plist
new file mode 100644
index 000000000000..361af532a3a9
--- /dev/null
+++ b/lang/cel/pkg-plist
@@ -0,0 +1,15 @@
+bin/aq
+%%PORTDOCS%%share/doc/cel/CoreArchitecture.html
+%%PORTDOCS%%share/doc/cel/Credits
+%%PORTDOCS%%share/doc/cel/DefaultProtos
+%%PORTDOCS%%share/doc/cel/Linker.html
+%%PORTDOCS%%share/doc/cel/Logs.html
+%%PORTDOCS%%share/doc/cel/ProtoLanguage.html
+%%PORTDOCS%%share/doc/cel/README
+%%PORTDOCS%%share/doc/cel/SimpleDataFormat.html
+%%PORTDOCS%%share/doc/cel/Threads
+%%PORTDOCS%%share/doc/cel/activation.html
+%%PORTDOCS%%share/doc/cel/stackframe
+%%PORTDOCS%%share/doc/cel/structure.html
+%%PORTDOCS%%share/doc/cel/todo.html
+%%PORTDOCS%%@dirrm share/doc/cel