aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2017-05-04 21:19:04 +0800
committergahr <gahr@FreeBSD.org>2017-05-04 21:19:04 +0800
commitf347e5b3acbf28094d5b836e0a4c2bdd02f10d27 (patch)
tree4eab00e6c5b43ddf1274872a2486da8959a57ae5 /lang
parent9ac5dcd4b2352d2d9d75d91744b85a6d4f750eb2 (diff)
downloadfreebsd-ports-gnome-f347e5b3acbf28094d5b836e0a4c2bdd02f10d27.tar.gz
freebsd-ports-gnome-f347e5b3acbf28094d5b836e0a4c2bdd02f10d27.tar.zst
freebsd-ports-gnome-f347e5b3acbf28094d5b836e0a4c2bdd02f10d27.zip
lang/seed7: update to 05_20170501
With this update, lang/seed7 depends on a number of database client libraries (MySQL, SQLite, unixODBC and PostgreSQL). The reason for this is that the configuration stage doesn't allow to specify which database drivers to use, but rather automatically links against what's installed. This would cause non-tracked dependencies in the case the user building the port happens to have any of the drivers installed at build time. 20170501: - The example program diff7.sd7 has been added. This program compares two files line by line. - The example program hd.sd7 has been added. This program writes a hexdump of a given file. - The functions sha384 and sha512 have been added to msgdigest.s7i. - The compiler has been improved to optimize expressions like bin64(aBigExpression mod aPowerOfTwo). - The library vectorfont.s7i has been improved to allow scaling of vector fonts. - The dialog element passwordField has been added to cgidialog.s7i. The passwordField dialog element allows entering a password without readable echo. - The function readPassword has been added to editline.s7i. - In array.s7i the for-until loops for arrays have been improved to work correct, when the until-condition uses the for variable. - In cli_cmds.s7i the functions getCommandParameter, getUnixCommandParameter and getDosCommandParameter has been improved to recognize when a closing quote is missing. - In cli_cmds.s7i in the function processCommand the handling of external commands with redirection of stdin has been improved. - The functions xyArray and scale have been added to graph.s7i. - In seed7_05.s7i the exception DATABASE_ERROR has been introduced. - The programs sql7.sd7 and chkdb.sd7 have been improved to use the new exception DATABASE_ERROR. - A parse operator for dbCategory has been added to sql_base.s7i. - The pictures return_pic and right_arrow_pic have been added to pic32.s7i and pic16.s7i. - The function checkBinBinaryWithBigMod has been added to chkbin.sd7. This function checks the optimizations done with expressions like bin64(aBigExpression mod aPowerOfTwo). - In tls.s7i the type securityParameters has been renamed to tlsParameters. The functions showMsg and showMsgType have been renamed to showTlsMsg respectively showTlsMsgType. - In tls.s7i the generation of CLIENT_HELLO, SERVER_HELLO, CERTIFICATE, SERVER_HELLO_DONE, CLIENT_KEY_EXCHANGE, CHANGE_CIPHER_SPEC, FINISHED, ALERT and APPLICATION_DATA messages has been improved. - In int_act.s7i the types addSubElementType and addSubElementListType have been renamed to addSubIntElementType respectively addSubIntListType. - In the compiler (in big_act.s7i, function process_const_big_mod) the handling of the bigInteger mod operator, when the divisor is a power of two, has been improved. Now a temporary result is freed. - In the compiler (in big_act.s7i, function process_const_big_mult) the handling of the bigInteger multiplication with a negated power of two has been improved. Now a temporary result is freed. - The functions generateAddSubParamList and evaluateConstants have been added to comp/big_act.s7i. - The function optimize_bin_binary_of_big_mod has been added to the
Diffstat (limited to 'lang')
-rw-r--r--lang/seed7/Makefile7
-rw-r--r--lang/seed7/distinfo6
2 files changed, 8 insertions, 5 deletions
diff --git a/lang/seed7/Makefile b/lang/seed7/Makefile
index f718063a2e2c..5ece59c206cc 100644
--- a/lang/seed7/Makefile
+++ b/lang/seed7/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= seed7
-DISTVERSION= 05_20170129
+DISTVERSION= 05_20170501
CATEGORIES= lang
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTNAME}/
DISTNAME= ${PORTNAME}_${DISTVERSION}
@@ -16,10 +16,13 @@ COMMENT= High-level, extensible programming language
LICENSE= GPLv2 LGPL21
LICENSE_COMB= multi
+LIB_DEPENDS= libodbc.so:databases/unixODBC
+
OPTIONS_DEFINE= DOCS EXAMPLES
-USES= ncurses tar:tgz
+USES= mysql:client ncurses pgsql sqlite tar:tgz
USE_XORG= x11
+WANT_PGSQL= client
ONLY_FOR_ARCHS= i386 amd64 sparc64
diff --git a/lang/seed7/distinfo b/lang/seed7/distinfo
index 245cede58c94..62f790dd0160 100644
--- a/lang/seed7/distinfo
+++ b/lang/seed7/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1485777042
-SHA256 (seed7_05_20170129.tgz) = 38517f699302b7bb83f669d1ed38f3050d6eb1a80c51f92d4005528af073b982
-SIZE (seed7_05_20170129.tgz) = 2706706
+TIMESTAMP = 1493901277
+SHA256 (seed7_05_20170501.tgz) = 5e732b5ba76946933114cfd7a450bec0488472c8540943954ea96eb812ddabeb
+SIZE (seed7_05_20170501.tgz) = 2745078