aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-12-05 08:53:19 +0800
committeredwin <edwin@FreeBSD.org>2005-12-05 08:53:19 +0800
commit08a2fa82cd4f6588449b81c8534c42aba7fe2e0d (patch)
treeef66ee81930a9594726a6676978b4162577ac2ca /lang
parent19feb22e85f40be1352d2a7ce122f6f28b4d40fc (diff)
downloadfreebsd-ports-gnome-08a2fa82cd4f6588449b81c8534c42aba7fe2e0d.tar.gz
freebsd-ports-gnome-08a2fa82cd4f6588449b81c8534c42aba7fe2e0d.tar.zst
freebsd-ports-gnome-08a2fa82cd4f6588449b81c8534c42aba7fe2e0d.zip
Remove install-info from Makefile, it's automatically done when INFO is defined
Diffstat (limited to 'lang')
-rw-r--r--lang/Sather/Makefile5
-rw-r--r--lang/bigloo/Makefile5
-rw-r--r--lang/egcs/Makefile3
-rw-r--r--lang/gauche/Makefile3
-rw-r--r--lang/gcc295/Makefile3
-rw-r--r--lang/gcc32/Makefile3
-rw-r--r--lang/slib/Makefile1
-rw-r--r--lang/yorick/Makefile1
8 files changed, 3 insertions, 21 deletions
diff --git a/lang/Sather/Makefile b/lang/Sather/Makefile
index 971e9421d262..0b589cc3bce0 100644
--- a/lang/Sather/Makefile
+++ b/lang/Sather/Makefile
@@ -91,9 +91,8 @@ do-install:
.for file in sabrowse.1 sacomp.1
${INSTALL_MAN} ${WRKSRC}/Doc/man/man1/${file} ${MANPREFIX}/man/man1
.endfor
-.for file in sather-mode.info sather-tutorial.info sather.info
- ${INSTALL_DATA} ${WRKSRC}/Emacs/${file} ${PREFIX}/info
- @install-info ${PREFIX}/info/${file} ${PREFIX}/info/dir
+.for file in ${INFO}
+ ${INSTALL_DATA} ${WRKSRC}/Emacs/${file}.info ${PREFIX}/info
.endfor
.for file in hl319.el sather-lib.el sather-module.el sather.el
${INSTALL_DATA} ${WRKSRC}/Emacs/${file} ${PREFIX}/share/emacs/site-lisp
diff --git a/lang/bigloo/Makefile b/lang/bigloo/Makefile
index 5ac34e5f2ba5..d13f131f00df 100644
--- a/lang/bigloo/Makefile
+++ b/lang/bigloo/Makefile
@@ -49,13 +49,10 @@ post-configure:
BROKEN= "Does not compile on !i386"
.endif
-post-install: install-info
+post-install:
@${SED} "s|%%PREFIX%%|${PREFIX}|g" < ${FILESDIR}/bigloo.sh | ${SED} "s|%%BIGLOO_VERSION%%|${PORTVERSION}|g" > ${PREFIX}/etc/rc.d/000.bigloo.sh
@${CHMOD} 750 ${PREFIX}/etc/rc.d/000.bigloo.sh
-install-info:
- @${INSTALL_INFO} ${PREFIX}/info/${PORTNAME}.info ${PREFIX}/info/dir
-
test: build
@(cd ${WRKSRC}; ${GMAKE} test)
diff --git a/lang/egcs/Makefile b/lang/egcs/Makefile
index fbd2ffa1c8d9..fd99a69b3edb 100644
--- a/lang/egcs/Makefile
+++ b/lang/egcs/Makefile
@@ -99,9 +99,6 @@ post-install:
${MV} -f ${PREFIX}/lib/libstdc++.so* \
${PREFIX}/lib/gcc-lib/${CONFIGURE_TARGET}/${EGCS_REV}
.endif
-.for info in cpp g77 gcc
- install-info ${PREFIX}/info/${info}.info ${PREFIX}/info/dir
-.endfor
cd ${PREFIX} ;\
${FIND} lib/gcc-lib/${CONFIGURE_TARGET}/${EGCS_REV} \
-type f -o -type l >${WRKDIR}/PLIST.gcc-lib
diff --git a/lang/gauche/Makefile b/lang/gauche/Makefile
index 7b1888c671c9..4c91e42a1e73 100644
--- a/lang/gauche/Makefile
+++ b/lang/gauche/Makefile
@@ -67,9 +67,6 @@ post-install:
.if !defined(NOPORTDOCS)
${INSTALL_MAN} ${WRKSRC}/doc/*.1 ${MANPREFIX}/man/man1/
${INSTALL_DATA} ${WRKSRC}/doc/*.info ${PREFIX}/info/
-.for info in ${INFO}
- install-info --section="${INFOSECTION}" ${WRKSRC}/doc/${info}.info ${PREFIX}/info/dir
-.endfor
.endif
.include <bsd.port.post.mk>
diff --git a/lang/gcc295/Makefile b/lang/gcc295/Makefile
index 167f76d8d320..d7b9b8f5bd76 100644
--- a/lang/gcc295/Makefile
+++ b/lang/gcc295/Makefile
@@ -115,9 +115,6 @@ post-install:
.if defined(WANT_SHAREDLIBS)
${MV} -f ${PREFIX}/lib/libstdc++.so* ${TARGLIB}
.endif
-.for info in ${INFO}
- install-info ${PREFIX}/info/${info}.info ${PREFIX}/info/dir
-.endfor
cd ${PREFIX} ;\
${FIND} lib/gcc-lib/${CONFIGURE_TARGET}/${GCC_REV} \
-type f -o -type l >${WRKDIR}/PLIST.gcc-lib
diff --git a/lang/gcc32/Makefile b/lang/gcc32/Makefile
index 3b55c2edce1d..40b22f5211c6 100644
--- a/lang/gcc32/Makefile
+++ b/lang/gcc32/Makefile
@@ -123,9 +123,6 @@ post-install:
-${MV} -f ${PREFIX}/lib/ieee ${TARGLIB}
${RM} -f ${PREFIX}/lib/libiberty.a
${RM} -f ${TARGLIB}/*.la
-.for info in cpp cppinternals g77 gcc
- install-info ${PREFIX}/info/${info}.info ${PREFIX}/info/dir
-.endfor
# I am sick and tired of the anonyance that man pages can only be generated if
# perl 5.6 is installed. This is becoming a royal PITA on non-5-CURRENT systems
.for mp in ${_MANPAGES}
diff --git a/lang/slib/Makefile b/lang/slib/Makefile
index 7c60482f0bc1..c8d465a2b458 100644
--- a/lang/slib/Makefile
+++ b/lang/slib/Makefile
@@ -33,7 +33,6 @@ do-install:
${MKDIR} ${DATADIR}
cd ${WRKSRC}; ${INSTALL_DATA} *.scm *.init *.txt *.xyz *.ps ${DATADIR}
${INSTALL_MAN} ${WRKSRC}/slib.info ${PREFIX}/info
- install-info ${PREFIX}/info/slib.info ${PREFIX}/info/dir
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
.for file in ANNOUNCE ChangeLog FAQ README
diff --git a/lang/yorick/Makefile b/lang/yorick/Makefile
index b76eed9f840a..70a8c21198e9 100644
--- a/lang/yorick/Makefile
+++ b/lang/yorick/Makefile
@@ -55,7 +55,6 @@ post-install:
for f in ${WRKSRC}/doc/yorick.info*; do \
${INSTALL_DATA} $$f ${PREFIX}/info; \
done
- install-info ${PREFIX}/info/yorick.info ${PREFIX}/info/dir
.endif
.include <bsd.port.mk>