aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2015-09-12 20:59:17 +0800
committerdanfe <danfe@FreeBSD.org>2015-09-12 20:59:17 +0800
commit0bd0f5373ee4db6a0f1012b4efede8f6d17aad65 (patch)
tree0a1e5fa3cac8591b9d924eb4411780c36f8e108d /lang
parent9da097c6a9583abe71503e88ee0a934c8bfa1341 (diff)
downloadfreebsd-ports-gnome-0bd0f5373ee4db6a0f1012b4efede8f6d17aad65.tar.gz
freebsd-ports-gnome-0bd0f5373ee4db6a0f1012b4efede8f6d17aad65.tar.zst
freebsd-ports-gnome-0bd0f5373ee4db6a0f1012b4efede8f6d17aad65.zip
Unbreak the build on PowerPC. This is a quick fix rather than perfectly
correct: REGINA_BITS macro is set by configure script (for known systems, but passed to the compiler unconditionally even if empty) and checked and set in `rexx.h' as well if defined(__APPLE__) && defined(__MACH__). Better approach would be either making configure script logic exhaustive, or move REGINA_BITS setting entirely into `rexx.h', leaving the ability to override it via --enable-{32,64}bit configure arguments.
Diffstat (limited to 'lang')
-rw-r--r--lang/rexx-regina/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/lang/rexx-regina/Makefile b/lang/rexx-regina/Makefile
index 73c65fc8b2d6..bad65c1bee40 100644
--- a/lang/rexx-regina/Makefile
+++ b/lang/rexx-regina/Makefile
@@ -26,13 +26,11 @@ EXAMPLESDIR= ${PREFIX}/share/examples/Regina-REXX
CONFLICTS= rexx-imc-[0-0]* oorexx-[0-9]*
-BROKEN_powerpc= Does not link on powerpc
-
OPTIONS_DEFINE= EXAMPLES
.include <bsd.port.options.mk>
-.if ${ARCH} == i386
+.if ${ARCH} == i386 || ${ARCH} == powerpc
CONFIGURE_ARGS+= --enable-32bit
.endif