aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2006-08-07 21:12:12 +0800
committerrafan <rafan@FreeBSD.org>2006-08-07 21:12:12 +0800
commit115bf13ffb5c17b6192dcaa9f881ad32f887e23b (patch)
tree1cf9c7f12833111ee12822cb6cedd05b0a0be6fe /lang
parente6fe07a15f0f2111b1a3789ed83decad613db11a (diff)
downloadfreebsd-ports-gnome-115bf13ffb5c17b6192dcaa9f881ad32f887e23b.tar.gz
freebsd-ports-gnome-115bf13ffb5c17b6192dcaa9f881ad32f887e23b.tar.zst
freebsd-ports-gnome-115bf13ffb5c17b6192dcaa9f881ad32f887e23b.zip
Add sather-tutorial 000328, a tutorial on the Sather programming
language. PR: ports/101425 Submitted by: Stanislav Sedov <ssedov at mbsd.msk.ru>
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/sather-tutorial/Makefile35
-rw-r--r--lang/sather-tutorial/distinfo3
-rw-r--r--lang/sather-tutorial/pkg-descr3
-rw-r--r--lang/sather-tutorial/pkg-plist82
5 files changed, 124 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index d1f9e2231776..1aa8cb295d54 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -262,6 +262,7 @@
SUBDIR += ruby18
SUBDIR += ruby18_static
SUBDIR += sather-specification
+ SUBDIR += sather-tutorial
SUBDIR += sbcl
SUBDIR += scheme48
SUBDIR += schemetoc
diff --git a/lang/sather-tutorial/Makefile b/lang/sather-tutorial/Makefile
new file mode 100644
index 000000000000..d214a486cc23
--- /dev/null
+++ b/lang/sather-tutorial/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: sather-tutorial
+# Date created: 5 August 2006
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tutorial
+PORTVERSION= 000328
+CATEGORIES= lang
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR=sather/Doc
+PKGNAMEPREFIX= sather-
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}.html
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= A tutorial on the Sather programming language
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+DOCSDIR= ${PREFIX}/share/doc/sather/${PORTNAME}
+
+do-install:
+ ${MKDIR} ${DOCSDIR}
+ @${TAR} -xf ${DISTDIR}/${DISTFILES} -C ${DOCSDIR}
+ @${FIND} ${DOCSDIR}/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;
+ ${CHOWN} -R ${SHAREOWN} ${DOCSDIR}/
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= tar is too old
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/lang/sather-tutorial/distinfo b/lang/sather-tutorial/distinfo
new file mode 100644
index 000000000000..a47b870651ad
--- /dev/null
+++ b/lang/sather-tutorial/distinfo
@@ -0,0 +1,3 @@
+MD5 (sather-tutorial-000328.html.tar.gz) = 7d6406c0ef5e41c8e8093459b8b5615f
+SHA256 (sather-tutorial-000328.html.tar.gz) = cb7415dfe4a144c71f315267837db09fb6d7555e4ae8cd2bd210b24f42ccab72
+SIZE (sather-tutorial-000328.html.tar.gz) = 255712
diff --git a/lang/sather-tutorial/pkg-descr b/lang/sather-tutorial/pkg-descr
new file mode 100644
index 000000000000..860258ff8d64
--- /dev/null
+++ b/lang/sather-tutorial/pkg-descr
@@ -0,0 +1,3 @@
+A tutorial on the Sather programming language.
+
+WWW: http://www.gnu.org/software/sather/
diff --git a/lang/sather-tutorial/pkg-plist b/lang/sather-tutorial/pkg-plist
new file mode 100644
index 000000000000..69afeff7eaf4
--- /dev/null
+++ b/lang/sather-tutorial/pkg-plist
@@ -0,0 +1,82 @@
+%%DOCSDIR%%/tutorial.html/HTML.manifest
+%%DOCSDIR%%/tutorial.html/abstract.html
+%%DOCSDIR%%/tutorial.html/abstract1223.html
+%%DOCSDIR%%/tutorial.html/abstract1259.html
+%%DOCSDIR%%/tutorial.html/abstract1308.html
+%%DOCSDIR%%/tutorial.html/abstract1606.html
+%%DOCSDIR%%/tutorial.html/arrays.html
+%%DOCSDIR%%/tutorial.html/builtin.html
+%%DOCSDIR%%/tutorial.html/builtin2276.html
+%%DOCSDIR%%/tutorial.html/builtin2339.html
+%%DOCSDIR%%/tutorial.html/builtin2347.html
+%%DOCSDIR%%/tutorial.html/builtin2503.html
+%%DOCSDIR%%/tutorial.html/c-builtin.html
+%%DOCSDIR%%/tutorial.html/c-inline.html
+%%DOCSDIR%%/tutorial.html/c-parameters.html
+%%DOCSDIR%%/tutorial.html/c-user-types.html
+%%DOCSDIR%%/tutorial.html/c.html
+%%DOCSDIR%%/tutorial.html/catalogue.html
+%%DOCSDIR%%/tutorial.html/catalogue3249.html
+%%DOCSDIR%%/tutorial.html/classes.html
+%%DOCSDIR%%/tutorial.html/classes275.html
+%%DOCSDIR%%/tutorial.html/classes382.html
+%%DOCSDIR%%/tutorial.html/classes453.html
+%%DOCSDIR%%/tutorial.html/classes715.html
+%%DOCSDIR%%/tutorial.html/classes771.html
+%%DOCSDIR%%/tutorial.html/closures.html
+%%DOCSDIR%%/tutorial.html/closures2064.html
+%%DOCSDIR%%/tutorial.html/conditional.html
+%%DOCSDIR%%/tutorial.html/employee.html
+%%DOCSDIR%%/tutorial.html/exceptions.html
+%%DOCSDIR%%/tutorial.html/exceptions2144.html
+%%DOCSDIR%%/tutorial.html/fortran-datatypes.html
+%%DOCSDIR%%/tutorial.html/fortran-names.html
+%%DOCSDIR%%/tutorial.html/fortran-parameters.html
+%%DOCSDIR%%/tutorial.html/fortran-portability.html
+%%DOCSDIR%%/tutorial.html/fortran.html
+%%DOCSDIR%%/tutorial.html/immutable.html
+%%DOCSDIR%%/tutorial.html/immutable1937.html
+%%DOCSDIR%%/tutorial.html/inclusion.html
+%%DOCSDIR%%/tutorial.html/inclusion1161.html
+%%DOCSDIR%%/tutorial.html/intro.html
+%%DOCSDIR%%/tutorial.html/intro202.html
+%%DOCSDIR%%/tutorial.html/intro41.html
+%%DOCSDIR%%/tutorial.html/intro44.html
+%%DOCSDIR%%/tutorial.html/intro53.html
+%%DOCSDIR%%/tutorial.html/intro79.html
+%%DOCSDIR%%/tutorial.html/iterator-1.png
+%%DOCSDIR%%/tutorial.html/iterator-2.png
+%%DOCSDIR%%/tutorial.html/iterator-3.png
+%%DOCSDIR%%/tutorial.html/iterators.html
+%%DOCSDIR%%/tutorial.html/iterators1034.html
+%%DOCSDIR%%/tutorial.html/iterators873.html
+%%DOCSDIR%%/tutorial.html/last.png
+%%DOCSDIR%%/tutorial.html/operator-expressions.html
+%%DOCSDIR%%/tutorial.html/operators.html
+%%DOCSDIR%%/tutorial.html/operators1882.html
+%%DOCSDIR%%/tutorial.html/overloading.html
+%%DOCSDIR%%/tutorial.html/parameterized-overloading.html
+%%DOCSDIR%%/tutorial.html/parameterized.html
+%%DOCSDIR%%/tutorial.html/parameterized1751.html
+%%DOCSDIR%%/tutorial.html/parameterized1792.html
+%%DOCSDIR%%/tutorial.html/rem-1.png
+%%DOCSDIR%%/tutorial.html/rem-2.png
+%%DOCSDIR%%/tutorial.html/rem-3.png
+%%DOCSDIR%%/tutorial.html/rem-4.png
+%%DOCSDIR%%/tutorial.html/rem-5.png
+%%DOCSDIR%%/tutorial.html/rem-6.png
+%%DOCSDIR%%/tutorial.html/rem-7.png
+%%DOCSDIR%%/tutorial.html/rem-8.png
+%%DOCSDIR%%/tutorial.html/safety.html
+%%DOCSDIR%%/tutorial.html/safety2172.html
+%%DOCSDIR%%/tutorial.html/safety2208.html
+%%DOCSDIR%%/tutorial.html/safety2219.html
+%%DOCSDIR%%/tutorial.html/sather-tutorial.html
+%%DOCSDIR%%/tutorial.html/style.css
+%%DOCSDIR%%/tutorial.html/sys.html
+%%DOCSDIR%%/tutorial.html/type-conformance.html
+%%DOCSDIR%%/tutorial.html/type-inference.html
+%%DOCSDIR%%/tutorial.html/typecase.html
+@dirrm %%DOCSDIR%%/tutorial.html
+@dirrm %%DOCSDIR%%
+@dirrmtry share/doc/sather