aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2012-06-21 06:35:15 +0800
committermva <mva@FreeBSD.org>2012-06-21 06:35:15 +0800
commit172e172f08224ec9d82b6130d1e404de2792a449 (patch)
tree6b01040f8bb3ff341c15a0a4fcba4cd83b78cbf2 /lang
parent5fd44195d5649353dc4a5af78e53d9fc346ade6c (diff)
downloadfreebsd-ports-gnome-172e172f08224ec9d82b6130d1e404de2792a449.tar.gz
freebsd-ports-gnome-172e172f08224ec9d82b6130d1e404de2792a449.tar.zst
freebsd-ports-gnome-172e172f08224ec9d82b6130d1e404de2792a449.zip
- Fix builds, if the NLS option switch is set. In some cases
expat-related modules are not built correctly. PR: ports/169276 Submitted by: Greg Byshenk <freebsd@byshenk.net>
Diffstat (limited to 'lang')
-rw-r--r--lang/python24/Makefile5
-rw-r--r--lang/python25/Makefile5
-rw-r--r--lang/python26/Makefile5
-rw-r--r--lang/python27/Makefile5
-rw-r--r--lang/python31/Makefile5
-rw-r--r--lang/python32/Makefile5
6 files changed, 18 insertions, 12 deletions
diff --git a/lang/python24/Makefile b/lang/python24/Makefile
index 3aeffdd053ab..f00b7ed1d607 100644
--- a/lang/python24/Makefile
+++ b/lang/python24/Makefile
@@ -63,8 +63,9 @@ PLIST_SUB+= IF_DEFAULT="@comment "
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
-LDFLAGS+= "-L${LOCALBASE}/lib"
-CFLAGS+= "-I${LOCALBASE}/include"
+# XXX do not set any LDFLAGS or CFLAGS - this causes pyexpat to fail building
+#LDFLAGS+= "-L${LOCALBASE}/lib"
+#CFLAGS+= "-I${LOCALBASE}/include"
.else
CONFIGURE_ENV+= ac_cv_lib_intl_textdomain=no ac_cv_header_libintl_h=no
.endif
diff --git a/lang/python25/Makefile b/lang/python25/Makefile
index 4bb38a3ca316..c7e1eafe15c3 100644
--- a/lang/python25/Makefile
+++ b/lang/python25/Makefile
@@ -70,8 +70,9 @@ PLIST_SUB+= IF_DEFAULT="@comment "
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
-LDFLAGS+= "-L${LOCALBASE}/lib"
-CFLAGS+= "-I${LOCALBASE}/include"
+# XXX do not set any LDFLAGS or CFLAGS - this causes pyexpat to fail building
+#LDFLAGS+= "-L${LOCALBASE}/lib"
+#CFLAGS+= "-I${LOCALBASE}/include"
.else
CONFIGURE_ENV+= ac_cv_lib_intl_textdomain=no ac_cv_header_libintl_h=no
.endif
diff --git a/lang/python26/Makefile b/lang/python26/Makefile
index 52dbf102afd6..cfd285d858dd 100644
--- a/lang/python26/Makefile
+++ b/lang/python26/Makefile
@@ -82,8 +82,9 @@ PLIST_SUB+= IF_DEFAULT="@comment "
.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
-LDFLAGS+= "-L${LOCALBASE}/lib"
-CFLAGS+= "-I${LOCALBASE}/include"
+# XXX do not set any LDFLAGS or CFLAGS - this causes pyexpat to fail building
+#LDFLAGS+= "-L${LOCALBASE}/lib"
+#CFLAGS+= "-I${LOCALBASE}/include"
.else
CONFIGURE_ENV+= ac_cv_lib_intl_textdomain=no ac_cv_header_libintl_h=no
.endif
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index c03236a92af5..dbff4c2e1243 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -82,8 +82,9 @@ PLIST_SUB+= IF_DEFAULT="@comment "
.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
-LDFLAGS+= "-L${LOCALBASE}/lib"
-CFLAGS+= "-I${LOCALBASE}/include"
+# XXX do not set any LDFLAGS or CFLAGS - this causes pyexpat to fail building
+#LDFLAGS+= "-L${LOCALBASE}/lib"
+#CFLAGS+= "-I${LOCALBASE}/include"
.else
CONFIGURE_ENV+= ac_cv_lib_intl_textdomain=no ac_cv_header_libintl_h=no
.endif
diff --git a/lang/python31/Makefile b/lang/python31/Makefile
index 7e55be079854..45fcafac8be2 100644
--- a/lang/python31/Makefile
+++ b/lang/python31/Makefile
@@ -66,8 +66,9 @@ PLIST_SUB+= IF_DEFAULT="@comment "
.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
-LDFLAGS+= "-L${LOCALBASE}/lib"
-CFLAGS+= "-I${LOCALBASE}/include"
+# XXX do not set any LDFLAGS or CFLAGS - this causes pyexpat to fail building
+#LDFLAGS+= "-L${LOCALBASE}/lib"
+#CFLAGS+= "-I${LOCALBASE}/include"
.else
CONFIGURE_ENV+= ac_cv_lib_intl_textdomain=no ac_cv_header_libintl_h=no
.endif
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index 041c3e747a9a..1aae5c8de8e6 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -67,8 +67,9 @@ PLIST_SUB+= IF_DEFAULT="@comment "
.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
-LDFLAGS+= "-L${LOCALBASE}/lib"
-CFLAGS+= "-I${LOCALBASE}/include"
+# XXX do not set any LDFLAGS or CFLAGS - this causes pyexpat to fail building
+#LDFLAGS+= "-L${LOCALBASE}/lib"
+#CFLAGS+= "-I${LOCALBASE}/include"
.else
CONFIGURE_ENV+= ac_cv_lib_intl_textdomain=no ac_cv_header_libintl_h=no
.endif