aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2009-07-20 00:42:09 +0800
committerstas <stas@FreeBSD.org>2009-07-20 00:42:09 +0800
commit1baeab6fa745861828df3b834bd0e42e4564d967 (patch)
treed7dab0def7ff5042044c0222aa08e626a051c008 /lang
parent708830f2caed394504bcb4bef5a9746b0a033b15 (diff)
downloadfreebsd-ports-gnome-1baeab6fa745861828df3b834bd0e42e4564d967.tar.gz
freebsd-ports-gnome-1baeab6fa745861828df3b834bd0e42e4564d967.tar.zst
freebsd-ports-gnome-1baeab6fa745861828df3b834bd0e42e4564d967.zip
- Add ${PTHREAD_LIBS} to LDFLAGS in threaded build. This fixes the issue
when pthread libraries don't show up in Config::CONFIG["LIBS"] in some cases. Reported by: dinoex
Diffstat (limited to 'lang')
-rw-r--r--lang/ruby18/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/lang/ruby18/Makefile b/lang/ruby18/Makefile
index ee7e77cc1728..5ab744a3f44f 100644
--- a/lang/ruby18/Makefile
+++ b/lang/ruby18/Makefile
@@ -60,6 +60,7 @@ PKGNAMESUFFIX= #empty
CONFIGURE_ARGS+=--disable-pthread
PKGNAMESUFFIX:= ${PKGNAMESUFFIX}+nopthreads
.else
+LDFLAGS+= ${PTHREAD_LIBS}
CONFIGURE_ARGS+=--enable-pthread
.endif