aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-12-31 03:23:38 +0800
committermiwi <miwi@FreeBSD.org>2006-12-31 03:23:38 +0800
commit3c7b516d88496b013fea493d016bf853120750c9 (patch)
treedff1b40aa556a88a2dcd1c291f8ecb981c81dae4 /lang
parent123197788a33b1b8eea934b456de9147518ae0cf (diff)
downloadfreebsd-ports-gnome-3c7b516d88496b013fea493d016bf853120750c9.tar.gz
freebsd-ports-gnome-3c7b516d88496b013fea493d016bf853120750c9.tar.zst
freebsd-ports-gnome-3c7b516d88496b013fea493d016bf853120750c9.zip
This is the port of Randall Hyde's High Level Assembly (HLA).
Don't let the name fool you. HLA is "real" assembly language, just made easier for beginners so they can learn the language faster than ever before. Anything you can do with a traditional assembler can be done with HLA; HLA just happens to do a lot more than traditional assemblers! WWW: http://webster.cs.ucr.edu/ PR: ports/107224 Submitted by: Hernan Di Pietro <hernan.di.pietro at gmail.com>
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/linux-hla/Makefile42
-rw-r--r--lang/linux-hla/distinfo3
-rw-r--r--lang/linux-hla/files/pkg-message.in30
-rw-r--r--lang/linux-hla/pkg-descr11
-rw-r--r--lang/linux-hla/pkg-plist93
6 files changed, 180 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 56b105f2f985..4495ff4df6de 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -138,6 +138,7 @@
SUBDIR += libjit
SUBDIR += librep
SUBDIR += libutils
+ SUBDIR += linux-hla
SUBDIR += linux-j
SUBDIR += linux-libg2c
SUBDIR += linux-libperl5.8
diff --git a/lang/linux-hla/Makefile b/lang/linux-hla/Makefile
new file mode 100644
index 000000000000..c57f55220f49
--- /dev/null
+++ b/lang/linux-hla/Makefile
@@ -0,0 +1,42 @@
+# ports collection makefile for: linux-hla
+# Date created: 26 December 2006
+# Whom: Hernan Di Pietro <hernan.di.pietro@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hla
+PORTVERSION= 1.86
+CATEGORIES= lang
+MASTER_SITES= http://webster.cs.ucr.edu/AsmTools/HLA/HLAv${PORTVERSION}/
+PKGNAMEPREFIX= linux-
+DISTNAME= hla
+
+MAINTAINER= hernan.di.pietro@gmail.com
+COMMENT= Randall Hyde High-Level Assembly (HLA) port
+
+IA32_BINARY_PORT= yes
+USE_LINUX= yes
+NO_INSTALL_MANPAGES= yes
+NO_BUILD= yes
+SUB_FILES= pkg-message
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/hla ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/hlaparse ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/include/hla
+ ${MKDIR} ${PREFIX}/lib/hla
+ ${INSTALL_DATA} ${WRKSRC}/hlalib/hlalib.a ${PREFIX}/lib/hla
+ ${MKDIR} ${PREFIX}/include/hla/os
+ ${INSTALL_DATA} ${WRKSRC}/include/*.hhf ${PREFIX}/include/hla
+ ${INSTALL_DATA} ${WRKSRC}/include/*.scc ${PREFIX}/include/hla
+ ${INSTALL_DATA} ${WRKSRC}/include/os/*.hhf ${PREFIX}/include/hla/os
+ ${INSTALL_DATA} ${WRKSRC}/include/os/*.scc ${PREFIX}/include/hla/os
+
+post-install:
+ ${BRANDELF} -t Linux ${PREFIX}/bin/hla
+ ${BRANDELF} -t Linux ${PREFIX}/bin/hlaparse
+
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/lang/linux-hla/distinfo b/lang/linux-hla/distinfo
new file mode 100644
index 000000000000..421832e458bf
--- /dev/null
+++ b/lang/linux-hla/distinfo
@@ -0,0 +1,3 @@
+MD5 (hla.tar.gz) = 8d00bcbe6c801f610d952237b8cde227
+SHA256 (hla.tar.gz) = a3419124b006a9ecbf0eb169adb306ea93ddf4a941bf55e206bee3e4a5621459
+SIZE (hla.tar.gz) = 1249522
diff --git a/lang/linux-hla/files/pkg-message.in b/lang/linux-hla/files/pkg-message.in
new file mode 100644
index 000000000000..8a4857604b4e
--- /dev/null
+++ b/lang/linux-hla/files/pkg-message.in
@@ -0,0 +1,30 @@
+==================================================
+To use HLA you must setup environment variables
+for the compiler to find hlalib.a library and
+related include files.
+
+# Use this for sh
+
+hlalib=%%PREFIX%%/lib/hla/hlalib.a
+export hlalib
+hlainc=%%PREFIX%%/include/hla
+export hlainc
+
+# for [t]csh
+
+setenv hlalib "%%PREFIX%%/lib/hla/hlalib.a"
+setenv hlainc "%%PREFIX%%/include/hla/"
+
+See the documentation of your shell to make
+environment settings permanent.
+
+--------------------------------------------------
+
+(!)REMEMBER TO BRANDELF YOUR HLA OUTPUT
+ EXECUTABLES, e.g:
+
+ hla hello.hla
+ brandelf -f 3 hello
+
+==================================================
+
diff --git a/lang/linux-hla/pkg-descr b/lang/linux-hla/pkg-descr
new file mode 100644
index 000000000000..b1577274fe3a
--- /dev/null
+++ b/lang/linux-hla/pkg-descr
@@ -0,0 +1,11 @@
+This is the port of Randall Hyde's High Level Assembly (HLA).
+Don't let the name fool you. HLA is "real" assembly language,
+just made easier for beginners so they can learn the language
+faster than ever before. Anything you can do with a traditional
+assembler can be done with HLA; HLA just happens to do a lot
+more than traditional assemblers!
+
+WWW: http://webster.cs.ucr.edu/
+
+- Hernan Di Pietro
+hernan.di.pietro@gmail.com
diff --git a/lang/linux-hla/pkg-plist b/lang/linux-hla/pkg-plist
new file mode 100644
index 000000000000..fa325739914c
--- /dev/null
+++ b/lang/linux-hla/pkg-plist
@@ -0,0 +1,93 @@
+bin/hla
+bin/hlaparse
+include/hla/os/aout.hhf
+include/hla/os/atomic.hhf
+include/hla/os/dirent.hhf
+include/hla/os/errno.hhf
+include/hla/os/fcntl.hhf
+include/hla/os/fs.hhf
+include/hla/os/ioport.hhf
+include/hla/os/ipc.hhf
+include/hla/os/kernel.hhf
+include/hla/os/lists.hhf
+include/hla/os/mm.hhf
+include/hla/os/mman.hhf
+include/hla/os/module.hhf
+include/hla/os/msg.hhf
+include/hla/os/net.hhf
+include/hla/os/param.hhf
+include/hla/os/poll.hhf
+include/hla/os/prctl.hhf
+include/hla/os/processor.hhf
+include/hla/os/ptrace.hhf
+include/hla/os/quota.hhf
+include/hla/os/reboot.hhf
+include/hla/os/resource.hhf
+include/hla/os/sched.hhf
+include/hla/os/shm.hhf
+include/hla/os/semaphore.hhf
+include/hla/os/signals.hhf
+include/hla/os/socket.hhf
+include/hla/os/spinlock.hhf
+include/hla/os/stat.hhf
+include/hla/os/syscall.hhf
+include/hla/os/sysctl.hhf
+include/hla/os/system.hhf
+include/hla/os/time.hhf
+include/hla/os/timer.hhf
+include/hla/os/tqueue.hhf
+include/hla/os/types.hhf
+include/hla/os/uio.hhf
+include/hla/os/unistd.hhf
+include/hla/os/utsname.hhf
+include/hla/os/wait.hhf
+include/hla/os/vssver.scc
+include/hla/RADbg.hhf
+include/hla/args.hhf
+include/hla/arrays.hhf
+include/hla/bits.hhf
+include/hla/chars.hhf
+include/hla/console.hhf
+include/hla/conv.hhf
+include/hla/coroutines.hhf
+include/hla/cset.hhf
+include/hla/datetime.hhf
+include/hla/dtClass.hhf
+include/hla/env.hhf
+include/hla/excepts.hhf
+include/hla/fileclass.hhf
+include/hla/fileio.hhf
+include/hla/getversion.hhf
+include/hla/hla.hhf
+include/hla/hll.hhf
+include/hla/linux.hhf
+include/hla/lists.hhf
+include/hla/math.hhf
+include/hla/memory.hhf
+include/hla/misctypes.hhf
+include/hla/mmap.hhf
+include/hla/os.hhf
+include/hla/osbsd.hhf
+include/hla/oslinux.hhf
+include/hla/oswin.hhf
+include/hla/patterns.hhf
+include/hla/rand.hhf
+include/hla/stderr.hhf
+include/hla/stdin.hhf
+include/hla/stdio.hhf
+include/hla/stdlib.hhf
+include/hla/stdout.hhf
+include/hla/strings.hhf
+include/hla/tables.hhf
+include/hla/timer.hhf
+include/hla/w.hhf
+include/hla/winmain.hhf
+include/hla/wpa.hhf
+include/hla/x86.hhf
+include/hla/vssver.scc
+lib/hla/hlalib.a
+share/nls/POSIX
+share/nls/en_US.US-ASCII
+@dirrm include/hla/os
+@dirrm include/hla
+@dirrm lib/hla