aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2006-11-20 07:39:00 +0800
committerstas <stas@FreeBSD.org>2006-11-20 07:39:00 +0800
commit43537b38583457860e1403ff180ff4643fa55dc9 (patch)
tree7d7419230feabe91d2ba4051d6d452cd27a18631 /lang
parent7fb3e42c6ecd7a2863b45ae02269e68dc59bc2bb (diff)
downloadfreebsd-ports-gnome-43537b38583457860e1403ff180ff4643fa55dc9.tar.gz
freebsd-ports-gnome-43537b38583457860e1403ff180ff4643fa55dc9.tar.zst
freebsd-ports-gnome-43537b38583457860e1403ff180ff4643fa55dc9.zip
- Back-out the previous commit, as it can cause linking problems (pthread's
unresolved symbols) on some systems (e.g. with libgnomeui). Linking threading libraries donesn't employ threading in ruby per se, so it's safe to do that in non-threaded case. Reported by: mezz
Diffstat (limited to 'lang')
-rw-r--r--lang/ruby18/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/lang/ruby18/Makefile b/lang/ruby18/Makefile
index 25d24c70c8dd..6d73963f6b94 100644
--- a/lang/ruby18/Makefile
+++ b/lang/ruby18/Makefile
@@ -40,10 +40,11 @@ OPTIONS= PTHREADS "Enable pthreads support (may break some apps)" off \
.include <bsd.port.pre.mk>
PKGNAMESUFFIX= #empty
+CFLAGS+= ${PTHREAD_CFLAGS} # Keep this, else ruby will fail to load
+LDFLAGS+= ${PTHREAD_LIBS} # libraries dependent op libpthread.
+
.if defined(WITH_PTHREADS)
CONFIGURE_ARGS+=--enable-pthread
-CFLAGS+= ${PTHREAD_CFLAGS}
-LDFLAGS+= ${PTHREAD_LIBS}
PKGNAMESUFFIX:= ${PKGNAMESUFFIX}+pthreads
.else
CONFIGURE_ARGS+=--disable-pthread