aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2010-11-12 22:03:04 +0800
committerstas <stas@FreeBSD.org>2010-11-12 22:03:04 +0800
commit55aea6b23bd62c39c6a246ffed46629f0d084248 (patch)
tree561f94efe56e34c6a87f83bbeb0d1178be96b989 /lang
parent340f202df862f8361ef979a88a73a92af20ce086 (diff)
downloadfreebsd-ports-gnome-55aea6b23bd62c39c6a246ffed46629f0d084248.tar.gz
freebsd-ports-gnome-55aea6b23bd62c39c6a246ffed46629f0d084248.tar.zst
freebsd-ports-gnome-55aea6b23bd62c39c6a246ffed46629f0d084248.zip
- Install .lisp files before .fasl. Otherwise sbcl ends up
thinking that FASL files are outdated. - Bump portrevision. Submitted by: Anonymous <swell.k@gmail.com>
Diffstat (limited to 'lang')
-rw-r--r--lang/sbcl/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/sbcl/Makefile b/lang/sbcl/Makefile
index a71f74a2a40d..18606df061a0 100644
--- a/lang/sbcl/Makefile
+++ b/lang/sbcl/Makefile
@@ -10,7 +10,7 @@
PORTNAME= sbcl
PORTVERSION= 1.0.43.0
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= lang lisp
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:R} \
@@ -228,8 +228,8 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/output/sbcl.core ${SBCL_HOME}/
.for MOD in ${CONTRIB_MODULES}
${MKDIR} ${SBCL_HOME}/${MOD}
- ${INSTALL_DATA} ${WRKSRC}/contrib/${MOD}/*.fasl ${SBCL_HOME}/${MOD}/
${INSTALL_DATA} ${WRKSRC}/contrib/${MOD}/*.lisp ${SBCL_HOME}/${MOD}/
+ ${INSTALL_DATA} ${WRKSRC}/contrib/${MOD}/*.fasl ${SBCL_HOME}/${MOD}/
(if test -f ${WRKSRC}/contrib/${MOD}/${MOD}.asd; then ${INSTALL_DATA} \
${WRKSRC}/contrib/${MOD}/${MOD}.asd ${SBCL_HOME}/${MOD}/; fi)
.endfor