aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2008-06-26 20:28:08 +0800
committerjohans <johans@FreeBSD.org>2008-06-26 20:28:08 +0800
commit5dc050b80744023b744c6eb3ee8bb642f682cc42 (patch)
tree581d2f17ac1e04baaf3b49d0ec1c98634f07da30 /lang
parent5c22ddb4300c9d32095fbe7b38f87eb37da93b45 (diff)
downloadfreebsd-ports-gnome-5dc050b80744023b744c6eb3ee8bb642f682cc42.tar.gz
freebsd-ports-gnome-5dc050b80744023b744c6eb3ee8bb642f682cc42.tar.zst
freebsd-ports-gnome-5dc050b80744023b744c6eb3ee8bb642f682cc42.zip
Add optional regression tests
PR: ports/124918 Submitted by: Pedro F. Giffuni
Diffstat (limited to 'lang')
-rw-r--r--lang/yorick/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/lang/yorick/Makefile b/lang/yorick/Makefile
index 02ef9e708903..213e38d22229 100644
--- a/lang/yorick/Makefile
+++ b/lang/yorick/Makefile
@@ -56,4 +56,10 @@ post-install:
${INSTALL_DATA} $$f ${PREFIX}/${INFO_PATH}; \
done
+# Hidden by default: this requires an X terminal to run all checks
+.ifdef MAINTAINER_MODE
+regression-test: build
+ (cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} check)
+.endif
+
.include <bsd.port.mk>