aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2015-07-04 01:16:45 +0800
committeradamw <adamw@FreeBSD.org>2015-07-04 01:16:45 +0800
commit6163013b7db5149d78ab40065f394efc23a02ebd (patch)
treef34b8cd70977ea59f1f581c3d0b1e358e500d053 /lang
parent8d346dc0c1f340dc4c5a90746fecefb4cbd92999 (diff)
downloadfreebsd-ports-gnome-6163013b7db5149d78ab40065f394efc23a02ebd.tar.gz
freebsd-ports-gnome-6163013b7db5149d78ab40065f394efc23a02ebd.tar.zst
freebsd-ports-gnome-6163013b7db5149d78ab40065f394efc23a02ebd.zip
Add lang/p5-Try-Catch, a stripped-down, faster implementation of
p5-Try-Tiny.
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/p5-Try-Catch/Makefile20
-rw-r--r--lang/p5-Try-Catch/distinfo2
-rw-r--r--lang/p5-Try-Catch/pkg-descr7
-rw-r--r--lang/p5-Try-Catch/pkg-plist2
5 files changed, 32 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index c5f564722fd0..75f11dc42f17 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -212,6 +212,7 @@
SUBDIR += p5-Switch
SUBDIR += p5-Tcl
SUBDIR += p5-Test-XPath
+ SUBDIR += p5-Try-Catch
SUBDIR += p5-Try-Tiny
SUBDIR += p5-Try-Tiny-Retry
SUBDIR += p5-TryCatch
diff --git a/lang/p5-Try-Catch/Makefile b/lang/p5-Try-Catch/Makefile
new file mode 100644
index 000000000000..3f9c7316895b
--- /dev/null
+++ b/lang/p5-Try-Catch/Makefile
@@ -0,0 +1,20 @@
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Try-Catch
+PORTVERSION= 0.0.5
+CATEGORIES= lang perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:MAMOD
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= Try/Catch exception handler based on Try::Tiny, but faster
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/lang/p5-Try-Catch/distinfo b/lang/p5-Try-Catch/distinfo
new file mode 100644
index 000000000000..0a873e038f90
--- /dev/null
+++ b/lang/p5-Try-Catch/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Try-Catch-0.0.5.tar.gz) = fc03f25af887190c1195d061cfcf93955de60fa9a642fc1a9afcdebe83f576c5
+SIZE (Try-Catch-0.0.5.tar.gz) = 7610
diff --git a/lang/p5-Try-Catch/pkg-descr b/lang/p5-Try-Catch/pkg-descr
new file mode 100644
index 000000000000..e5a12ebe6bbb
--- /dev/null
+++ b/lang/p5-Try-Catch/pkg-descr
@@ -0,0 +1,7 @@
+A small, fast, try catch blocks for perl, it's inspired and mostly copied from
+Try::Tiny but with some modifications to boost execution speed.
+
+Consider Try::Catch a stripped Try::Tiny version with no blessing and no usage
+of Sub::Name.
+
+WWW: https://metacpan.org/pod/Try::Catch
diff --git a/lang/p5-Try-Catch/pkg-plist b/lang/p5-Try-Catch/pkg-plist
new file mode 100644
index 000000000000..a46926cb8513
--- /dev/null
+++ b/lang/p5-Try-Catch/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Try/Catch.pm
+%%PERL5_MAN3%%/Try::Catch.3.gz