aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2015-08-31 13:39:41 +0800
committerpgj <pgj@FreeBSD.org>2015-08-31 13:39:41 +0800
commit635da2bd2f61c8b3ee3de810c57f7eaa0145050e (patch)
tree18769d317b8ad88b84983cc131eb25996871b054 /lang
parentc416597e801b7191e78576224b798fb339155371 (diff)
downloadfreebsd-ports-gnome-635da2bd2f61c8b3ee3de810c57f7eaa0145050e.tar.gz
freebsd-ports-gnome-635da2bd2f61c8b3ee3de810c57f7eaa0145050e.tar.zst
freebsd-ports-gnome-635da2bd2f61c8b3ee3de810c57f7eaa0145050e.zip
- Remove the deprecated USE_AUTOTOOLS variable
- Improve interaction with USE_GITHUB in bsd.cabal.mk that fixes the build of math/hs-Agda-stdlib Obtained from: FreeBSD Haskell
Diffstat (limited to 'lang')
-rw-r--r--lang/ghc/Makefile3
-rw-r--r--lang/ghc/bsd.cabal.mk9
2 files changed, 7 insertions, 5 deletions
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index 95106dc9cac9..b6166458f47c 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -29,9 +29,8 @@ CONFLICTS= ghc-7.4.* ghc-7.6.* ghc-7.8.*
LIB_DEPENDS+= libgmp.so:${PORTSDIR}/math/gmp
-USE_AUTOTOOLS= autoconf autoheader
USE_PERL5= build
-USES= gmake iconv:translit ncurses perl5 tar:xz
+USES= autoreconf gmake iconv:translit ncurses perl5 tar:xz
MAKE_ENV+= LC_ALL=en_US.UTF-8 LANG=en_US.UTF-8
# This is needed on FreeBSD 9.x due to the bootstrap tarball.
diff --git a/lang/ghc/bsd.cabal.mk b/lang/ghc/bsd.cabal.mk
index fae7bb72ae9c..a9d6ef14ff2a 100644
--- a/lang/ghc/bsd.cabal.mk
+++ b/lang/ghc/bsd.cabal.mk
@@ -9,13 +9,16 @@
# Maintained by: haskell@FreeBSD.org
#
-.if !defined(METAPORT)
+.if !defined(METAPORT) && !defined(USE_GITHUB)
MASTER_SITES?= http://hackage.haskell.org/package/${PORTNAME}-${PORTVERSION}/:hackage
DISTFILES?= ${DISTNAME}${EXTRACT_SUFX}:hackage
-DIST_SUBDIR?= cabal
EXTRACT_ONLY?= ${DISTNAME}${EXTRACT_SUFX}
-.else
+.endif
+
+.if defined(METAPORT)
USES+= metaport
+.else
+DIST_SUBDIR?= cabal
.endif # !METAPORT
MAKE_ENV+= LC_ALL=en_US.UTF-8 LANG=en_US.UTF-8 DESTDIR=${STAGEDIR} \