aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2012-04-11 20:52:17 +0800
committermiwi <miwi@FreeBSD.org>2012-04-11 20:52:17 +0800
commit80cd46abc5eb6d352284fbf74234bdf52beebcd2 (patch)
tree26472a3cb24a8689f1fc7c0103ceb0c7fcb57239 /lang
parente364ed49caabe33d83d554574637a18a75528de5 (diff)
downloadfreebsd-ports-gnome-80cd46abc5eb6d352284fbf74234bdf52beebcd2.tar.gz
freebsd-ports-gnome-80cd46abc5eb6d352284fbf74234bdf52beebcd2.tar.zst
freebsd-ports-gnome-80cd46abc5eb6d352284fbf74234bdf52beebcd2.zip
- Update:
* python26 -> 2.6.8 * python27 -> 2.7.3 * python31 -> 3.1.5 * python32 -> 3.2.1 Security: http://www.vuxml.org/freebsd/b4f8be9e-56b2-11e1-9fb7-003067b2972c.html CVE-2012-0845 CVE-2012-0876 CVE-2012-1150 CVE-2012-0845 CVE-2011-3389
Diffstat (limited to 'lang')
-rw-r--r--lang/python26/Makefile3
-rw-r--r--lang/python26/distinfo4
-rw-r--r--lang/python26/files/patch-CVE-2012-084514
-rw-r--r--lang/python26/pkg-plist4
-rw-r--r--lang/python27/Makefile3
-rw-r--r--lang/python27/distinfo4
-rw-r--r--lang/python27/files/patch-CVE-2012-084514
-rw-r--r--lang/python27/files/patch-Lib-test-test_fcntl.py11
-rw-r--r--lang/python27/files/patch-Lib-test-test_ioctl.py23
-rw-r--r--lang/python27/files/patch-Lib-test-test_threading.py11
-rw-r--r--lang/python27/pkg-plist16
-rw-r--r--lang/python31/Makefile3
-rw-r--r--lang/python31/distinfo4
-rw-r--r--lang/python31/files/patch-CVE-2012-084515
-rw-r--r--lang/python32/Makefile3
-rw-r--r--lang/python32/distinfo4
-rw-r--r--lang/python32/files/patch-CVE-2012-084546
-rw-r--r--lang/python32/files/patch-Doc-library-fcntl.rst11
-rw-r--r--lang/python32/files/patch-Lib-test-test_fcntl.py11
-rw-r--r--lang/python32/files/patch-Lib-test-test_ioctl.py23
-rw-r--r--lang/python32/pkg-plist10
21 files changed, 31 insertions, 206 deletions
diff --git a/lang/python26/Makefile b/lang/python26/Makefile
index 5b5ad11f5af9..848d9bddf172 100644
--- a/lang/python26/Makefile
+++ b/lang/python26/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= python26
-PORTVERSION= 2.6.7
-PORTREVISION= 3
+PORTVERSION= 2.6.8
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
diff --git a/lang/python26/distinfo b/lang/python26/distinfo
index cf0fb61390bb..bd2548b4586f 100644
--- a/lang/python26/distinfo
+++ b/lang/python26/distinfo
@@ -1,2 +1,2 @@
-SHA256 (python/Python-2.6.7.tgz) = a8093eace4cfd3e06b05f0deb5d765e3c6cec65908048640a8cadd7a948b3826
-SIZE (python/Python-2.6.7.tgz) = 13322372
+SHA256 (python/Python-2.6.8.tgz) = 5bf02a75ffa2fcaa5a3cabb8201998519b045541975622316888ea468d9512f7
+SIZE (python/Python-2.6.8.tgz) = 13282574
diff --git a/lang/python26/files/patch-CVE-2012-0845 b/lang/python26/files/patch-CVE-2012-0845
deleted file mode 100644
index a205a7de0ea5..000000000000
--- a/lang/python26/files/patch-CVE-2012-0845
+++ /dev/null
@@ -1,14 +0,0 @@
---- Lib/SimpleXMLRPCServer.py.orig 2011-06-11 19:46:23.000000000 +0400
-+++ Lib/SimpleXMLRPCServer.py 2012-02-15 12:50:23.000000000 +0400
-@@ -486,7 +486,10 @@
- L = []
- while size_remaining:
- chunk_size = min(size_remaining, max_chunk_size)
-- L.append(self.rfile.read(chunk_size))
-+ chunk = self.rfile.read(chunk_size)
-+ if not chunk:
-+ break
-+ L.append(chunk)
- size_remaining -= len(L[-1])
- data = ''.join(L)
-
diff --git a/lang/python26/pkg-plist b/lang/python26/pkg-plist
index 1010fb68d6c1..52a6f8b49ec1 100644
--- a/lang/python26/pkg-plist
+++ b/lang/python26/pkg-plist
@@ -697,9 +697,9 @@ lib/lib%%PYTHON_VERSION%%.so.1
%%PYTHON_LIBDIR%%/json/tool.py
%%PYTHON_LIBDIR%%/keyword.py
%%PYTHON_LIBDIR%%/lib2to3/Grammar.txt
-%%PYTHON_LIBDIR%%/lib2to3/Grammar2.6.7.final.0.pickle
+%%PYTHON_LIBDIR%%/lib2to3/Grammar2.6.8.final.0.pickle
%%PYTHON_LIBDIR%%/lib2to3/PatternGrammar.txt
-%%PYTHON_LIBDIR%%/lib2to3/PatternGrammar2.6.7.final.0.pickle
+%%PYTHON_LIBDIR%%/lib2to3/PatternGrammar2.6.8.final.0.pickle
%%PYTHON_LIBDIR%%/lib2to3/__init__.py
%%PYTHON_LIBDIR%%/lib2to3/fixer_base.py
%%PYTHON_LIBDIR%%/lib2to3/fixer_util.py
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index 8e24a7fb28d0..b8003445888b 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= python27
-PORTVERSION= 2.7.2
-PORTREVISION= 4
+PORTVERSION= 2.7.3
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
diff --git a/lang/python27/distinfo b/lang/python27/distinfo
index 180f3879d2f1..7afacc30a8a2 100644
--- a/lang/python27/distinfo
+++ b/lang/python27/distinfo
@@ -1,2 +1,2 @@
-SHA256 (python/Python-2.7.2.tgz) = 1d54b7096c17902c3f40ffce7e5b84e0072d0144024184fff184a84d563abbb3
-SIZE (python/Python-2.7.2.tgz) = 14091337
+SHA256 (python/Python-2.7.3.tgz) = d4c20f2b5faf95999fd5fecb3f7d32071b0820516224a6d2b72932ab47a1cb8e
+SIZE (python/Python-2.7.3.tgz) = 14135620
diff --git a/lang/python27/files/patch-CVE-2012-0845 b/lang/python27/files/patch-CVE-2012-0845
deleted file mode 100644
index a205a7de0ea5..000000000000
--- a/lang/python27/files/patch-CVE-2012-0845
+++ /dev/null
@@ -1,14 +0,0 @@
---- Lib/SimpleXMLRPCServer.py.orig 2011-06-11 19:46:23.000000000 +0400
-+++ Lib/SimpleXMLRPCServer.py 2012-02-15 12:50:23.000000000 +0400
-@@ -486,7 +486,10 @@
- L = []
- while size_remaining:
- chunk_size = min(size_remaining, max_chunk_size)
-- L.append(self.rfile.read(chunk_size))
-+ chunk = self.rfile.read(chunk_size)
-+ if not chunk:
-+ break
-+ L.append(chunk)
- size_remaining -= len(L[-1])
- data = ''.join(L)
-
diff --git a/lang/python27/files/patch-Lib-test-test_fcntl.py b/lang/python27/files/patch-Lib-test-test_fcntl.py
deleted file mode 100644
index f8773e0aaf1c..000000000000
--- a/lang/python27/files/patch-Lib-test-test_fcntl.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- Lib/test/test_fcntl.py.orig 2010-08-14 16:56:31.290525837 +0800
-+++ Lib/test/test_fcntl.py 2010-08-14 16:56:39.007508167 +0800
-@@ -30,7 +30,7 @@
- if sys.platform in ('netbsd1', 'netbsd2', 'netbsd3',
- 'Darwin1.2', 'darwin',
- 'freebsd2', 'freebsd3', 'freebsd4', 'freebsd5',
-- 'freebsd6', 'freebsd7', 'freebsd8',
-+ 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9', 'freebsd10'
- 'bsdos2', 'bsdos3', 'bsdos4',
- 'openbsd', 'openbsd2', 'openbsd3', 'openbsd4'):
- if struct.calcsize('l') == 8:
diff --git a/lang/python27/files/patch-Lib-test-test_ioctl.py b/lang/python27/files/patch-Lib-test-test_ioctl.py
deleted file mode 100644
index 76ffe5338f9f..000000000000
--- a/lang/python27/files/patch-Lib-test-test_ioctl.py
+++ /dev/null
@@ -1,23 +0,0 @@
---- Lib/test/test_ioctl.py.orig 2010-08-14 16:20:34.137255285 +0800
-+++ Lib/test/test_ioctl.py 2010-08-14 16:36:01.013654144 +0800
-@@ -41,18 +41,9 @@
- raise unittest.SkipTest('pty module required')
- mfd, sfd = pty.openpty()
- try:
-- if termios.TIOCSWINSZ < 0:
-- set_winsz_opcode_maybe_neg = termios.TIOCSWINSZ
-- set_winsz_opcode_pos = termios.TIOCSWINSZ & 0xffffffffL
-- else:
-- set_winsz_opcode_pos = termios.TIOCSWINSZ
-- set_winsz_opcode_maybe_neg, = struct.unpack("i",
-- struct.pack("I", termios.TIOCSWINSZ))
--
-+ set_winsz_opcode = termios.TIOCSWINSZ
- our_winsz = struct.pack("HHHH",80,25,0,0)
-- # test both with a positive and potentially negative ioctl code
-- new_winsz = fcntl.ioctl(mfd, set_winsz_opcode_pos, our_winsz)
-- new_winsz = fcntl.ioctl(mfd, set_winsz_opcode_maybe_neg, our_winsz)
-+ new_winsz = fcntl.ioctl(mfd, set_winsz_opcode, our_winsz)
- finally:
- os.close(mfd)
- os.close(sfd)
diff --git a/lang/python27/files/patch-Lib-test-test_threading.py b/lang/python27/files/patch-Lib-test-test_threading.py
deleted file mode 100644
index 0f9c791c9e01..000000000000
--- a/lang/python27/files/patch-Lib-test-test_threading.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- Lib/test/test_threading.py.orig 2010-11-29 08:22:00.000000000 +0800
-+++ Lib/test/test_threading.py 2010-11-29 08:25:21.000000000 +0800
-@@ -476,7 +476,7 @@
- return
- # Skip platforms with known problems forking from a worker thread.
- # See http://bugs.python.org/issue3863.
-- if sys.platform in ('freebsd4', 'freebsd5', 'freebsd6', 'netbsd5',
-+ if sys.platform in ('freebsd6', 'freebsd7', 'freebsd8', 'freebsd9', 'freebsd10', 'netbsd5',
- 'os2emx'):
- print >>sys.stderr, ('Skipping test_3_join_in_forked_from_thread'
- ' due to known OS bugs on'), sys.platform
diff --git a/lang/python27/pkg-plist b/lang/python27/pkg-plist
index 57e698cab922..ec6e5d21fced 100644
--- a/lang/python27/pkg-plist
+++ b/lang/python27/pkg-plist
@@ -393,6 +393,7 @@ lib/lib%%PYTHON_VERSION%%.so.1
%%PYTHON_LIBDIR%%/distutils/tests/test_util.py
%%PYTHON_LIBDIR%%/distutils/tests/test_versionpredicate.py
%%PYTHON_LIBDIR%%/distutils/tests/test_version.py
+%%PYTHON_LIBDIR%%/distutils/tests/xxmodule.c
%%PYTHON_LIBDIR%%/distutils/text_file.py
%%PYTHON_LIBDIR%%/distutils/unixccompiler.py
%%PYTHON_LIBDIR%%/distutils/util.py
@@ -735,9 +736,9 @@ lib/lib%%PYTHON_VERSION%%.so.1
%%PYTHON_LIBDIR%%/json/tool.py
%%PYTHON_LIBDIR%%/keyword.py
%%PYTHON_LIBDIR%%/lib2to3/Grammar.txt
-%%PYTHON_LIBDIR%%/lib2to3/Grammar2.7.2.final.0.pickle
+%%PYTHON_LIBDIR%%/lib2to3/Grammar2.7.3.final.0.pickle
%%PYTHON_LIBDIR%%/lib2to3/PatternGrammar.txt
-%%PYTHON_LIBDIR%%/lib2to3/PatternGrammar2.7.2.final.0.pickle
+%%PYTHON_LIBDIR%%/lib2to3/PatternGrammar2.7.3.final.0.pickle
%%PYTHON_LIBDIR%%/lib2to3/__init__.py
%%PYTHON_LIBDIR%%/lib2to3/__main__.py
%%PYTHON_LIBDIR%%/lib2to3/btm_matcher.py
@@ -836,7 +837,7 @@ lib/lib%%PYTHON_VERSION%%.so.1
%%PYTHON_LIBDIR%%/lib2to3/tests/test_pytree.py
%%PYTHON_LIBDIR%%/lib2to3/tests/test_refactor.py
%%PYTHON_LIBDIR%%/lib2to3/tests/test_util.py
-%%PYTHON_LIBDIR%%/lib-dynload/Python-2.7.2-py%%PYVER%%.egg-info
+%%PYTHON_LIBDIR%%/lib-dynload/Python-2.7.3-py%%PYVER%%.egg-info
%%PYTHON_LIBDIR%%/lib-dynload/_bisect.so
%%PYTHON_LIBDIR%%/lib-dynload/_codecs_cn.so
%%PYTHON_LIBDIR%%/lib-dynload/_codecs_hk.so
@@ -1101,6 +1102,10 @@ lib/lib%%PYTHON_VERSION%%.so.1
%%PYTHON_LIBDIR%%/test/cjkencodings/gbk.txt
%%PYTHON_LIBDIR%%/test/cjkencodings/hz-utf8.txt
%%PYTHON_LIBDIR%%/test/cjkencodings/hz.txt
+%%PYTHON_LIBDIR%%/test/cjkencodings/iso2022_jp.txt
+%%PYTHON_LIBDIR%%/test/cjkencodings/iso2022_jp-utf8.txt
+%%PYTHON_LIBDIR%%/test/cjkencodings/iso2022_kr-utf8.txt
+%%PYTHON_LIBDIR%%/test/cjkencodings/iso2022_kr.txt
%%PYTHON_LIBDIR%%/test/cjkencodings/johab-utf8.txt
%%PYTHON_LIBDIR%%/test/cjkencodings/johab.txt
%%PYTHON_LIBDIR%%/test/cjkencodings/shift_jis-utf8.txt
@@ -1108,6 +1113,7 @@ lib/lib%%PYTHON_VERSION%%.so.1
%%PYTHON_LIBDIR%%/test/cjkencodings/shift_jisx0213-utf8.txt
%%PYTHON_LIBDIR%%/test/cjkencodings/shift_jisx0213.txt
%%PYTHON_LIBDIR%%/test/data/README
+%%PYTHON_LIBDIR%%/test/nokia.pem
%%PYTHON_LIBDIR%%/test/decimaltestdata/abs.decTest
%%PYTHON_LIBDIR%%/test/decimaltestdata/add.decTest
%%PYTHON_LIBDIR%%/test/decimaltestdata/and.decTest
@@ -1282,7 +1288,6 @@ lib/lib%%PYTHON_VERSION%%.so.1
%%PYTHON_LIBDIR%%/test/randv2_64.pck
%%PYTHON_LIBDIR%%/test/randv3.pck
%%PYTHON_LIBDIR%%/test/re_tests.py
-%%PYTHON_LIBDIR%%/test/regex_tests.py
%%PYTHON_LIBDIR%%/test/regrtest.py
%%PYTHON_LIBDIR%%/test/relimport.py
%%PYTHON_LIBDIR%%/test/reperf.py
@@ -1296,7 +1301,6 @@ lib/lib%%PYTHON_VERSION%%.so.1
%%PYTHON_LIBDIR%%/test/ssl_key.pem
%%PYTHON_LIBDIR%%/test/string_tests.py
%%PYTHON_LIBDIR%%/test/subprocessdata/sigchild_ignore.py
-%%PYTHON_LIBDIR%%/test/svn_python_org_https_cert.pem
%%PYTHON_LIBDIR%%/test/test_MimeWriter.py
%%PYTHON_LIBDIR%%/test/test_SimpleHTTPServer.py
%%PYTHON_LIBDIR%%/test/test_StringIO.py
@@ -1356,6 +1360,7 @@ lib/lib%%PYTHON_VERSION%%.so.1
%%PYTHON_LIBDIR%%/test/test_codecencodings_jp.py
%%PYTHON_LIBDIR%%/test/test_codecencodings_kr.py
%%PYTHON_LIBDIR%%/test/test_codecencodings_tw.py
+%%PYTHON_LIBDIR%%/test/test_codecencodings_iso2022.py
%%PYTHON_LIBDIR%%/test/test_codecmaps_cn.py
%%PYTHON_LIBDIR%%/test/test_codecmaps_hk.py
%%PYTHON_LIBDIR%%/test/test_codecmaps_jp.py
@@ -1566,6 +1571,7 @@ lib/lib%%PYTHON_VERSION%%.so.1
%%PYTHON_LIBDIR%%/test/test_pty.py
%%PYTHON_LIBDIR%%/test/test_pwd.py
%%PYTHON_LIBDIR%%/test/test_py3kwarn.py
+%%PYTHON_LIBDIR%%/test/test_py_compile.py
%%PYTHON_LIBDIR%%/test/test_pyclbr.py
%%PYTHON_LIBDIR%%/test/test_pydoc.py
%%PYTHON_LIBDIR%%/test/test_pyexpat.py
diff --git a/lang/python31/Makefile b/lang/python31/Makefile
index 22935d91857c..a8c4e054d3bf 100644
--- a/lang/python31/Makefile
+++ b/lang/python31/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= python31
-PORTVERSION= 3.1.4
-PORTREVISION= 3
+PORTVERSION= 3.1.5
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
diff --git a/lang/python31/distinfo b/lang/python31/distinfo
index dcad946de55d..50c26d2f7310 100644
--- a/lang/python31/distinfo
+++ b/lang/python31/distinfo
@@ -1,2 +1,2 @@
-SHA256 (python/Python-3.1.4.tgz) = fadc05ea6d05360cff189944a85ecd2180bbc308784d168b350450e70bbdd846
-SIZE (python/Python-3.1.4.tgz) = 11795512
+SHA256 (python/Python-3.1.5.tgz) = d12dae6d06f52ef6bf1271db4d5b4d14b5dd39813e324314e72b648ef1bc0103
+SIZE (python/Python-3.1.5.tgz) = 11798798
diff --git a/lang/python31/files/patch-CVE-2012-0845 b/lang/python31/files/patch-CVE-2012-0845
deleted file mode 100644
index 9a381c22e345..000000000000
--- a/lang/python31/files/patch-CVE-2012-0845
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/Lib/xmlrpc/server.py b/Lib/xmlrpc/server.py
---- Lib/xmlrpc/server.py
-+++ Lib/xmlrpc/server.py
-@@ -476,7 +476,10 @@
- L = []
- while size_remaining:
- chunk_size = min(size_remaining, max_chunk_size)
-- L.append(self.rfile.read(chunk_size))
-+ chunk = self.rfile.read(chunk_size)
-+ if not chunk:
-+ break
-+ L.append(chunk)
- size_remaining -= len(L[-1])
- data = b''.join(L)
-
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index 32ed1a2e65f6..43fd6192a65c 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= python32
-PORTVERSION= 3.2.2
-PORTREVISION= 3
+PORTVERSION= 3.2.3
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
diff --git a/lang/python32/distinfo b/lang/python32/distinfo
index 16a63a03cdf5..a65cb59f4ed8 100644
--- a/lang/python32/distinfo
+++ b/lang/python32/distinfo
@@ -1,2 +1,2 @@
-SHA256 (python/Python-3.2.2.tgz) = acc6a13cb4fed0b7e86716324a8437e326645b8076177eede5a0cad99ec0313c
-SIZE (python/Python-3.2.2.tgz) = 12732276
+SHA256 (python/Python-3.2.3.tgz) = 74c33e165edef7532cef95fd9a325a06878b5bfc8a5d038161573f283eaf9809
+SIZE (python/Python-3.2.3.tgz) = 12787688
diff --git a/lang/python32/files/patch-CVE-2012-0845 b/lang/python32/files/patch-CVE-2012-0845
deleted file mode 100644
index e30dbe1e4532..000000000000
--- a/lang/python32/files/patch-CVE-2012-0845
+++ /dev/null
@@ -1,46 +0,0 @@
-diff --git a/Lib/test/test_xmlrpc.py b/Lib/test/test_xmlrpc.py
---- Lib/test/test_xmlrpc.py
-+++ Lib/test/test_xmlrpc.py
-@@ -519,12 +519,7 @@
-
- def tearDown(self):
- # wait on the server thread to terminate
-- self.evt.wait(4.0)
-- # XXX this code does not work, and in fact stop_serving doesn't exist.
-- if not self.evt.is_set():
-- self.evt.set()
-- stop_serving()
-- raise RuntimeError("timeout reached, test has failed")
-+ self.evt.wait()
-
- # disable traceback reporting
- xmlrpc.server.SimpleXMLRPCServer._send_traceback_header = False
-@@ -671,6 +666,13 @@
- server = xmlrpclib.ServerProxy("http://%s:%d/RPC2" % (ADDR, PORT))
- self.assertEqual(server.add("a", "\xe9"), "a\xe9")
-
-+ def test_partial_post(self):
-+ # Check that a partial POST doesn't make the server loop: issue #14001.
-+ conn = http.client.HTTPConnection(ADDR, PORT)
-+ conn.request('POST', '/RPC2 HTTP/1.0\r\nContent-Length: 100\r\n\r\nbye')
-+ conn.close()
-+
-+
- class MultiPathServerTestCase(BaseServerTestCase):
- threadFunc = staticmethod(http_multi_server)
- request_count = 2
-diff --git a/Lib/xmlrpc/server.py b/Lib/xmlrpc/server.py
---- Lib/xmlrpc/server.py
-+++ Lib/xmlrpc/server.py
-@@ -476,7 +476,10 @@
- L = []
- while size_remaining:
- chunk_size = min(size_remaining, max_chunk_size)
-- L.append(self.rfile.read(chunk_size))
-+ chunk = self.rfile.read(chunk_size)
-+ if not chunk:
-+ break
-+ L.append(chunk)
- size_remaining -= len(L[-1])
- data = b''.join(L)
-
diff --git a/lang/python32/files/patch-Doc-library-fcntl.rst b/lang/python32/files/patch-Doc-library-fcntl.rst
deleted file mode 100644
index 46c072e1c062..000000000000
--- a/lang/python32/files/patch-Doc-library-fcntl.rst
+++ /dev/null
@@ -1,11 +0,0 @@
---- Doc/library/fcntl.rst.orig 2009-06-08 09:41:29.000000000 -0400
-+++ Doc/library/fcntl.rst 2010-06-24 22:31:02.000000000 -0400
-@@ -48,8 +48,6 @@
- This function is identical to the :func:`fcntl` function, except that the
- argument handling is even more complicated.
-
-- The op parameter is limited to values that can fit in 32-bits.
--
- The parameter *arg* can be one of an integer, absent (treated identically to the
- integer ``0``), an object supporting the read-only buffer interface (most likely
- a plain Python string) or an object supporting the read-write buffer interface.
diff --git a/lang/python32/files/patch-Lib-test-test_fcntl.py b/lang/python32/files/patch-Lib-test-test_fcntl.py
deleted file mode 100644
index bc3987953d67..000000000000
--- a/lang/python32/files/patch-Lib-test-test_fcntl.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- Lib/test/test_fcntl.py.orig 2009-05-24 11:46:13.000000000 -0400
-+++ Lib/test/test_fcntl.py 2010-06-24 13:56:52.000000000 -0400
-@@ -29,7 +29,7 @@
- if sys.platform in ('netbsd1', 'netbsd2', 'netbsd3',
- 'Darwin1.2', 'darwin',
- 'freebsd2', 'freebsd3', 'freebsd4', 'freebsd5',
-- 'freebsd6', 'freebsd7', 'freebsd8',
-+ 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9', 'freebsd10'
- 'bsdos2', 'bsdos3', 'bsdos4',
- 'openbsd', 'openbsd2', 'openbsd3', 'openbsd4'):
- if struct.calcsize('l') == 8:
diff --git a/lang/python32/files/patch-Lib-test-test_ioctl.py b/lang/python32/files/patch-Lib-test-test_ioctl.py
deleted file mode 100644
index 2488bc755583..000000000000
--- a/lang/python32/files/patch-Lib-test-test_ioctl.py
+++ /dev/null
@@ -1,23 +0,0 @@
---- Lib/test/test_ioctl.py.orig 2009-08-13 04:51:18.000000000 -0400
-+++ Lib/test/test_ioctl.py 2010-06-24 13:35:29.000000000 -0400
-@@ -41,18 +41,9 @@ class IoctlTests(unittest.TestCase):
- raise unittest.SkipTest('pty module required')
- mfd, sfd = pty.openpty()
- try:
-- if termios.TIOCSWINSZ < 0:
-- set_winsz_opcode_maybe_neg = termios.TIOCSWINSZ
-- set_winsz_opcode_pos = termios.TIOCSWINSZ & 0xffffffff
-- else:
-- set_winsz_opcode_pos = termios.TIOCSWINSZ
-- set_winsz_opcode_maybe_neg, = struct.unpack("i",
-- struct.pack("I", termios.TIOCSWINSZ))
--
-+ set_winsz_opcode = termios.TIOCSWINSZ
- our_winsz = struct.pack("HHHH",80,25,0,0)
-- # test both with a positive and potentially negative ioctl code
-- new_winsz = fcntl.ioctl(mfd, set_winsz_opcode_pos, our_winsz)
-- new_winsz = fcntl.ioctl(mfd, set_winsz_opcode_maybe_neg, our_winsz)
-+ new_winsz = fcntl.ioctl(mfd, set_winsz_opcode, our_winsz)
- finally:
- os.close(mfd)
- os.close(sfd)
diff --git a/lang/python32/pkg-plist b/lang/python32/pkg-plist
index abc07b2d9f86..2860760b13e1 100644
--- a/lang/python32/pkg-plist
+++ b/lang/python32/pkg-plist
@@ -18,6 +18,7 @@ lib/lib%%PYTHON_VERSION%%%%PYABIVER%%.a
lib/lib%%PYTHON_VERSION%%%%PYABIVER%%.so
lib/lib%%PYTHON_VERSION%%%%PYABIVER%%.so.1
libdata/pkgconfig/python-3.2.pc
+%%PYTHON_INCLUDEDIR%%%%PYABIVER%%/accu.h
%%PYTHON_INCLUDEDIR%%%%PYABIVER%%/Python-ast.h
%%PYTHON_INCLUDEDIR%%%%PYABIVER%%/Python.h
%%PYTHON_INCLUDEDIR%%%%PYABIVER%%/abstract.h
@@ -2434,8 +2435,6 @@ libdata/pkgconfig/python-3.2.pc
%%PYTHON_LIBDIR%%/test/__pycache__/pystone.cpython-32.pyo
%%PYTHON_LIBDIR%%/test/__pycache__/re_tests.cpython-32.pyc
%%PYTHON_LIBDIR%%/test/__pycache__/re_tests.cpython-32.pyo
-%%PYTHON_LIBDIR%%/test/__pycache__/regex_tests.cpython-32.pyc
-%%PYTHON_LIBDIR%%/test/__pycache__/regex_tests.cpython-32.pyo
%%PYTHON_LIBDIR%%/test/__pycache__/regrtest.cpython-32.pyc
%%PYTHON_LIBDIR%%/test/__pycache__/regrtest.cpython-32.pyo
%%PYTHON_LIBDIR%%/test/__pycache__/relimport.cpython-32.pyc
@@ -2916,6 +2915,8 @@ libdata/pkgconfig/python-3.2.pc
%%PYTHON_LIBDIR%%/test/__pycache__/test_property.cpython-32.pyo
%%PYTHON_LIBDIR%%/test/__pycache__/test_pstats.cpython-32.pyc
%%PYTHON_LIBDIR%%/test/__pycache__/test_pstats.cpython-32.pyo
+%%PYTHON_LIBDIR%%/test/__pycache__/test_py_compile.cpython-32.pyo
+%%PYTHON_LIBDIR%%/test/__pycache__/test_py_compile.cpython-32.pyc
%%PYTHON_LIBDIR%%/test/__pycache__/test_pty.cpython-32.pyc
%%PYTHON_LIBDIR%%/test/__pycache__/test_pty.cpython-32.pyo
%%PYTHON_LIBDIR%%/test/__pycache__/test_pwd.cpython-32.pyc
@@ -3470,7 +3471,6 @@ libdata/pkgconfig/python-3.2.pc
%%PYTHON_LIBDIR%%/test/randv2_64.pck
%%PYTHON_LIBDIR%%/test/randv3.pck
%%PYTHON_LIBDIR%%/test/re_tests.py
-%%PYTHON_LIBDIR%%/test/regex_tests.py
%%PYTHON_LIBDIR%%/test/regrtest.py
%%PYTHON_LIBDIR%%/test/relimport.py
%%PYTHON_LIBDIR%%/test/reperf.py
@@ -3500,7 +3500,9 @@ libdata/pkgconfig/python-3.2.pc
%%PYTHON_LIBDIR%%/test/subprocessdata/qgrep.py
%%PYTHON_LIBDIR%%/test/subprocessdata/sigchild_ignore.py
%%PYTHON_LIBDIR%%/test/support.py
-%%PYTHON_LIBDIR%%/test/svn_python_org_https_cert.pem
+%%PYTHON_LIBDIR%%/test/mime.types
+%%PYTHON_LIBDIR%%/test/test_py_compile.py
+%%PYTHON_LIBDIR%%/test/nokia.pem
%%PYTHON_LIBDIR%%/test/test___all__.py
%%PYTHON_LIBDIR%%/test/test___future__.py
%%PYTHON_LIBDIR%%/test/test__locale.py