aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorbf <bf@FreeBSD.org>2012-01-21 01:26:00 +0800
committerbf <bf@FreeBSD.org>2012-01-21 01:26:00 +0800
commit851f0ed7aa91bc8f2b2a32f0e3d547361fbc69d4 (patch)
tree253badf34e61e9d3feb7759deacc2c86653220ba /lang
parent680e9490a2fbea098bfbe0ed0bbc08f3fe74f79c (diff)
downloadfreebsd-ports-gnome-851f0ed7aa91bc8f2b2a32f0e3d547361fbc69d4.tar.gz
freebsd-ports-gnome-851f0ed7aa91bc8f2b2a32f0e3d547361fbc69d4.tar.zst
freebsd-ports-gnome-851f0ed7aa91bc8f2b2a32f0e3d547361fbc69d4.zip
The compiler flags contain '/', so use a different delimiter
with sed; set USE_FORTRAN; remove some unused variables
Diffstat (limited to 'lang')
-rw-r--r--lang/p5-ExtUtils-F77/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/lang/p5-ExtUtils-F77/Makefile b/lang/p5-ExtUtils-F77/Makefile
index 9b15ad343cab..e96591ba3307 100644
--- a/lang/p5-ExtUtils-F77/Makefile
+++ b/lang/p5-ExtUtils-F77/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ExtUtils-F77
PORTVERSION= 1.17
+PORTREVISION= 1
CATEGORIES= lang perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -15,15 +16,13 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Helps link C programs with Fortran subroutines
PERL_CONFIGURE= yes
+USE_FORTRAN= yes
MAN3= ExtUtils::F77.3
-GCCLIBDIR_CMDS= ${FC} -print-file-name=libgfortran.so | ${SED} -e s/libgfortran.so//
-F2CLIB= -lgfortran
-
post-patch:
- @${REINPLACE_CMD} -e "s/'gfortran44'/'${FC}'/" \
- -e "s/'-O2'/'${CFLAGS}'/" \
+ @${REINPLACE_CMD} -e "s|'gfortran44'|'${FC}'|" \
+ -e "s|'-O2'|'${CFLAGS}'|" \
${WRKSRC}/F77.pm
.include <bsd.port.mk>