aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-09-17 17:34:36 +0800
committerbapt <bapt@FreeBSD.org>2013-09-17 17:34:36 +0800
commit8a2d63031a099b9ea52853efc1371c54d2830546 (patch)
tree563d439844258b24e903ebc7b8c67ace406d292b /lang
parent725a612e719cce8b875cf136e22dd3a380ac9947 (diff)
downloadfreebsd-ports-gnome-8a2d63031a099b9ea52853efc1371c54d2830546.tar.gz
freebsd-ports-gnome-8a2d63031a099b9ea52853efc1371c54d2830546.tar.zst
freebsd-ports-gnome-8a2d63031a099b9ea52853efc1371c54d2830546.zip
Convert to new perl framework
Diffstat (limited to 'lang')
-rw-r--r--lang/erlang-runtime16/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/lang/erlang-runtime16/Makefile b/lang/erlang-runtime16/Makefile
index cfeacc427133..fc18e188b6a3 100644
--- a/lang/erlang-runtime16/Makefile
+++ b/lang/erlang-runtime16/Makefile
@@ -52,6 +52,10 @@ OPTIONS_DEFAULT=SMP OPENSSL THREADS SCTP KQUEUE
ERL_RELEASE= R${PORTVERSION:S/.//g:U}
+USES= gmake perl5
+USE_CSTD= gnu89
+GNU_CONFIGURE= yes
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
@@ -118,11 +122,6 @@ WX_UNICODE= yes
CONFIGURE_ARGS+=--with-wx-config=${WX_CONFIG}
.endif
-USE_GMAKE= yes
-USE_CSTD= gnu89
-USE_PERL5= yes
-GNU_CONFIGURE= yes
-
.if ${PORT_OPTIONS:MODBC}
CONFIGURE_ARGS+=--with-odbc
.if ${PORT_OPTIONS:MUNIXODBC}