aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2003-06-27 06:58:32 +0800
committerade <ade@FreeBSD.org>2003-06-27 06:58:32 +0800
commit9487d820b3247d8654d99544f8144188dcec810a (patch)
tree740462af7ed8e371913ea7f6b12533a99dd524ac /lang
parentdfe03c1be7cf9f1612091e1e697a7e74f7002416 (diff)
downloadfreebsd-ports-gnome-9487d820b3247d8654d99544f8144188dcec810a.tar.gz
freebsd-ports-gnome-9487d820b3247d8654d99544f8144188dcec810a.tar.zst
freebsd-ports-gnome-9487d820b3247d8654d99544f8144188dcec810a.zip
libtool uber-patch
* kill devel/libtool and move to devel/libtool13, upgrading to 1.3.5 * upgrade repo-copied devel/libtool14 to 1.4.3 * break out libltdl into its own separate port * move to version-numbered binaries/scripts (ie: there is *no* 'libtool' any more -- USE_LIBTOOL and USE_LIBTOOL_VER are your friends) Approved by: portmgr (kris) - for the bsd.port.mk hooks Tested by: bento 4-exp builds (repeatedly)
Diffstat (limited to 'lang')
-rw-r--r--lang/dylan/Makefile1
-rw-r--r--lang/guile/Makefile4
-rw-r--r--lang/open-cobol-devel/Makefile2
-rw-r--r--lang/open-cobol/Makefile2
-rw-r--r--lang/php4/bsd.php.mk2
-rw-r--r--lang/php5/bsd.php.mk2
-rw-r--r--lang/php53/bsd.php.mk2
7 files changed, 7 insertions, 8 deletions
diff --git a/lang/dylan/Makefile b/lang/dylan/Makefile
index a5816a9f2399..a0d8b5545b8b 100644
--- a/lang/dylan/Makefile
+++ b/lang/dylan/Makefile
@@ -28,7 +28,6 @@ MAINTAINER= housel@acm.org
COMMENT= CMU Gwydion project interpreter and compiler for the Dylan language
LIB_DEPENDS= gc.1:${PORTSDIR}/devel/boehm-gc
-RUN_DEPENDS= libtool:${PORTSDIR}/devel/libtool
USE_PERL5= yes
USE_GMAKE= yes
diff --git a/lang/guile/Makefile b/lang/guile/Makefile
index 39d3ea8f76d3..282c00e60fd9 100644
--- a/lang/guile/Makefile
+++ b/lang/guile/Makefile
@@ -7,7 +7,7 @@
PORTNAME= guile
PORTVERSION= 1.6.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= guile
@@ -15,7 +15,7 @@ MASTER_SITE_SUBDIR= guile
MAINTAINER= gnome@FreeBSD.org
COMMENT= GNU Ubiquitous Intelligent Language for Extension
-LIB_DEPENDS= ltdl.1:${PORTSDIR}/devel/libtool
+LIB_DEPENDS= ltdl.4:${PORTSDIR}/devel/libltdl
USE_REINPLACE= yes
USE_GMAKE= yes
diff --git a/lang/open-cobol-devel/Makefile b/lang/open-cobol-devel/Makefile
index 39f81d001e96..d05cf4605a41 100644
--- a/lang/open-cobol-devel/Makefile
+++ b/lang/open-cobol-devel/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= An open-source COBOL compiler
LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext \
- ltdl.1:${PORTSDIR}/devel/libtool \
+ ltdl.4:${PORTSDIR}/devel/libltdl \
gmp.6:${PORTSDIR}/math/libgmp4
GNU_CONFIGURE= yes
diff --git a/lang/open-cobol/Makefile b/lang/open-cobol/Makefile
index 39f81d001e96..d05cf4605a41 100644
--- a/lang/open-cobol/Makefile
+++ b/lang/open-cobol/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= An open-source COBOL compiler
LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext \
- ltdl.1:${PORTSDIR}/devel/libtool \
+ ltdl.4:${PORTSDIR}/devel/libltdl \
gmp.6:${PORTSDIR}/math/libgmp4
GNU_CONFIGURE= yes
diff --git a/lang/php4/bsd.php.mk b/lang/php4/bsd.php.mk
index 9a3c5c13acd2..f315c3c4d1fb 100644
--- a/lang/php4/bsd.php.mk
+++ b/lang/php4/bsd.php.mk
@@ -87,5 +87,5 @@ configure-message: phpize
phpize:
@${ECHO_MSG} "===> PHPizing for ${DISTNAME}"
- @(cd ${WRKSRC}; phpize)
+ @(cd ${WRKSRC}; ${SETENV} ${SCRIPTS_ENV} ${LOCALBASE}/bin/phpize)
.endif
diff --git a/lang/php5/bsd.php.mk b/lang/php5/bsd.php.mk
index 9a3c5c13acd2..f315c3c4d1fb 100644
--- a/lang/php5/bsd.php.mk
+++ b/lang/php5/bsd.php.mk
@@ -87,5 +87,5 @@ configure-message: phpize
phpize:
@${ECHO_MSG} "===> PHPizing for ${DISTNAME}"
- @(cd ${WRKSRC}; phpize)
+ @(cd ${WRKSRC}; ${SETENV} ${SCRIPTS_ENV} ${LOCALBASE}/bin/phpize)
.endif
diff --git a/lang/php53/bsd.php.mk b/lang/php53/bsd.php.mk
index 9a3c5c13acd2..f315c3c4d1fb 100644
--- a/lang/php53/bsd.php.mk
+++ b/lang/php53/bsd.php.mk
@@ -87,5 +87,5 @@ configure-message: phpize
phpize:
@${ECHO_MSG} "===> PHPizing for ${DISTNAME}"
- @(cd ${WRKSRC}; phpize)
+ @(cd ${WRKSRC}; ${SETENV} ${SCRIPTS_ENV} ${LOCALBASE}/bin/phpize)
.endif