aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2013-09-08 02:21:14 +0800
committertijl <tijl@FreeBSD.org>2013-09-08 02:21:14 +0800
commit983dae1e2d66c1669452cefc14281a80858bd2bf (patch)
treea9f18cb2b4e15a31406b6cff278f8e104a47f001 /lang
parentc8dd0801c79daa794caf2e13894534576260ea57 (diff)
downloadfreebsd-ports-gnome-983dae1e2d66c1669452cefc14281a80858bd2bf.tar.gz
freebsd-ports-gnome-983dae1e2d66c1669452cefc14281a80858bd2bf.tar.zst
freebsd-ports-gnome-983dae1e2d66c1669452cefc14281a80858bd2bf.zip
Conflict with sdcc-devel and simplify options handling.
Diffstat (limited to 'lang')
-rw-r--r--lang/sdcc/Makefile62
-rw-r--r--lang/sdcc/pkg-plist26
2 files changed, 43 insertions, 45 deletions
diff --git a/lang/sdcc/Makefile b/lang/sdcc/Makefile
index c35c0639d05c..29aed3eb7c0d 100644
--- a/lang/sdcc/Makefile
+++ b/lang/sdcc/Makefile
@@ -2,6 +2,7 @@
PORTNAME= sdcc
PORTVERSION= 3.3.0
+PORTREVISION= 1
DISTVERSIONPREFIX= src-
CATEGORIES= lang
MASTER_SITES= SF
@@ -13,10 +14,10 @@ LICENSE= GPLv3
BUILD_DEPENDS= ${LOCALBASE}/include/boost/graph/adjacency_list.hpp:${PORTSDIR}/devel/boost-libs
-CONFLICTS_INSTALL= sdcc-[0-9]*
+CONFLICTS_INSTALL= sdcc-[0-9]* sdcc-devel-[0-9]*
GNU_CONFIGURE= yes
+USES= gmake
USE_BZIP2= yes
-USE_GMAKE= yes
OPTIONS_DEFINE= DEVLIB DOCS UCSIM
OPTIONS_MULTI= TARGETS
@@ -33,59 +34,30 @@ CPPFLAGS+= -idirafter ${LOCALBASE}/include
CONFIGURE_ARGS= --disable-avr --disable-install-libbfd --disable-werror \
--enable-new-pics docdir=${DOCSDIR}
CONFIGURE_ENV= ARCH=""
-PLIST_FILES= bin/as2gbmap bin/makebin bin/packihx bin/sdar bin/sdcc \
- bin/sdcclib bin/sdcpp bin/sdld bin/sdld6808 bin/sdldgb \
- bin/sdldz80 bin/sdnm bin/sdobjcopy bin/sdranlib
PORTDATA= *
PORTDOCS= *
WRKSRC= ${WRKDIR}/sdcc-${DISTVERSION}
+OPTIONS_SUB= yes
+DEVLIB_CONFIGURE_OFF= --disable-device-lib
+HC08_CONFIGURE_OFF= --disable-hc08 --disable-hc08-port \
+ --disable-s08-port
+MCS51_CONFIGURE_OFF= --disable-51 --disable-mcs51-port \
+ --disable-ds390-port --disable-ds400-port
+PIC_BUILD_DEPENDS= gputils>=1.0.0:${PORTSDIR}/devel/gputils
+PIC_RUN_DEPENDS= gpasm:${PORTSDIR}/devel/gputils
+PIC_CONFIGURE_OFF= --disable-pic14-port --disable-pic16-port
+UCSIM_CONFIGURE_OFF= --disable-ucsim
+Z80_CONFIGURE_OFF= --disable-z80 --disable-z80-port \
+ --disable-z180-port --disable-gbz80-port \
+ --disable-r2k-port --disable-r3ka-port
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64"
CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
.endif
-.if empty(PORT_OPTIONS:MDEVLIB)
-CONFIGURE_ARGS+=--disable-device-lib
-.endif
-
-.if ${PORT_OPTIONS:MHC08}
-PLIST_FILES+= bin/sdas6808 %%UCSIM%%bin/shc08
-.else
-CONFIGURE_ARGS+=--disable-hc08 --disable-hc08-port --disable-s08-port
-.endif
-
-.if ${PORT_OPTIONS:MMCS51}
-PLIST_FILES+= bin/sdas390 bin/sdas8051 %%UCSIM%%bin/s51 \
- %%UCSIM%%bin/sdcdb %%UCSIM%%bin/sdcdb.el \
- %%UCSIM%%bin/sdcdbsrc.el
-.else
-CONFIGURE_ARGS+=--disable-51 --disable-mcs51-port \
- --disable-ds390-port --disable-ds400-port
-.endif
-
-.if ${PORT_OPTIONS:MPIC}
-BUILD_DEPENDS+= gputils>=1.0.0:${PORTSDIR}/devel/gputils
-RUN_DEPENDS+= gpasm:${PORTSDIR}/devel/gputils
-.else
-CONFIGURE_ARGS+=--disable-pic14-port --disable-pic16-port
-.endif
-
-.if ${PORT_OPTIONS:MUCSIM}
-PLIST_SUB+= UCSIM=""
-.else
-CONFIGURE_ARGS+=--disable-ucsim
-PLIST_SUB+= UCSIM="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MZ80}
-PLIST_FILES+= bin/sdasgb bin/sdasrab bin/sdasz80 %%UCSIM%%bin/sz80
-.else
-CONFIGURE_ARGS+=--disable-z80 --disable-z80-port --disable-z180-port \
- --disable-gbz80-port --disable-r2k-port --disable-r3ka-port
-.endif
-
post-patch:
@${REINPLACE_CMD} '/install:/s/:.*/:/' \
${WRKSRC}/Makefile.in \
diff --git a/lang/sdcc/pkg-plist b/lang/sdcc/pkg-plist
new file mode 100644
index 000000000000..c21a61787ef3
--- /dev/null
+++ b/lang/sdcc/pkg-plist
@@ -0,0 +1,26 @@
+bin/as2gbmap
+bin/makebin
+bin/packihx
+%%UCSIM%%%%MCS51%%bin/s51
+bin/sdar
+%%MCS51%%bin/sdas390
+%%HC08%%bin/sdas6808
+%%MCS51%%bin/sdas8051
+%%Z80%%bin/sdasgb
+%%Z80%%bin/sdasrab
+%%Z80%%bin/sdasz80
+bin/sdcc
+bin/sdcclib
+%%UCSIM%%%%MCS51%%bin/sdcdb
+%%UCSIM%%%%MCS51%%bin/sdcdb.el
+%%UCSIM%%%%MCS51%%bin/sdcdbsrc.el
+bin/sdcpp
+bin/sdld
+bin/sdld6808
+bin/sdldgb
+bin/sdldz80
+bin/sdnm
+bin/sdobjcopy
+bin/sdranlib
+%%UCSIM%%%%HC08%%bin/shc08
+%%UCSIM%%%%Z80%%bin/sz80